Skip to content
main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

Why has vodafone disabled so many features in Wifi calling?

2: Seeker

Anyone got any idea why Vodafone decided to take a useful phone feature and make it useless.

 

I am having a problems with wifi calling on my s7 edge.

The reception is flaky in my house. Good enough for the phone to see the network but not good enough to make a good call.
The only way to guarntee the wifi calling stays connected is to go into airplane mode at which point I cannot send or recieve texts.

 

Tried tech support but they are pretty useless and keep wanting me to re-connect to the mobile network and restart my phone rather than answering my question.

View more options
4 REPLIES
17: Community Champion

Hi

 

Unfortunately I'm unable to try the feature on my s7 edge as I'm payg. 

 

Any feedback left in posts here are fed back. 

 

I've not seen any recent posts also highlighting similar issues. 

 

Could it be the phone , sim card or WiFi connection between phone and source?

IMG_1084.JPG

View more options
17: Community Champion

Hi @nervousfrog

 

The way WiFi calling works is to enable you to make and receive calls when the signal is poor or non existant.

 

If you have signal available in your home, although minimal, and the phone can see the network, as far as WiFi calling is concerned, you already have a mobile phone signal.

 

At least by putting the phone on offline mode, you have found a workaround to enable you to make calls over WiFi.

 

If you check out the support pages, there is further help and support for WiFi calling.

View more options
2: Seeker

Which is fine except then I can't then send/recieve text messages.

 

The default wifi calling software from Android enables you to set wifi as prefered for calling Vodafone appear to have disabled this option.

 

So if wifi is available it uses wifi.

View more options
Moderator

@nervousfrog

 

I've sent you a private message with details on how to get in touch so we can look into this further for you.

 

For anyone else with the same issue, please contact customer service.

View more options