Skip to content
main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

Wifi Calling gone in 7.0 S7?

3: Seeker Silver

Thanks for the tip @mark_baguley, all working again for me.Smiley Happy

View more options
3: Seeker Silver

@sonic_1 is it works for You on Android 7.0 XEU?

View more options
3: Seeker Silver

@ iMoCks Yes it is working on the 7.0 XEU, I follewd the instruction as posted above but left it a little longer the 24 hours. Then access the phone setiings by pressing Phone > numeric keypad > access the settings in the top right hand corner and now wifi calling has come back as an option.

View more options
3: Seeker Silver

Thanks for the updates.  This is good news @Sonic and @ iMoCks.  Has anyone tried this workaround with the 7.0 BTU?

View more options
3: Seeker Silver

Nice. I disabled wifi calling on my account for over 24 hours and then i enabled it back, yesterday about 6pm and nothing change. Still have no wifi calling option on my XEU 7.0   Smiley Sad

View more options
3: Seeker Silver

Just wanted to add my experiences with Wifi Calling on an unbranded S7 Edge. Firstly when I purchased my Vodafone S7 Edge from carphone warehouse I wasn't aware that there was any difference between doing this and getting one direct from Vodafone and all the features that were listed on carphone warehouse’s website for the phone I expected to get on mine, including wifi calling. So I was pretty surprised when I first went to try and use wifi calling in my house, which had a very poor signal and it wouldn't work.

 

I came on here and explained my issue and was basically greeted with a load of sanctimonious posts with people saying the same guff as on this thread, how vodafone CLEARLY makes it known that wifi calling only works on phones bought directly from them, this is of course nonsense.

 

In the end after a few calls to vodafone and me being persistant an American vodafone employee suggested that there was a way for him to send me the network settings that would enable wifi calling, which he kindly did. So I know 100% that it is Vodafone withholding the feature and not Android or Samsung as some of the overly pretentious posters on here were suggesting the issue was with.


Unfortunately since the Nougat update I've lost wifi calling but I'll give the guide on here a go to get it back. Thanks to the poster who provided it!

 

 

View more options
17: Community Champion
Of course it's Vodafone withholding the feature. That's never been denied by anyone. Your anger should be directed at Carphone Warehouse for you are their customer and if they are telling their customers that Wi Fi calling is available on phones bought from them they are lying.

View more options
3: Seeker Silver

No, I had never heard of wifi calling until I had a text message from Vodafone informing me of this great new feature.

 

The problem lies firmley at the feet of Vodafone.

Don't shirk away from your responsability, its a Vodafone problem.

 

View more options
17: Community Champion
I have many responsibilities but, as a fellow customer, I'm delighted to say that Vodafone isn't one of them.

View more options
3: Seeker Silver

My wifi calling is back on again, thanks alot mark_baguley!

 

 

View more options
Highlighted
3: Seeker Silver

Ok. I had some issue on my account and my online account do not let me enable or disable WiFi calling. 
I spoke with adviser right now and everything was fixed. 
I can confirm - Android 7.0 XEU (Carphone Warehouse UK) - WiFi Calling is working.
Will try to flash BTU at night and check if it works also. If yes i will stay on BTU as it is getting updates earlier than XEU. Smiley Happy

View more options
3: Seeker Silver

Hi iMoCks.  Did you manage to flash BTU and did wifi calling work with this?

View more options
1: Seeker

like many who skip to the end of a forum to see if there's an answer (thats me) vodafone has just been sloppy updating the information on their site to reflect the changes on android noughat 7.0

 

I'm sure someone posted the explanation so kudos to them but for people like me that were using this feature because of the atrocious signal inside my house heres the simple way to get it back in 5 steps.

1. tap the green phone icon thats been on android forever

2. at the top right you'll see 3 dots stacked : (missing one) press the top right of the screen on the 3 dots

3. select settings from this drop down menu.

4.swipe down till you see wifi calling

5. slide tab to on

 

vodafone pay monthly customer android 7.0 pushed on me yesterday

View more options
1: Seeker

try my method, same sitch as you crap signal etc.

go into your apps, select the green phone icon, click top right on 3 dots, select settings, swipe down till you see wifi calling and tap it on.

I swear its moved from where it was previous, and while most of my apps and settings returned to how they were , wifi calling was switched off.

hope this helps mate.

View more options
3: Seeker Silver

@milestone

no, but tomorrow i'll get brand new Galaxy S7 Edge with preinstalled BTU and will try to get WiFi Calling. PM me to remind to give you any info. Sometimes You have to call to customer service and force them to activate it via technical team. That what i have to do to get WiFi Calling on XEU.

View more options
3: Seeker Silver

@milestone i can confirm that WiFi calling is working on Android 7 BTU

I just need to make call to customer service and adviser was talking with technician team and they have to restart that option in their system, after that i didn't receive any confirmation message but found option in phone settings. Enable it and wifi calling is fully working. 

View more options
3: Seeker Silver

Hi @iMocks

I have now taken the 7.0 btu (non-vodafone) update and can report that wifi calling IS working.

Here's what worked for me:

  1. Logged in to Myvodafone account to set wifi calling to "on" but was told that I could not enter the feature because I was not elegible.
  2. Rang Vodafone tech to reset my wifi calling.
  3. In parallel sent text to 97888 with the message "calling"
  4. Immediately received an automated responder saying that wifi calling had been activated on my account (even though this was not reflected on the website at the time, but 24 hours later was shown as "on")

I cannot say whether the text message did it or whether it was the Vodafone tech doing a reset, but the key thing is that wifi calling is now working with a non-vodafone rom (the Samsung plain vanilla version 6.01 which I downloaded /flashed, and then allowed it to take the 7.0 update).

 

My take on all of this is that Vodafone are not withholding any features but they do have a silly glitch in their system which requires the wifi calling feature to be reset when upgrading to 7.0.  They could also have been more transparent and proactive in providing us with information about this workaround.

 

View more options
1: Seeker

My wi-fi calling disappeared when I upgraded android to 7.0. I got it back by doing the following. 

 

Switched it off overnight in my Vodafone account.

 

When I reactivated it I found the place in my phone settings (not obvious) where it could be turned on.

Settings

Applications

Select the 3 dots in top right hand corner

Show system apps

Phone (first of 3 entries)

More settings

Scroll down to WI-FI CALLING

select on

 

This worked for me and I now have wi-fi calling again on a phone not purchased directly from Vodafone 

 

View more options
3: Seeker Silver

Thanks NMC58!

 

I can confirm the procedure above also worked for me on a Carphone Warehouse supplied S7 running Nougat (some threads were suggesting wi-fi calling would not work on non-vodafone supplied handsets).

 

Darren

View more options
3: Seeker Silver

Upgraded my SGS7 Edge to Andoid 7.0 with a smaller software update being required after this and my Wifi Calling has gone, no option in phone either, its disappeared, but does show Wifi Calling extra as activated in Myvodafone Smiley Sad

View more options