You are here:


Ask a question:
Rank 1: Guest
Posts: 2
Registered: ‎24-04-2011

No service???

I have today received my 1st iPhone. I am not a technical whizzkid at all and therefore this seems to have me completely baffled.


I thought I had followed the instructions ok, but now the iPhone says no service? I am getting well stressed now and was hoping someobody may be able to shed some light as to what I may have done wrong.


I feel like packing it  back up and sending it back, lol!!!




Message 1 of 2 (5,878 Views)
Moderator (Retired)
Posts: 23,636
Registered: ‎21-07-2008

Re: No service???

Hi Sharonkll,


Many thanks for your post here.


When it comes to the activation of the iPhone4 there are a couple of things that can be an issue.


Can you confirm if you have had your Micro SIM activated?

Have you connected the phone to iTunes and activated the phone?


Is the issue still happening?


If you can let us know we will be able to help you further.



eForum Team

I’m part of the Vodafone Tech Team and here to help. As this is a public forum, we can only answer non account specific queries. Please note, we’re unable to reply to private messages.

If you see a helpful post, please click the 'Thanks' button to let the author know. If a post solves your query, please click the ‘This is the Answer?’ button. This helps others find helpful answers in the community too.

Message 2 of 2 (5,824 Views)
Got a question?

Get help and technical support on Vodafone's devices, products and services from our online community

If your question relates directly to your account or mobile number please contact our customer services team.

Help and Support
My Vodafone

My Vodafone

Stay in control of your spending and manage your account online.

Log in

Register for My Vodafone

Top up