You are here:

Data on the go

Ask a question:
Reply
Rank 1: Guest
Posts: 2
Registered: ‎20-12-2016

4G connection issue

I have a D-Link 4G LTE Router linked to an external Antennae. The Router works great when I use an EE data sim - giving me a strong 4G signal and fast broadband speed. I would like to move to a vodafone monthly contract so I purchased a vodafone pay as you go data sim so I could try it out before comitting to a monthly contract. However I'm only getting 2G/3G with this card. The lights on the Router indicate little or no signal yet I am getting 4G on my phone!

Are there any settings which I can use to get this to work?

 

Many thanks

 

 

Message 1 of 14 (8,293 Views)
Posts: 1,933
Topics: 6
Thanks: 239
Solutions: 16
Registered: ‎29-09-2015

Re: 4G connection issue

@wjmagee Your D-Link router will need to be compatible with our 800Mhz frequency range in order to pick up a 4G signal. 

 

If you're unsure how to check this, you'll need to contact the router manufacturer for further assistance. 

 

Message 2 of 14 (8,089 Views)
Rank 1: Guest
Posts: 8
Registered: ‎12-12-2016

Re: 4G connection issue

If your D-Link router model is a "DWR-921 4G LTE Router", purchased in the UK, then it should work with Vodafone's 4G service on the 800MHz band. If they can be configured, check the APN settings in the router menu.

If this is the router model you have then it should work okay and the problem could be with Vodafone's service provision for the sim card. Best idea is to check the sim in another 4G capable device eg a recent model iPad or Android tablet. Make sure you enable 4G under the Mobile Data settings on the iPad and check that the APN settings are correct. Turn off WiFi and make sure the iPad connects at 4G, visible at the top left of the screen. Also check the signal strength and network performance. If the iPad connects at 3G then the problem is with Vodafone. Contact their support people.

Good luck!

 

Message 3 of 14 (8,080 Views)
Rank 1: Guest
Posts: 5
Registered: ‎11-04-2011

Re: 4G connection issue

Hello   I had a very similar issue. I bought a R216 Mobile Wi Fi with a 30Gb 4G Sim on pay monthly..When I tried it out it would only connect to 2G and 3G. I tried a friends device with his SIM in it and that was ok. So put his Sim in my device and 4G now ok. Problem is therefore with the SIM

After approx 20 min call to Eygpt --yes-- it was discovered that although I had ordered a 4 G Sim, on the system, I was only allocated 3G. They are supposed to be recifying the problem soon.

Cheers

Peter

 

Message 4 of 14 (8,040 Views)
Posts: 1,933
Topics: 6
Thanks: 239
Solutions: 16
Registered: ‎29-09-2015

Re: 4G connection issue

@pafos Please keep us updated with how you get on. 

 

We'll be here to help if you need any further assistance. 

Message 5 of 14 (7,950 Views)
Rank 1: Guest
Posts: 2
Registered: ‎20-12-2016

Re: 4G connection issue

Thanks for your reply. Yes my Router is a D Link 4G LTE (DWR-921). It works great with EE data sim with settings set to AUTO. With Vodafone data sim it seems to get stuck at the connecting stage. I can set it up manually but my problem is I don't know the correct settings. I contacted Vodafone Support and they told me that I had to contact D-Link. I contacted D-Link and they told me to contact Vodafone! If I put the vodafone sim into my phone it works ok. I'm able to access the Internet. Any further help would be greatly appreciated. I noticed somewhere online that EE supports IPv6 whereas Vodafone doesn't. There is a setting on Router to enable IPv6. This is enabled by default. Should I turn this off for Vodafone

Thanks

Message 6 of 14 (7,943 Views)
Posts: 279
Topics: 4
Thanks: 60
Solutions: 2
Registered: ‎11-11-2016

Re: 4G connection issue

Hi @wjmagee, I'd recommend speaking with the manufacturer of your router to help with this further. They will be able to assist with any changes that need to be made within its settings.

Message 7 of 14 (7,504 Views)
Rank 1: Guest
Posts: 5
Registered: ‎27-12-2016

Re: 4G connection issue

Any chance your using a Dlink DWR 921?? one of my clients uses one of those with an external antenna, I put an EE sim in it as no other network was close to the speed of EE?

 

I know on the WWW UI you can set the modem to use 3g or 4g, set it too 4g only

Message 8 of 14 (7,234 Views)
Rank 1: Guest
Posts: 8
Registered: ‎12-12-2016

Re: 4G connection issue

@wjmagee In the "Prefer Service Type" setting on the "WAN Service Configuration" page of your router set the value to "Auto Mode". This will let your router connect on 3G as well as 4G. If you have a 4G signal in your area then you will automatically connect at 4G, if the sim is authorize for that service.

 

When you put the sim in your phone did you get a 4G connection or was it just 3G?

 

With regard to IPv6 I don't believe Vodafone supports that on their mobile data network so I would disable that setting till you resolve your issues with 4G access. Vodafone use Network Address Translation (NAT) for mobile data connections so even with IPv4 you don't get a direct Internet connection. Google CGNAT for more information.

 

Message 9 of 14 (6,675 Views)
Rank 1: Guest
Posts: 1
Registered: ‎04-01-2017

Re: 4G connection issue

Hi Peter, did you get a solution? I have a TP-Link 4G MiFi modem M7350 and a Vodafone data only SIM (4G 50Gig) but can only pickup 3G despite being in strong 4G area? I too spoke with technical support who advised me that 4g had not been switched on for my card?? I was told no further action required and it would be fully functioning within 24 hours but no change. Don't like paying for a service that I'm not getting😳

Message 10 of 14 (6,548 Views)
Rank 1: Guest
Posts: 5
Registered: ‎27-12-2016

Re: 4G connection issue

I didnt think Vodafone charged for 4g?

 

the DWR-921 should work although i use EE in mine. Also have an outdoor antenna.

 

Very fast.

 

JK

Message 11 of 14 (6,452 Views)
Rank 2: First Poster
Posts: 21
Registered: ‎27-02-2017

Re: 4G connection issue

I use the TP Link MR200 and only got 3G until 4 calls later got 4G activated on the SIM card.

 

Trouble is i kept getting told my Sim CArd was activated on 4G when it wasn't or my APN settings were incorrect when there were right or even my equipment was faulty when it works fine on EE and Three

Message 12 of 14 (1,930 Views)
Posts: 142
Topics: 0
Thanks: 31
Solutions: 0
Registered: ‎11-11-2016

Re: 4G connection issue

@crunchieeagle I've replied to your post regarding this, on another thread here Smiley Happy

Message 13 of 14 (1,766 Views)
Rank 1: Guest
Posts: 14
Registered: ‎02-03-2017

Re: 4G connection issue

[ Edited ]

Hi, I had a similar problem with a 4g sim only connecting at 3g. I went onto live chat without much hope of getting a solution but they did something and now I have 4g connection. It seems to be a problem with the "provisioning" of the sim. Maybe I was lucky in that I got someone who knew what they were doing but you could give it a try.

 

Message 14 of 14 (1,485 Views)
Got a question?

Get help and technical support on Vodafone's devices, products and services from our online community

If your question relates directly to your account or mobile number please contact our customer services team.

My Vodafone

My Vodafone

Stay in control of your spending and manage your account online.

Log in

Register for My Vodafone

Top up