You are here:
Ask a question:
Reply
Rank 1: Guest
Posts: 1
Registered: ‎06-03-2011

Vodafone Mobile Broadband Keeps Disconnecting

[ Edited ]

My Vodafone Mobile Broadband keeps disconnecting and has been for the last 5 days. My modem is a Huawei and had been working fine until recently. I have tried updating my software, removing and reinstalling the software and rebooting my computer but it does not get fixed. It says the signal is strong but somehow it keeps disconnecting. The light on the USB is normally blue and stable but when it goes offline it is blue and flashing. What do I do?

Message 1 of 36 (13,640 Views)
Rank 1: Guest
Posts: 2
Registered: ‎15-04-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi - did you get a resolution for this?  I've got the exact same problem after updating my software.  Connects OK and works for a random amounts of time then disconnects without prompting me.

 

Thanks,

 

Mike

Message 2 of 36 (13,407 Views)
Moderator (Retired)
Posts: 3,428
Registered: ‎13-01-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi axva88

 

Welcome to the eForum

Hmm it sounds like your having an issue with your modem.

Could you let me know the model of your Mobile broadband dongle?

Also what version of the software are you using? Have you tried installing the previous software version?

 

Have you tried using the extension cable to see if this improves the reliability of your connection?

If the modem has a blue flashing light, this usually means its ready to connect to a 3G connection.

 

I would suspect with this behaviour that there might be a coverage problem in the area which may cause these symptoms. Have you tried your Mobile Broadband in different areas? Could you let me know the postcode your having this problem in and I will check for you.

I would also recommend testing your connection by creating a new connection:

Windows XP:

  • o back to the Modems Tab in Phone and Modem
  • Highlight the  modem
  • Click Properties
  • Click Change Settings
  • Click the Advanced Tab
  • In the extra initialisation command field, type in at+cgdcont=1,"IP","internet"
  • Click OK and then go back to the Control Panel
  • Load up Network and Sharing Centre
  • Create a new dial-up internet connection with the following settings
  • Phone Number: *99#
  • Username: web
  • Password: web
  • Name: Vodafone
  • You can then connect to this by going to Start > Connect To > Vodafone


I’d also recommend trying your modem after performing a clean boot:

 

To Apply “Clean Boot” on Windows XP:

1. Click Start > Run. 

2. In the Run window, type following text: 
msconfig 
3. Click OK.
The System Configuration Utility appears. 
4. Click the General tab. 
Click on Selective Startup and make sure that "Load System Services" is the only item checked. 
(You will be unable to unselect "Use Original BOOT.INI." This is OK). 
5. Click the Services tab. 
6. Select Hide all Microsoft Services. 
Warning Do not skip this step. You must hide the Microsoft Services before you go on to step 7. 
7. Clear all the services that are still displayed on the Services tab. 
8. Click Apply > OK. 
9. Click Restart. 



To Apply "Clean Boot" on Windows Vista: 

1. Click Start Menu, and type msconfig in the search bar. 
2. Hit return (or double left click) on returned Msconfig file to launch System Configuration utility. 
The System Configuration Utility appears. 
3. Ensure the General tab is selected. 
4. Click on Selective Startup and make sure that "Load System Services" is the only item checked. 
(You will be unable to unselect "Use Original BOOT.INI." This is OK). 
5. Click the Services tab. 
6. Select Hide all Microsoft Services. 
Warning Do not skip this step. You must hide the Microsoft Services before you go on to step 7. 
7. Clear all the services that are still displayed on the Services tab by selecting “Disable All”. 
8. Click Apply > OK. 
9. Click Restart. 

 

To Reverse Clean Boot: 

Restore your computer to its original settings 

1. Rerun MSConfig utility as detailed above

2. On the general tab click Normal Startup. 

3. Click OK.


Please let me know how you get on.

Thanks
BenJ
eForum Team

Message 3 of 36 (13,402 Views)
Rank 1: Guest
Posts: 2
Registered: ‎19-04-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

I have experienced the same problem. Worked OK for two months now disconnects every ten minutes or so. I have tried the advice on this site with no success.

 

Well - better try another make of dongle, this one was clearly designed to fail after a set period.

Message 4 of 36 (13,370 Views)
Moderator (Retired)
Posts: 3,706
Registered: ‎04-05-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi Boromiir


Let me firstly welcome you to the Vodafone eForum. New faces are always welcome around here. :smileyhappy:


This is a strange occurrence.:smileyindifferent:


As Ben stated earlier, this would normally be associated to a fluctuation in coverage in a given area. It may help if you advise the postcode area where you use the device. There may be an issue that has deteriorated the coverage recently, and this is something I would like to check out for you.


Did you set up the manual connection, as Ben showed in the beginning of his post?


If so, did this still result in a periodic disconnection, or was it stable?


If you've not tried the manual connection, I'd recommend you attempt this and advise of the results of this action.


Let me know how you get on with this.


Regards


Trev

eForum Team

Message 5 of 36 (13,344 Views)
Rank 1: Guest
Posts: 2
Registered: ‎19-04-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

Trev

 

done all that. It worked for all of twenty minutes, then fell over.

 

Cuurently I can gert a connection for ten to fifteen minutes then it fails. I usually have to restart the latpop to restore the connection. This si simply not a satisfactory situation. As I pointed out this dongle worked fine for a month, now it is simply  a very unreliable piece of hardware.

 

As other people seem to be having the same problem I can only conclude that the Vodafone dongle is simply unreliable.

 

I certainly have no intention of running and rerunning msconfig whenever I want to use this.

Message 6 of 36 (13,331 Views)
Tech Team
Posts: 18,630
Registered: ‎04-08-2008

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi Boromiir

 

Thanks for coming back to us here. I'm sorry to hear that you are still having issues with this.

 

As its disconnecting after a set period of time can you tell me the full postcode of the area in which you are having this problem and we'll be happy to look at this for you to see if there are any problems with the local sites.

 

Thanks

 

Wayne

 

eForum Team

Message 7 of 36 (13,313 Views)
Rank 1: Guest
Posts: 1
Registered: ‎14-06-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi guys!! (Answer is here)

 

I got me this mobile broadband usb last month, the one with the 2gb and extra 2gb for night owl.. Also same problem..

But as I always look around on my pc to find the problem, I found the solution!! It's very simple really, all you have to do is go to your network settings (after being connected to the internet) I am using windows 7, so it might be different. (come to think of it, I never checked the date of these posts) :smileyvery-happy: So what I did, is I simply changed it to a "home network" it NEVER disconnected again!!! I have moved my pc several times though, doing so I removed the usb.. So then I just need to change it quick again.. It was very frustrating though... Hope this helps!! Do good!

 

Message 8 of 36 (13,085 Views)
Rank 3: Occasional Poster
Posts: 56
Registered: ‎15-12-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

I'm having the same problem. I'm certain this is not a network problem because several other devices (iphone and ipad) work fine with full signal strength.

 

It almost appears that the dongle 4505 connects OK then for some reason the connection is terminated, then the dongle attempts to reconnect. I'd love to know what causes these disconnections - i've tried reproducing the fault but it seems to happen at random - sometimes in the middle of data downloads.

 

Does changing to a 'home network' really solve the problem and if so why ????  I'm using Windows 7 (64Bit) and have the latest VMC software and dongle firmware installed.

 

Previously the dongle has worked perfectly - the problems only seemed to have started with the updated version of VMC.

Message 9 of 36 (13,027 Views)
Moderator (Retired)
Posts: 23,636
Registered: ‎21-07-2008

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi Magicdave2010,

 

To be honest I'm not sure if changing the location to home would make a difference however as it has worked for another user it would definitely be worth a try.

 

Please can you give this a go and if it doesn't resolve the issue, please come back to us and we will be able to investigate this further for you.

 

James

eForum Team



I’m part of the Vodafone Tech Team and here to help. As this is a public forum, we can only answer non account specific queries. Please note, we’re unable to reply to private messages.


If you see a helpful post, please click the 'Thanks' button to let the author know. If a post solves your query, please click the ‘This is the Answer?’ button. This helps others find helpful answers in the community too.

Message 10 of 36 (12,987 Views)
Rank 1: Guest
Posts: 4
Registered: ‎28-08-2009

Re: Vodafone Mobile Broadband Keeps Disconnecting

I have just returned from holiday in South Wales where I experienced this same problem for the first time and it happened at more than one location. I had however upgraded to the 10.1 software just before going away and maybe this is the common factor.

 

The time for it to fail was variable and I knew it had happened by a bing from the laptop. I would then find an error message, something about being unable to connect and device in use. If I then pressed Connect on the main screen it would usually briefly flash up the progress bar it usually shows when connecting but nothing else. I would then usually find another window lurking in the background saying that it had found a Vodafone connection, I can't remember the exact wording but I gained the impression that it thought it was a better connection.

 

Unfortunately I didn't make note of the exact wording of the messages at the time, I was too busy getting frustrated.

Message 11 of 36 (12,945 Views)
Rank 1: Guest
Posts: 5
Registered: ‎21-06-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

yeah thats what mine was doing before it started not even connecting for longer than 10 secs. please someone out there must know what the issuses are, way to many people reporting this for it to be my dongle an puter, i've lookedd all over the web and see that this is a fault that keeps popping up ;O(
Message 12 of 36 (12,942 Views)
Rank 3: Occasional Poster
Posts: 56
Registered: ‎15-12-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

You're right - changing to home network only has made no difference ! Any other suggestions ?

Message 13 of 36 (12,927 Views)
Moderator (Retired)
Posts: 3,428
Registered: ‎13-01-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi Guys,

Have you noticed if using the extension cable that was provided with the modem makes a difference?

Also what make and model is your dongle?

Have you tried taking the SIM out and putting in a phone, dialing *#105# and calling to see the last time the SIM updated?  It could be that you need to roam the SIM and then test to see if this helps.

Thanks
BenJ
eForum Team 

Message 14 of 36 (12,904 Views)
Rank 1: Guest
Posts: 1
Registered: ‎23-06-2012

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hello.  Did this issue ever get resolved?

 

I am using a K4504 modem on a Windows 7 laptop with Mobile Connect Lite version 9.4.8.21929.  I have been having the same problem off-and-on for the past year.  It happens almost everyday, and sometimes more than once.  I have tested on Windows XP and WIndows Vista laptops, with the same results, so I don't think that it is the software version I am on, though I might upgrade and see if that helps.  Here is what happens in my case:

 

1. Randomly, my computer emits a sound indicating that a USB devices has been disconnected (same sound you get if you just unplugged it).  I note the time.

2. I check, and find that I no longing have a network connection.

3. The light is no longer on, nor flashing, on the devide.

4. MCL says it is searching for a device.

5. Device manager says the device is still there.

6. Phone & Modems says the device is still there and functioning properly.

7. I go to "safely remove the device", but Control Panel says the device is still in use.

8. After a time, MCL says "No device."

9. I can then safely remove the device, and I get the audible sound from the laptop that  the device has been removed.

10. MCL immediately starts looking for the device, but can't find it.

11. I reinsert the device and get two audible sounds when the device is ready.  It immediately starts flashing.

12. MCL eventually finds it after what seems a long period of time, but then can't connect and I get two dialog boxes.  Sometimes, I actually get the dialog that says I have to enter the PIN, though this is quite rare and random.

 

At this point, if I call my service provider to check on the status of my account, they tell me that I have logged off at the same time as the drop (#1 from above).

 

Sometimes, the modem is quite warm to the touch after a drop; but most times, it is not.  I do use the extension cable, but have tested without it, as well, and still got drops.

 

To get reconnected without rebooting:

 

1. I safely remove the device (one audible tone) and shut down MCL.

2. I reinsert the device (two audible tones), and wait about 15 seconds.

3. I restart MCL.  After some time, I am connected.

 

Now, we have both EDGE and 3G.  I get 3 bars on 3G and 5 bars on EDGE.  I have MCL set to 3G only because random switching between 3G and EDGE was getting annoying, too.  It didn't seem to affect the drop situation, as I get it when I have 3G Preferred or 3G Only selected.  I have never noticed the drop happening when I was connected to EDGE (can't be 100% sure, but I also can't recall seeing it happen).  I have never had the drop occur when not connected to the network (i.e., I manually disconnected, and then had it drop after sometime).

 

Also, this is the third modem I have received on my account, as the service provider originally thought the drops might be a defective modem.  Also, I don't think it is something I have added or from another USB device because I recently had to rebuild a laptop and tested this problem with a PC that had just had Window 7 reinstalled with no external USB devices added -- no mouse, no printers and no other modems.  And still, I get this problem.  And interestingly enough, the modem that I am now using has no wireless port of any kind installed -- yes, they still make those, so the drop isn't being caused by another wireless device that I have.

 

Clearly, this is an issue between the laptop and the modem, and not the modem and the network; however, is it possible that some interference/signal from the network is forcing a drop?  I know that my provider can log me off remotely (probably a "kill"), because I have been with them when they did it so they could update some settings on my account and I was logged in at the time.  Is it possible that the EDGE signal is so strong that it is interferring with the 3G signal, or maybe even a signal from another network?

 

Anyway, I would like to hear if any progress has been made on this issue; otherwise, I will probably have to find another service provider because this is just too annoying.  Thanks,

Message 15 of 36 (9,909 Views)
Tech Team
Posts: 11,295
Registered: ‎10-01-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi tom44299

 

Thanks for your post. It doesn't appear to have been resolved in public on the eForum and I'm unaware as to whether this was successfully resolved off line with the customers directly or not.

 

I've referred your post to one of our mobile broadband and data specialists for further help and guidance. As son as I have a reply I'll be on to update the thread.

 

Thanks

 

Simon

Message 16 of 36 (9,881 Views)
Rank 6: Frequent Poster
Posts: 151
Registered: ‎07-12-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

As of yesterday, my dongle in my laptop now only holds a connection for a few minutes, if I am lucky. It is most frustrating and I dont know why it is suddenly doing this. At the moment it seems to be one thing after the other with Vodafone what with the inability to view one's balance etc. AGAIN!
Message 17 of 36 (9,823 Views)
Moderator (Retired)
Posts: 23,636
Registered: ‎21-07-2008

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi HHGTTG,

 

I have raised the issue regarding not being able to see the balance again this morning to be looked at by our online teams.

 

In regards to the connection on your dongle can you confirm if this happens everywhere?

 

How old is your SIM?

 

What is the postcodes where this has happened?

 

James

I’m part of the Vodafone Tech Team and here to help. As this is a public forum, we can only answer non account specific queries. Please note, we’re unable to reply to private messages.


If you see a helpful post, please click the 'Thanks' button to let the author know. If a post solves your query, please click the ‘This is the Answer?’ button. This helps others find helpful answers in the community too.

Message 18 of 36 (9,784 Views)
Rank 6: Frequent Poster
Posts: 151
Registered: ‎07-12-2010

Re: Vodafone Mobile Broadband Keeps Disconnecting

My SIM/Dongle is 18 months old and this is only used within my house and has worked almost perfectly for this time anywhere in the house plugged in to my laptop. My postcode area is BR2

Message 19 of 36 (9,777 Views)
Tech Team
Posts: 11,295
Registered: ‎10-01-2011

Re: Vodafone Mobile Broadband Keeps Disconnecting

Hi HHGTTG

 

Thanks for your reply. Please could you confirm your full postcode? If you do not wish to post it on the thread please update it in your personal information on the eForum settings and we can pick it up from there.

 

Thanks

 

Simon

Message 20 of 36 (9,731 Views)