You are here:
Ask a question:
Reply
Rank 1: Guest
gersin008
Posts: 15
Registered: ‎25-08-2009
Accepted Solution

S2 Email

Hi

 

Was wondering if anyone can help me

 

I have managed to setup my email, on the S2 , for my Demon account and I manage to receive and send emails when I am linked to wi-fi at home, however, when I am roaming I can only receive emails and unable to send.

 

Does anyone know a way round this? Is this a problem at Demons end or Vodafone?

 

Thanks for any assistance

Sean

Message 1 of 13 (4,799 Views)
Rank 42: Oracle I
thesoupdragon
Posts: 6,176
Registered: ‎09-10-2010

Re: S2 Email

Hi Sean

 

This will be an issue with smtp protocol.

 

Can you tell me the settings you are using (Hide your email address)

 

You can use your Gmail smtp settings to send your Demon email as well.

 

 

  • Gmail SMTP server address: smtp.gmail.com
  • Gmail SMTP user name: Your full Gmail address (e.g. example@gmail.com)
  • Gmail SMTP password: Your Gmail password
  • Gmail SMTP port465
  • Gmail SMTP TLS/SSL required: yes

Wink.gif

 

halloweenSig.png

Message 2 of 13 (4,747 Views)
Rank 38: Professor II
grolschuk
Posts: 3,078
Registered: ‎18-10-2011

Re: S2 Email

Expanding on what the problem is most likely going to be.

Demon's email servers will be set to only allow email relay (sending) from clients on their network.
This is very common practice for ISPs, as it protects them from people using their servers as spam relays.

Some email servers will allow you to send email from the same domain as long as you are authenticated (such as gmail)
And some servers will allow you to send any email from anywhere to anywhere and not complain :smileyhappy:
Message 3 of 13 (4,744 Views)
Rank 1: Guest
gersin008
Posts: 15
Registered: ‎25-08-2009

Re: S2 Email

Hi
thanks for your response

Struggling to understand how you can use Gmail when i want to send using my demonaccount and Gmail asks for a Google address ?

My set up for demon is post.demon.co.uk. and port25 but works fine with wifi

Thanks
Sean
Message 4 of 13 (4,722 Views)
Rank 1: Guest
gersin008
Posts: 15
Registered: ‎25-08-2009

Re: S2 Email

I should add that the demon email worked very well on my old Blackberry
Message 5 of 13 (4,718 Views)
Rank 34: Scholar III
Northern-dj
Posts: 7,076
Registered: ‎23-10-2008

Re: S2 Email

This is a doooooozy

 

 

 

WAP 

 

yes Wap is holding this up 

You neet to put the Internet settings 

Found here 

http://devicehelp.vodafone.co.uk/filestore/devices/Samsung/i9000%20Galaxy%20S/SamsungGalaxySi9000_WE...

 

this gets round the wap problem 

you will find them you can send and recive 


Message 6 of 13 (4,715 Views)
Rank 1: Guest
gersin008
Posts: 15
Registered: ‎25-08-2009

Re: S2 Email

sending still failed with this.

 

Its so frustrating

Message 7 of 13 (4,661 Views)
Rank 1: Guest
Vic38
Posts: 3
Registered: ‎15-03-2012

Re: S2 Email

I have the same problem - I can recieve and send email with my ISP  through wireless - Plusnet, but when on 3G can only receive, not send.

Plusnet technical said :

"In order to send E-mail when not using a Plusnet connection you will need to enter the username and password in the settings for the outgoing E-mail server (This is referred to as SMTP authentication). Unfortunately we are unable to provide support for your phone so cannot advise specifically how you would do this on your phone. I would recommend asking your network provider or the manufacturer of the phone."

 

On the Vodafone site there is a help article "set up your phone for POP3 email" but in order to follow it I need to delete the phone account I have set up that works on wireless, basically start again. Speaking to Vodafone they wouldn't put me through to technical help as they say its my ISP problem. And no I don't want to use gmail etc as suggested in some of the responses - there has to be a fix!

So what do I do now to get it to work - any suggestions out there?

Message 8 of 13 (4,649 Views)
Rank 34: Scholar III
Northern-dj
Posts: 7,076
Registered: ‎23-10-2008

Re: S2 Email

[ Edited ]

Vic38 wrote:

I have the same problem - I can recieve and send email with my ISP  through wireless - Plusnet, but when on 3G can only receive, not send.

Plusnet technical said :

"In order to send E-mail when not using a Plusnet connection you will need to enter the username and password in the settings for the outgoing E-mail server (This is referred to as SMTP authentication). Unfortunately we are unable to provide support for your phone so cannot advise specifically how you would do this on your phone. I would recommend asking your network provider or the manufacturer of the phone."

 

On the Vodafone site there is a help article "set up your phone for POP3 email" but in order to follow it I need to delete the phone account I have set up that works on wireless, basically start again. Speaking to Vodafone they wouldn't put me through to technical help as they say its my ISP problem. And no I don't want to use gmail etc as suggested in some of the responses - there has to be a fix!

So what do I do now to get it to work - any suggestions out there?


 

 

First you don't have to delete the accout

you can have multiple accounts 

Now i have said this before and i will say this again 

Vodafones wap will block alot of pop3 and smtp connections 

So you need to bypass the wap server still using the 3G server, to do this you nees a Internet APN setting up

see below this is copyed form 

http://devicehelp.vodafone.co.uk/filestore/devices/Samsung/i9000%20Galaxy%20S/SamsungGalaxySi9000_WE...

Now i no this is for the Galaxy s but this is the only way i can get a smtp to work

How to configure your device for Internet

1.Touch the Menu key
2.Touch Settings
3.Touch Wireless & networks
4.Touch Mobile networks
5.Touch Access Point Names
6.Touch the Menu key
7.Touch New APN
8.Touch Name
9.Enter Vodafone Internet, touch OK
10. Touch APN
11. Enter:
For Pay monthly customers: internet
For Pay as you go customers: pp.vodafone.co.uk
12. Touch OK
13. Touch Username
14. Enter web, touch OK
15. Touch Password
16. Enter web, touch OK
17. Touch the Menu key
18. Touch Save
19. Touch the circle to the right of the Vodafone Internet profile name you have just created to
turn it green
20. Press the Home key to return to the home screen

 

Now on your phone you should have a email app not the socila Hub one 

Press the app and it will open now if there is no account set up it will open the settings up to add one, if there is a account set up for the app press the menu button then accounts this is were you set up your pop3 / smtp accounts now i would use the manual set up and use the settings that your isp gave you 

Now if you have got this working with your wifi then make sure the Apn that you did above has a green dot and it should work the same as it does via your wifi 

This is just a security protacle built in to wap servers 

Now any time you want to use email you may have to change over to the internet settings 


 


Message 9 of 13 (4,640 Views)
Rank 1: Guest
Vic38
Posts: 3
Registered: ‎15-03-2012

Re: S2 Email

If you are still struggling then I have finally cracked it. The key bit is SMTP authentication. This needs to be on for outgoing mail when connected to 3G. So go check your outgoing email settings. If this doesn't it doesn't work then delete your account and set up again following the instructions on the vodafone support site see below. I deleted my account and started again as I couldn't follow the setup guide because it keep saying account exists.

 

support/devices/samsung/s2i9000/email setup/set up pop3 account.

 

Good luck.

Message 10 of 13 (4,610 Views)
Rank 1: Guest
Vic38
Posts: 3
Registered: ‎15-03-2012

Re: S2 Email

Thanks Northern DJ, your advice helped a bit - it gave me clues, confidence to delete and start again. When I checked following your response I already had the Vodaphone internet set up. This must have happened when I tried to follow their set up guide earlier in the week on POP3 email but I couldn't finish the instructions as the account existed. I then looked again at the POP3 set up guide and two thirds of this was the APN bit, with SMTP authentication in section 25. This was the key. My outgoing and incoming servers info etc was ok, just SMTP authentication was off and needed changing together with username and password. All works now. Thanks again for your help.

Message 11 of 13 (4,609 Views)
Rank 1: Guest
gersin008
Posts: 15
Registered: ‎25-08-2009

Re: S2 Email

tried everything guys but thanks for your help

Starting to think issue is with demon however all worked fine with the Blackberry and all works fine when connected to wi-fi

Glad you got yours working Vic


Sean
Message 12 of 13 (4,603 Views)
Rank 34: Scholar III
Northern-dj
Posts: 7,076
Registered: ‎23-10-2008

Re: S2 Email

You could have a security issue with the Domain blackberry have always been able to use most as they have always been known for security 

So Domains and Smtp servers can crank up there security 

so what's happened as Blackberry have gone by the way side many switching to Iphones the security has had to off been looked at and many IT managers reluctant to lower security, and good look with sorting that out 

The company I look after I had to get Microsoft certified  then i found out how much it was locked down 

The main Domain that every thing uses eg Website and email is were the security is so ISP can help the best way is to have two domains one for Email and one for your website 

One other option is to set up a VPN same way as the APN insteat you talk direct to the companise servers but you need to talk to your IT over that 


Message 13 of 13 (4,599 Views)