Skip to content
main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community


Connection failed due to incorrect APN setting (Vodafone es 3G)

2: Seeker

So I bought an unlocked HTC Wildfire S, my dad bought a new phone and gave me the SIM card since he wanted to keep his number.


However, I can't seem to connect to 3G network (Vodafone es 3G)


I set the APN settings as:


Operator: - Vodafone (Airtel)
Username: - vodafone
Password: - vodafone


...Which I found online somewhere.


I select the 3G network from the searched networks and it says "registered on network", but then I go back and it says "Connection failed due to incorrect APN setting".


Do I have the wrong settings?


I am a pay as you go customer in Spain, I bought this phone mostly for 3G capabilities, what is the problem?


EDIT: I found these APN settings:



But then got the error "Your SIM card does not allow a connection to this network"


Edit #2: Just tried to connect and it worked? I managed to load web pages fine. Maybe the new APN settings had to process? Or was it because I disabled Wifi? Either way - working now, so I'm happy. Smiley Happy

View more options
Moderator (Retired)

Hi tcgreen92


Thanks for letting us know that you've been able to update the APN settings to work with your device.


Your APN settings should work on the mobile network regardless of whether you have WiFi set to ON or OFF on your phone, however it is always worth checking that the APN's are correct for the network provider that you wish to use.


The APN's that you have provided on the post are correct for Vodafone ES so in future if you ever need to revert to these again keep the details in this post handy.





View more options
2: Seeker

Hi there,


I also got a Vodafone pay as you go SIM in Spain, it has worked fine before but this time when I changed over to this SIM it would not let me connect to the mobile network with the same error message.


I have tried it with these settings:

usuario: wap@wap
contraseña: wap125
Puerto: 80 


Are these wrong? Could I maybe message someone my details so that they can check if there's something wrong with my connection?

Thanks in advance


View more options

Hi hannahfurrer


Welcome to the eForum Smiley Happy


I've sent you a PM, if you could reply back I'll take a closer look at your account to make sure everything is set-up correctly. 


You can find your PM inbox here. If you can't access this link, please ensure that the box next to "Turn on private messages" is ticked on this page, and let us know if you need any further assistance.




View more options
1: Seeker

I am having a similar problem with my HTC one mini.


I cant access the internet via the Wi-fi but when I try to access the internet remotely it says


"Connection failed due to incorrect APN setting"


I've gone into Mobile network settings/Access point names/Vodafone UK Contract


The settings are


Name- Vodaphone UK Contract

Proxy-not set

Port- Not set


Password-*** (unknown)

server- Not set


Im not sure what I need to do to get it work, so any help would be appreciated as it is very frustrating 


Many Thanks

View more options
17: Community Champion

In Settings|Networks|Mobile data|(and possibly More, there may be an option for "get settings from provider.   If there is, tapping on it should install the correct APN and delete any others.   If not, the phone thinks what it has is correct.  You can also text the word WEB to 40127.   Some people report not getting a response to this, but check your settings again as they sometimes install silently.


If all else fails, you can enter the settings manually and the details are here.  Make sure you use the appropriate ones depending on whether your PAYG on on a monthly contract.

View more options