main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

Galaxy S7 EDGE wifi calling, no option

SOLVED
View solved solution
Highlighted
3: Seeker

I have just upgraded last week, i received the phone yesterday, brand new galaxy S7 edge. I have a pay monthly red value plan so i should have wifi calling enabled, and have been told by several advisors that i do have wifi calling and it IS enabled (from their end).

I've now spoken to 5 advisors, on phone and online, they all told me moreorless the same. They had "activated" it on their end....well how can you activate something more than once?

The PROBLEM is that there is no option in my phone to enable wifi calling, anywhere....ive restarted the damned thing 10 times now after being told "restart then go to settings...." sent the text saying "CALLING" to 97888 and received the reply. Its been over 24 hours since i recieved the reply from them, and still i have no option to enable it. Im at my wits end, somebody please help.

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Hi everyone, 

Apologies for the problems you're all currently having with Wi-Fi Calling. 

As far as we're aware at the moment, the next software update will push through a fix for this. As @Dane_B advised, we've fed it back and will update the thread when we have any further information. 

View more options
67 REPLIES
17: Community Champion

Hi @Plasmaticfever

 

 

Did you upgrade Directly with Vodafone or go through an independent?

 

What Android Firmware are you on ? Marshmallow or Nougat. 

 

Help link > https://support.vodafone.co.uk/Using-our-network/Wi-Fi-Calling/67269365

IMG_1084.JPG

View more options
3: Seeker

Hi,

 

I upgraded directly through vodafone online (through a chat advisor). 

 

It's android version 7.0.

The steps in that link ive seen a dozen times and they still dont help as the setting to even enable wifi calling is not present.

 

Cheers

 

View more options
17: Community Champion

Ok. 

 

In your online myvodafone have yiu looked to turn On the WiFi calling feature under Manage your extras > Manage minutes.

 

I have seen some previous posts where some have had hiccups with Nougat. 

IMG_1084.JPG

View more options
3: Seeker

Thank you for your replies, if i had to talk to another advisor following a script in broken english i think i'd throw the phone at a wall.

Wi-fi calling is enabled in the myvodafone->browse all extras  menu

It is switched on and says its available.

View more options
17: Community Champion

You're Welcome. 

 

From thread https://forum.vodafone.co.uk/t5/Android/Wifi-Calling-gone-in-7-0-S7/td-p/2535549/page/3

 

 

"All I did was go into my settings online and turn off the WiFi calling feature under Manage your extras > Manage minutes.

 

Leave it overnight for the change to take effect and then turn it back on again the next day. After that the WiFi calling feaure showed up again in the phone settings."

 

The above troubleshooting tip may help you too. 

IMG_1084.JPG

View more options
3: Seeker

I've done as you suggested, and will post back in 24hrs to see if it worked.

Thanks for your help

View more options
17: Community Champion

You're welcome and fingers crossed.  

 

The Vodafone Team here catch up with posts as they read them all. If the suggestions don't help then yes please post back and I'm sure they'll help you further. 

IMG_1084.JPG

View more options
3: Seeker

It's been a while since i responded, but unfortnuately the suggested method did not work, still no trace of an option in any of the settings.

View more options
Moderator

@Plasmaticfever

 

I've sent you a private message with details on how to get in touch.

 

Once recieved, a member of the team will be happy to help.

View more options
3: Seeker

Hi again, 

 

I've just had the phone exchanged as being on the phone to another advisor helped very little. Nobody seems to quite understand this problem.... 2 devices both running the same software have the same problem. I dont understand how nobody knows about this. 

The option in the settings does not exist, not on the new one either, no amount of rebooting and manually updating and turning the wifi calling feature on and off has done ANYTHING. Is there not just a damned file i can download to force the bloody thing to work. This problem is seriously frustrating and if i have to talk to another person who tells me to turn it off and on again im going to flip. 

I simply CANNOT be alone in this problem, all the searches i do are bringing up posts from last year when Nougart was brand new... well it isnt anymore, somebody must understand how it works. Also, all Samsung keep doing is saying its a vodafone problem as they (somehow open a sealed product and) embed their own software into the phone.

 

Please help.

 

View more options
Moderator

@Plasmaticfever

Did you email us your details using the link provided in the private message we sent you previously?

If so, please reply on the same email chain so our team can take another look into this for you. 

View more options
2: Seeker

Plasma, 

 

You're not alone 

 

Bought a brand new S7 edge from the vodafone shop in Newbury (1mile from vodafone global HQ....), as part of the update process it installed Nougat (i guess i could have skipped, but why would i), and i have never had the WiFI Calling switch. 

 

I live in the middle of nowhere and don't have a signal inside the house at all so bought this phone explciitly for wifi calling. 

 

I've followed all the guides- turn off the switch in the account, swap Sims with another phone, text 97888, etc etc. 

 

If i take the Sim out of my S7 and put in the vodafone S6 i have (which isn't on a 4red bundle) then suddenly wifi calling is activated in the S6. This means that the network is doing its thing, its just that the handset isn't quite right.

 

Have had numerous online chats, finally a tech guy admitted that there was nothing they could do and i should take the phone back to the store- which seems ridiculous.

 

What i did notice is that hte S6 and S7 operate differently when you swap the SIMs- they register with different SMS responses from the network- which seems weird.

 

 Can this really be this difficult- not sure what other solutions i have except for returning and cancelling

View more options
Moderator

@pugwash4x4

 

It's a shame to hear that your Wi-Fi calling isn't working.

 

So we can take another look into this for you, please follow the instructions I've just sent to you in a private message.

View more options
1: Seeker

Same problem  had 3 different s7 handsets and hours of Vodafone tech support online and in store. Still no wifi calling option in the phone settings.......

Finally gave up and payed Vodafone (£69) for a sure signal.  Bbc watchdog being informed...

 

View more options
11: Established

Guys what you need to do is go on live chat and ask them to send you the configuration messages again. Then once get the messages instal them and then you should have wifi calling.

View more options
1: Seeker

The idiotic Android developers removed the WiFi cvalling on the Nougat (version 7) update.  It was working fine on my S7 Edge until they updated the OS.  Now without it for weekss... and Vodafone have been USELESS at understanding and sorting out the problem.  The only thing we can do is wait for Android to release a patch.  No sign of that BTW after waiting weeks.

 

Here's what won't work:

 

1. Reactivating WifI Calling at Vodafone (tried this three times)

2. Factory Resetting your phone (thanks guys totally messed up my phone for nothing)

3. Going to a Vodafone shop for a 'patch' (2 hours I won't get back)

4. Getting a text update sent to your phone by Vodafone.

 

I am going to leave for EE who immediately seem to have solved the same issue.

14: Advanced member

Hi Plasmaticfever,

Have you tried this open phone dialer press the 3 black dots top right hand corner of phone then press settings scroll down and you should find WiFi calling there slide button to the right and this will enable the WiFi calling features.

Hope this helps

 

 

 

:robotmad:

View more options
4: Newbie

You need to activate correct APN settings.

Settings - Connections - Mobile Networks  - Access Points Names - ADD

Name - Contract WAP

APN - wap.vodafone.co.uk

Proxy - not set

Port - Not set

Username - wap

Password - wap

Server - http://www.vodafone.co.uk?cid=VOD-HOM-001

MMSC  - http://mms.vodafone.co.uk/servelets/mms

MMS Proxy - 212.183.137.12

MMS Port - 8799

MCC - 234

MNC - 15

Authentication Type  - PAP

APN - default

APN protocol - IPv4

APN roaming protocol- IPv4

Leave the remaining 4 settings as they are. Then press 3 dots and save the added APN

Then select the added APN and restart the phone. WI FI calling will appear once new APN embeds and gets registered. I did this on my phone after Factory Reset and Wi Fi calling option appeared afer about 40 minutes and when I go into APN settings the added APN is appearing as embedded thus if you click on it,  you can not change the settings apart from deleting it completely. Hope this helps

 

View more options
2: Seeker

I feel your pain rmrayner. I received my Galaxy S7 Edge yesterday after being promised by Vodafone that it supports Wi-Fi Calling just to find out that it doesn't. I've spent hours trawling through this forum to find that many other people have experienced the same problem. A couple of hours ago I spoke to 3 different Vodafone staff who told me they were completely unaware of this issue... so if anyone thinks that they are paying any attention to this forum (their customers) then they are not. Their solution was for me to give them another £70 for a Sure Signal.

 

The reason I replied directly to your post rmrayner is because this is not the fault of Android developers. Android 7 (aka Nougat) does support Wi-Fi Calling on this handset. I've seen it working on two other S7 Edge handsets on two of the other networks. However, the version of Android WE have been given has been tampered with by Vodafone first. That's why when we switched on our brand new phone it already has the Vodafone apps installed. Therefore, the fault is with Vodafone and not Google. I tried to explain this to an unsympathetic person at Vodafone earlier and he said that we would have to agree to disagree!!

View more options