main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Galaxy S7 EDGE wifi calling, no option

SOLVED
View solved solution
Administrator

@prozac1976 You can find more information on Wi-Fi Calling here

 

This includes which devices and plans are eligible and how to switch it on in the settings. 

View more options
2: Seeker

Thank you Alex. I had already followed the instructions in your link prior to calling today. Vodafone representatives have already told me today there is an issue regarding Wi-Fi calling with the latest firmware on this phone so why are you sending me to a link that does not help the situation? If you could explain that to me in some kind of detail that would help me and any other people looking for a solution that would be really helpful.

 

Just for the record, the instructions in your link are out of date for Android 7 on the Galaxy S7. These are the instructions provided but I can't see Phone after choosing Application:

  • Go to Settings, scroll down and choose the Application icon
  • Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option
  • A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK

I had to go to Settings > Application > Menu > Show System Apps > And then Phone.....and Wi-Fi Calling still isn't there because Vodafone have cocked up the firmware.

 

 

View more options
Moderator

@prozac1976

 

We've fed this back for you. We're currently waiting for a response.

 

Once we receive an update, we'll post on this thread for you and everyone else having WiFi calling issues.

View more options
3: Seeker

Cant wait for a response to this one. I have tried everything and even live chat are no good as they use the out of date scripts for Marshmallow and not Nougat

View more options
3: Seeker

I'm glad to see this thread is garnering more attention. I've basically all but given up with it as I have far too little patience to deal with the amount of incompetance vodafone is showing us.

I'm gonna give you guys a quick rundown of all the things I tried, which dont work:

1) Going Phone->"vertical dots"->Settings->(scroll down to bottom). 

2) Going Connections->More connections settings (not here either)->Advanced calling and messaging (nothing)

3) (For some reason accessing the phone settings via the applications menu) Settings->Applications->"vertical dots"->Show system apps->(scroll down to Phone, there are 3)->Tap the top one (280KB)->More settings->(scroll down to bottom). *NOTE - This is the exact same settings menu as number 1.*

4) Texting CALLING to 97888.

5) Using the MyVodafone app to turn off wi-fi calling, waiting and then re-enabling and waiting for confirmation.

 

The guide on the website to enable wifi calling does not correlate to the newest android system. Nougart (7) has different settings menus and different options, such that the guide on the vodafone website isnt possible to follow step-by-step. This is pretty unacceptable bearing in mind that Nougart has been out so long.

 

My issue is STILL not sorted, I have followed the steps from the private message one of the moderators sent, and my email recieved no reply. 

This is a vodafone issue, something on their firmware is not allowing this to work, surely someone must have a simple patch.

 

View more options
4: Newbie

You need to activate correct APN settings.

Settings - Connections - Mobile Networks  - Access Points Names - ADD

Name - Contract WAP

APN - wap.vodafone.co.uk

Proxy - not set

Port - Not set

Username - wap

Password - wap

Server - http://www.vodafone.co.uk?cid=VOD-HOM-001

MMSC  - http://mms.vodafone.co.uk/servelets/mms

MMS Proxy - 212.183.137.12

MMS Port - 8799

MCC - 234

MNC - 15

Authentication Type  - PAP

APN - default

APN protocol - IPv4

APN roaming protocol- IPv4

Leave the remaining 4 settings as they are. Then press 3 dots and save the added APN

Then select the added APN and restart the phone. WI FI calling will appear once new APN embeds and gets registered. I did this on my phone after Factory Reset and Wi Fi calling option appeared afer about 40 minutes and when I go into APN settings the added APN is appearing as embedded thus if you click on it,  you can not change the settings apart from deleting it completely. Hope this helps

View more options
4: Newbie

The other way of doing this is asking Vodafone to send Configuration settings message for MMS and Browser . It is basically the same as the manual process I have described in a previous post but sent by network and once you receive them, simply press install and restart the phone . I had same  issues with A5 and S7 edge, it is all to do with correct config settings and not the firmware. Simple solution should be text WEB to 40127 and trigger config settings to be sent to you. But when I sent the text the reply was your phone is not capable of receiving automated settings please complete set up manually.  

View more options
14: Advanced member

If your phones were supplied by Vodafone then I would have thought WiFi calling would have been enabled as standard as you should have all the Vodafone software already. As for myself my S7 edge is from CPW not Vodafone and l have WiFi calling enabled and working with android 7 without any problems. Once WiFi calling is set up and working and you have it enabled it will come on automatically when you don't have a strong signal. The only thing l can think of is there must be some kind of problem with the Vodafone software which is not allowing the WiFi calling features to work.

:robotmad:

View more options
3: Seeker

I'm glad you replied Stevie, because it has cemented in my mind how utterly useless vodafone is. You got your S7 elsewhere, and you managed to enable wifi calling....this is despite the claims vodafone make that you must get your phone direct from them for wifi calling on their network to be available. This makes me incredibly angry, but I thank you for the information nonetheless.

View more options
3: Seeker

I have followed the advice given and text WEB for the configuration settings, which i promptly received and installed. Prior to this I followed the steps to manually create an APN. Neither way has made the option appear, after restarting and everything, I've waited longer than 40 minutes (good few hours) and still nothing.

 

View more options
Highlighted
2: Seeker

Changing the APN settings and asking Vodafone to send a Configuration settings message is essentially the same thing and this will not help us because the option for Wi-Fi Calling is completely missing from our phones. The cause of the problem is the firmware that Vodafone have pushed out to our handsets and they will need to provide a patch / update to rectify this. Changing settings will not make an option appear in a settings menu that was not there before.

View more options
Moderator

Hi everyone, 

Apologies for the problems you're all currently having with Wi-Fi Calling. 

As far as we're aware at the moment, the next software update will push through a fix for this. As @DaneB advised, we've fed it back and will update the thread when we have any further information. 

View more options
4: Newbie

Hello again.

I understand your frustration as i went through it twice myself.

First was my wife's phone brand new Galaxy A5 2017 and Wi Fi calling option was not available in the menu. Wi Fi calling option appeared after asked Vodafone for 20 times to send me correct config settings. I swapped sim card around few times and config message finally arrived. installed restarted and Wi Fi calling option magiacally appeared.

 

Exactly the same issue with my recently upgraded s7 edge . No wi fi calling option in the menu and phone would not receive the config text even after swapping sim cards. I than copied the settings for APN from my wife's phone and after doing factory reset registered APN as I have described in a previous post. Result was the Wi Calling option appeared. I will attach few pictures to confirm

3: Seeker

Is there any timescale for this "Update"? one month, two month or longer??

View more options
Administrator

@markwcel We don't currently have a timescale for this, but we'll be sure to update this thread as soon as we hear back from our Specialist team. 

View more options
2: Seeker

I have fixed the issue on my handset. It seems the problem was caused by the Samsung Touchwiz Launcher that Vodafone have tinkered with I must add before Vodafone blame Samsung! All I did to resolve the problem was to install a different launcher. I installed the Google Now Launcher from Google Play and the Wi-Fi Calling feature appeared and it works really well. Here are the steps I took to resolve it which I hope will be able to help other people:

 

1) Open the Google Play app

2) Search for Google Now Launcher and install it

3) Open Google Now Launcher and it will ask you to select a home app

4) Choose Google Now Launcher

5) Now open the Phone app and tap on the three dots in the top right corner

6) Settings

7) Wi-Fi Calling should be near the bottom where you can enable it

 

In my opinion Google Now Launcher is much better than the Samsung Touchwiz anyway. It's seems to be a bit smoother and also has some pretty cool additional features such as screen search.

 

Also, out of curiosity I just uninstalled Google Now Launcher and reverted back to Touchwiz and the Wi-Fi Calling setting stayed in place so if you don't like Google Now Launcher you don't have to use it.

 

Hope this helps!

View more options
14: Advanced member

Hi prozac1976,

Glad to hear you found a solution that works for you. My personal opinion is that mobile companies shouldn't be allowed to mess around with any of the updates apart from testing them nor should they add any bloatware that is not needed and 99% of there customers do not want in the first place and that's the main reason I always buy my phones unbranded & simfree and swap networks every so often.

:robotmad:

View more options
2: Seeker

Brand new S7, Vodafone supplied, updated to Android 7 as soon as it came out the box, no wifi calling option, Vodafone online hopeless - 'take it to the nearest shop', telephone support just as bad, fobbed me off to Samsung after he had problem identifying his Android versions, Samsung said its Vodafone's problem. Not at all impressed, wifi calling was one of the main reasons for going with Vodafone.

View more options
3: Seeker

Just to confirm that the latest update a week or so ago has indeed caused the wifi calling feature to appear on my S7 EDGE

 

View more options
2: Seeker

Didn't work for me!

 

View more options