main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Galaxy S7 EDGE wifi calling, no option

SOLVED
View solved solution
4: Newbie

So, after multiple web chats, phone calls, one vist to a Vodafone Store and one to a Samsung Store, this is finally resolved.

 

I finally manage to get to the person who knows what to do and does it, and now i have the WiFi Calling option exactly where it should be (Phone...Settings), and WiFI Calling works.

 

To solve it someone at Vodafone had to send the correct settings to my phone.

 

This is despite being told "There is nothing we can do", "There is nothing wrong on your account", "Your hadset does not support that feature", "It is Samsung's fault, you need to speak to them" and (my favourite) "Well i can sell you a Sure Signal device if you want to use WiFi calling".

 

So, Colleen - thanks for instigating the process which finally got this resolved. i just now need to get this repeated on my wifes phone, my daugters phone and my mothers phone - so a happy 18+ hours more trying to get those sorted

 

Then i need to get the other outstanidng issue with Bill My Vodafone resolved (currently with Vodafone Complaints).

 

Finnaly i need to keep my fingers crossed that i experience no more issues in the remainde of my contract, as i really do not want the hassle, time and expense of tring to get Vodafone to resolve it. Nothing would convinse me to renew with Vodafone, absolutely nothing!

 

 

 

View more options
2: Seeker

Like many (most?) on here, I have the same issue and have followed all of the steps suggested resulting in no change. I stupidly visited a store after being told they could flash my phone only to be told they can't flash phones. Wasted another 2 hours chatting to a Voda specialist (must be a misnomer like Apple Genius) only to go to bed without WiFi calling but as angry as I can ever recall being. Can Jonb or any moderator now say exactly what is required to resolve this issue?

View more options
Moderator

@Fruitbat56 I'm sorry to hear you're having issues with this. Our team will be happy to take a look into it for you. I've sent you a private message with details on how to get in touch with us 😊 

 

View more options
4: Newbie

Hi Colleen, I have the exact same problem. I had wifi calling working on my phone and since a factory reset a week ago the option has dissapeared. Done all the things I am supposed to have done and called Customer service multiple times but they keep on fobbing me off.

 

Please can you help?

 

Thanks,

 

RV

View more options
2: Seeker

Hi RV,

 

Did you buy the handset from Vodafone? If not then they won't help you at all.  I've tried the usual things like looking in Settings>connections, Phone>settings, setting up APN, Factory Reset etc. none of which worked. I'm now considering flashing my handset with the Vodafone ROM but there are risks attached. Otherwise there are really only two other options namely, wait for an official Android patch or buy a new handset (ouch!).

 

Best,

 

Derek

View more options
Highlighted
2: Seeker

Same issue here folks. Got a new S7 from Amazon and Vodafone say they can't install Wifi calling as it wasn't purchased from them. I need a soloution if possible to stop me raging. One guy even claimed it was working when it isn't!

View more options
2: Seeker

I had a chat with a guy at Samsung and (this is pure speculation) it seems that Android may have dropped WiFi Calling from the OS so that they can charge the networks to reintroduce it. Anyway, my contract has expired so I'll be moving to an MNO with decent coverage at my home address.

 

Out.

 

Derek

View more options
4: Newbie

Hi Derek, 

 

Yes this is a handset purchased through Vodafone. Wi-fi calling was working perfectly fine but it dissapeared after I did a factory reset. Very frustrating.

Hoping Coleen gets in touch and helps get this issues resolved.

Thanks,

RV

View more options
Moderator

@TopDog129 Please check out more information on our Wi-Fi Calling page.
If you're still experiencing issues after following these steps, please check your private message inbox for details on how to contact our dedicated team.

View more options
4: Newbie

I did ask what needs to be done, but never got an precise answer, sorry. I want to find out myself, as i have to get this sorted on my wifes phone now - but really cannot face the hassle of having to go through tis again - another 10/12/more hours wasted potebtially.

 

In the end Vodafone did something their side which resolved it. exactly what was done was never discolsed, but it involvved sending some settings. What settings i have no idea. I was told i would receieve a text message with the settings, but i never did. However, the WiFi calling option suddenly appeared (having been absent for the last 12 months since i activated the option on my account.

 

When i asked exactly what had been done, as i now need to do the same with my wifes phone, Vodafone denied sending me any settings and said i had entered the correct settings myself!!! No, I had not, i had not changed any settings, or entered any settings

 

I found the whole process very exasperating, and followed the typical Vodafone patern for support: namely it required 10 or more chats/phone calls/visits (record is over 50 so far, in respect of a different problem), Vodafone representatives misrepresent the information - e.g. "It is the handset", "it is a Samsung problem", .... all of wihch are later found to be incorrect.

 

If i do manage to find out exactly what needs to be done when i sort my wifes phone out i will let you know - but i am nopt holding out much hope

View more options
2: Seeker

I had the same problem for about 1 year on my s7. I got it fixed today! It seems that the android software update wipes the wifi calling from the phone and Vodafone do not issue a refresh. What I did was as follows:

1. Go to My Vodafone and remove the wifi calling option.

2. Wait 24 hours (or until the option is no longer showing on My Vodafone).

3. Send text message: CALLING to 97888.

4. When you get the message that wifi calling is enabled, the option should now be on your phone.

PS: Vodafone advisers completely in the dark. They told me it was a problem with my phone as wifi calling was alreay set up at their end. This simple fix should be top of their list.

View more options
2: Seeker

Hi,

I had the same problem for about 1 year on my s7. I got it fixed today! It seems that the update wipes the wifi calling from the phone and Vodafone do not issue a refresh. What I did was as follows:

1. Go to My Vodafone and remove the wifi calling option.

2. Wait 24 hours (or until the option is no longer showing on My Vodafone).

3. Send text message: CALLING to 97888.

4. When you get the message that wifi calling is enabled, the option should now be on your phone.

I see that you appear to have tried this but maybe you did not wait long enough for the option to be removed from your account? Sending CALLING to 97888 does nothing if the option has not been properly de-activated. Btw, I have red bundle on CPW s7 phone. Moderator comments about needing a phone supplied by Vodafone are incorrect. I was also referred to Samsung by the Vodafone chat line when clearly this is an issue for the network provider!

Hope this helps.

 

 

 

 

 

View more options
2: Seeker

I echo the frustration in this stream. I moved to Vodafone after two separate assurances that WiFi Calling would work on my S7 Edge despite it being an Australian Samsung and having been flashed to O2 firmware (SamMobile and Odin) but I was advised to put it back to UK standard (BTU), and did so.

 

I have spent hours on the phone to agents of varying skill and have had some call back and others fail to ever get back as promised.  Each time I end up repeating the same sort of steps and going through the same script. I even went into a shop to see if they could get a better result ... they got tech on chat and went through the same stuff and tech promised to look into it and get back to me in 24 hrs ..... they did not!

 

The story so far:

 

  • The options do not, and never have, shown up in either: Settings>Connections>More Connection Settings or in Phone (three dots) Settings>More Settings
  • Plan corrected to a higher cost plan to one that allowed WiFi calling .. the sales person and 3 techies missed this issue!
  • The phone has been re-booted (many many times!)
  • One Vodafone support peson blamed Samsung and put me on to them ... they categorically said it was a Vodafone issue
  • Online account switch has been activated
  • SMS has been sent to activate
  • APN has been entered as shown on this site
  • Software is up-to-date (see below) ... with a small patch arriving today when I manually did an update check.

I am now on a more expensive plan than I need with many hours invested in trying to make this work. I am not spending more money on SureSignal as this will only give me a small signal footprint. Frankly I am not happy!  Any ideas on the magic fix for this?

 

 :-(

 

Base Software installed

ModelSM-G935F
Model nameGalaxy S7 edge
Country
United Kingdom (BTU)
VersionAndroid 7.0
  
Build dateTue, 17 Oct 2017 05:28:35 +0000
Security Patch Level2017-10-01
  
PDAG935FXXU1DQJ3
CSCG935FOXA1DQJ3

 

Patched 11/1/18

Baseband: G935FXXU1DQIL

Kernel:  3.18.14-12365438 Thu Dec 14 2017

Build: NRD90M. G935FXXS1DQLC

Security Patch: 1 Dec 17

View more options
Moderator

@PACPhone To check your eligibility for Wi-Fi calling please text CALLING free to 97888.
As you say you've already done this, could you please send us over an image of the text reply you get back?
Once we receive this, we'll be able to advise you further 

View more options
2: Seeker

Screenshot_20180112-191146.png

 

Slightly done that before :-)

.. and no promised call-back from my call a few days ago.

View more options
Moderator

@PACPhone I'm sorry you're having difficulty with adding WiFi calling to yor account. So we can take a look into this, please contact us via the link in the private message I've sent you.

 

View more options
2: Seeker

Still currently no option and the last promised 'I will call you back' still never happened.

Trying the switch off WiFi Calling online ... wait 24 hrs switch back on with re-boots solution.

... 

View more options
2: Seeker

... and that did not work!

 

It has me stumped amd it certainly seems to have Vodafone stumped!

 

So .. I switched networks and then bought a more expensive plan than I need with the express requirement of working WiFi calling on a non Vodafone S7 Edge and from this thread there seems to be a known issue but Vodafone still assured me it would work before and since I took out the account.

 

Anyone have any other ideas?

 

Thanks 

View more options
2: Seeker

OK... this worked. WiFi calling has been turned on and off by Voda and by SMS multiple times but following advice from a user further up this thread and switching it off myself on my online account via a PC ...then a hard phone reboot then wait 24 hrs ...then turn back on online .. then hard reboot...then wait a few hours and it is there!

 

Many many Voda people have not solved this!

View more options
Moderator

@PACPhone I'm glad to hear this has been resolved for you, but disappointed it wasn't one of my colleagues that was able to provide the resolution.

Let us know if you'd like us to investigate this and feedback your disappointment to the advisers concerned.

View more options