main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

Galaxy S7 EDGE wifi calling, no option

SOLVED
View solved solution
9: Established

This is exactly what happened to me. But Vodafone in the end were unable to activate the setting. 

 

That's when I used the Nova thing and it worked. I'm really sorry it didn't work for you. I have no idea why it does for some and not for others. 

 

BTW, there are a lot of Galaxy owners on Vodafone who can't get WiFi Calling to work. 

View more options
2: Seeker

So, this was quick, not however fixed by Vodafone I believe, after hours of waiting for Vodafone "server backend support" - as advised by multiple online advisors.

 

What I did:

 

1. Edited the CSC others.xml file to enable wifi calling - https://www.droidviews.com/how-to-enable-hidden-csc-features-on-samsung-galaxy-devices-with-root-acc... (*see below for what I did which deffered from this link).

2. Disabled WiFi calling in My Vodafone.

3. Rebooted phone - still didn't appear.

4. Sent txt CALLING to 97888.

5. Rebooted phone - still didn't appear.

6. Called 191, quoted "wifi calling" to be put through to someone who actually understands, after explaining they knew the exact process.

7. WiFi calling was re-activated on my account, I was advised to send a text message after 10 minutes to point 4. a

repeat of what I had tried.

6. 10 minutes later, before resending the txt or rebooting my phone I noticed that wifi calling was in the options screen.

 

Although I have enabled the option it is still not allowing me to make a WiFi call yet (tested by enabling airplane mode, and connecting to a wifi network). There may be a delay for it to work, I will wait 24 hours to test this.

 

I believe the step I took at point 1. allowed the settings to apply properly as after I made the change to the CSC, disabling wifi calling in My Vodafone and then sending a txt message to vodafone in step 4. I received a txt from Vodafone with further details on wifi calling (something which hadn't happen before).

 

Step 6. involved speaking to a nowledgeable person at Vodafone. so cannot be sure if this also had any influence.

 

*The step I took different in my case from the link above was to add the feature to the others.xml:

System > CSC > VOD > system > csc > others.xml, then add this line:

CSCFeature_Setting_SupportWifiCall>TRUE</CSCFeature_Setting_SupportWifiCall> save and exit, reboot the phone. The option may take a while to appear.

 

Note: the phone needs to be rooted to access system files.

 

If you need to speak with Vodafone My advice though would be to call 191 and quote wifi calling to be put through to someone who knows what they are doing, and does not just read from a script.

 

Still waiting for it to work but at least my phone is set up for it now.

 

Step 1. was an interesting discovery, manually adding entries to the others.xml file is a nice way of adding / removing functionality from the phone which is not available as standard, and is only an option to the provider.

View more options
Moderator

I'm sorry the options provided by @iainmann didn't help you @Craig26576. We'll be happy to look into this for you. As we'll need access to your account to do this, please contact us by following the instructions in this private message.

View more options
2: Seeker

Mark,

 

Thank you for your reply, I am, however, losing the will to live, must have contacted Vodafone support numerous times now, and each time it has mostly resulted in the same reply.

 

So, the wifi calling option was enabled this afternoon in the phone settings, which (my fault entirely) disapeared after making further changes to the CSC file. I am assuming that I will need to go through the process of waiting for provisioning again.

 

I have contacted "support" and I'm currently waiting for the settings to apply, which I now have to wait 2 - 24 hours (the was the last advice given).

 

Regards

Craig

 

 

View more options
Moderator
Moderator

Thanks for getting back in touch @Craig26576, please continue to keep us updated and let us know if you manage to get everything up and running.

If not, get in touch via the private message that @Mark sent out to you;  I'll be happy to help in any way I can.

View more options
2: Seeker

Hi,

 

I am not sure if anyone has done anything, but I am happy to say that Call+ and Message+ Enriched calling is now working on my phone, I am not sure if this is an alternative to the wifi calling option which the instructions mention.

 

A seperate app is required from the play store, which I am not too bothered about.

 

The main thing is I am working with WiFi and 4G calling now so I am happy again

 

Regards

Craig

View more options