main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

Galaxy S7 WiFi calling Android 7 Nougat

2: Seeker

This is not a question but it is intended to MAYBE clear up some confusion about WiFi calling using the S7 which has updated to Android 7 / Nougat.

I bought a used S7 locked to EE - it was NOT a Vodafone device and NOT bought from a Vodafone store.  I unlocked it via EE (costs £9 but worth it) so I can use any SIM.

Switched to Vodafone Pay Monthly and searched for WiFi calling option.  Many articles suggest the On/Off setting is in the main Settings menu somewhere but on my handset it is NOT there - I believe the Android 7 update removed / changed it.

I did find the setting as follows (these instructions are written so hopefully anyone can follow them!!)

  • Open the Phone menu (Green icon usually on the HOME screen with a white phone handset on it)
  • Tap the 3 vertical buttons at the top RH side of the screen
  • Tap the Settings option
  • Scroll down to almost the last item and there is WiFi calling - toggle it on / off
  • Send text / SMS to 97888 with word CALLING
  • Text returns saying that Vodafone will add WiFi calling to the account in 24 hours
  • I actually got another message after a couple of hours telling me Wi-Fi calling is on

To test / use the system I switched AIRPLANE mode on (to stop the normal mobile phone / SIM card making calls) and then switched WiFi on to connect to my home router.  I can now call (and receive calls) via WiFi with absolutely no mobile phone signal.

I hope this is understandable and maybe helps someone who is struggling

View more options
8 REPLIES
17: Community Champion

Hi @frankst237

 

Thank you for your insight. 

 

When Calling Over WiFi was initially released Samsung Phones that we’re eligible to be used did have to be purchased from Vodafone but that has since changed. 

A person may also find the Vodafone Support Page also helpful > How-do-I-set-up-Wi-Fi-Calling-on-an-Android-phone.

 

Current Phone > Samsung Note9 _512Gb > Model: SM-N960 Duos.

Samsung Gear s3 Frontier Watch.

View more options
4: Newbie

Bandofbrothers

 

The Vodafone web-site is lying when it says Wi-Fi Calling is available, in my case, on a Samsung Galaxy S6 Edge which I did not purchase from Vodafone. Numerous calls to Vodafone Chat got absolutely nowhere. Nothing they could do could make the Wi-Fi Calling option appear in Phone Settings menus.

In the end, they referred me to my local Vodafone store where I was told that Wi-Fi Calling would only work if my phone had been bought from Vodafone.

View more options
17: Community Champion

@olaflauder

 

The store has given you out if date advice. 

Its no longer required to have had purchased the phone directly from Vodafone. 

These links may help. 

vodafone-wi-fi-calling T&C.

Android/Wi-fi-enabling-on-Samsung-S7-phone.

Android/Galaxy-S7-WiFi-calling-Android-7-Nougat.

Current Phone > Samsung Note9 _512Gb > Model: SM-N960 Duos.

Samsung Gear s3 Frontier Watch.

View more options
4: Newbie

Hi there,

 

What you may want to try, are these following steps. Sign into vodafone.co.uk, if not registered do so. Then select calling options for the number you need wifi calling enabled for. Disable it if it shows as enabled, otherwise follow next step.

 

Send "CALLING" by sms to 97888. After receiving sms to say that service is enabled, reboot device.

View more options
4: Newbie

@bandofbrothers

I've still got problems with my Galaxy S6 Edge after following your advice so I'll start off a new topic for this problem specifically.

cheers, Roger

 

 

View more options
Moderator

@olaflauder Have you followed the instructions provided by @Spitfire400?
Please let us know how you get on 

View more options
2: Seeker

Hi, my ealier post explainign how I set up wifi calling on Android 7 on 10th December 2017 has now been superseded by a software update to Android 8.

The route I outlined in my ealier post (going into the phone app, clicking on settings and finding WiFi calling on/off) now no longer works - THANKS A LOT GOOGLE / ANDROID UPDATE.

I now cannot find anywhere to switch ON WiFi calling in the Android 8 menus.

 

If anyone has found a route PLEASE can you post it OR can Vodafone help us users out by telling us where (in my Samsung S7 as an example) the ability to switch it on / off now sits?

View more options
2: Seeker

All,

Bouncing between 3 different threads so apologies to anyone who reads this and gets confused.

I have now got WiFi calling back thanks to a different contributor in a thread about the Note 8.

After updating to Oreo (and presumably following the next update as well) the WiFi calling option disappeared.  I found this in the other thread:

So, if you want WiFi Calling on your Note 8: call 191, tell the robot "WiFi Calling" and ask the support guy or girl to send a configuration to "update the provisioning" on your handset.

I did this today and within 5 minutes of ending the call I had WiFI calling back and the toggle switch is back on the Settings screen in the PHONE app on my home page.

I hope this maybe helps others.

Thanks to the other contributors and Vodafone support who (when told the above) simply did the business within 5 minutes.

Frank

View more options