main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Huawei P20 Pro WiFi calling option no longer available on Android 9

Highlighted
2: Seeker

My P20 Pro recently completed an auto update to version 9 of it OS and Android. Since then the option of WiFi calling has been removed. Anyone know if its coming back or if Huawei or Vodafone have made any statements? Thanks. 

View more options
3 REPLIES 3
17: Community Champion

You might just need to set it back up @samuelholland25 

 

Vodafone would have tested the update for their branded handsets before allowing the update to be pushed to the phones. 

 

This may help.

 

Tips are in Vodafone and wi-fi-calling.

 

Along with.....

 

Calling Over WiFi Set up. Ask the agent to force the phone via sending an OTA configuration update that should provision your phone for Calling Over WiFi. 

 

"Register for Vodafone Wi-Fi Calling.

 

Text the word CALLING to 97888

This is a free text which will add the service to your account

You should receive the following confirmation text:

Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.

If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact-us.

 

Once you receive the confirmation text, switch on Wi-Fi Calling in your settings.

 

Go to Settings, scroll down and choose the Application icon

Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option

A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"

 

Also check in your myvodafone.

 

That all said sometimes a simple soft reboot by turning the phone Off and On can help. 

 

 

Current Phone > Samsung Note 9 _512Gb > Model: SM-N960 Hybrid-Duos.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
2: Seeker

Hi, thanks for your response. I've checked on MyVodafone and I'm still registered to have WiFi calling and have followed the instructions to make sure it is active. 

My concern is around the actual settings menu on the phone is now different. There used to be a section in the Phone -> Settings screen that allowed you at the handset level to toggle Wifi Calling on/off. This has completely gone so even setting at a carrier level I'm unable to use it on the handset.

I wondered if it was a fall out from updgrading to Android 9 and if this was a conscious decision by Huawei in partnership with Vodafone to remove it?

View more options
Moderator

Hey @samuelholland25,! Sorry about this issue you're having with Wi-Fi calling, it sounds strange. I've spoken with our Technical specialists on this who've advised you visit one of our stores who can actually take a look at the handset for you. You can find your nearest store here. I hope you get it sorted soon, let us know if you need anything else. Ross 

View more options