main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Mate 20 Pro wifi issues

Highlighted
4: Newbie

Hello everyone.

I have a Mate 20 Pro which for the most part is brilliant.

However, I am having issues with the WiFi connection. When I have the WiFi on, I find that the phone is sluggish browsing to various site such as topcashback, with it taking 30 seconds to find the site, let alone load it.

I turn off the WiFi and the pages load pretty much instantly.

At the same time, I have issues receiving text messages when the WiFi is on. People text me and I don't get the messages, sometimes for hours, or until I am out of range of the WiFi and then they get delivered.

In terms of home broadband, I have a 1GB Hyperoptic connection, so it is not a bandwith issue. The router provides a 5 and 2.4 GHz connection, but it makes not difference on either one.

Vodafone support have tried turning off WiFi calling to see if that solved the problem, but it has made no difference.

Has anyone had or are having similar issues and if so, is there a fix ?

Could it be the phone does not like the router or does it just suffer with WiFi issues?

 

Thanks

 

 

View more options
6 REPLIES 6
17: Community Champion

Does this happen no matter what wifi source you connect to @simonb007  ?

 

If so then yes it could be an idea for the phone to be looked at.

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
4: Newbie

To be honest, I have not really tested it outside of my home, as that is where I work from. 

When I go out to see clients, I have my phone on data, so I don't usually have the issue.

The text message issue can be sporadic. It will work when I initially connect to the WiFi, then I will get a call from someone after an hour - "Why aren't you replying to my texts"

I did have a sky adsl connection before Hyperoptic and the WiFi speed wasn't that great back then, but I put it down the measly 10mb connection I had and so I ran it on 4G most of the time.

Hence I asked if anyone on Vodafone has experienced similar issues, so I can nail it down to either the phone or the router.

View more options
17: Community Champion

Fair enough @simonb007 

 

It might also be beneficial to reach out on any Huawei community forums too.

 

I wish you all the best with this situation. 

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
Moderator
Moderator

Thanks for getting in touch @simonb007. I've taken a look for a few possible troubleshooting steps and found the following: 

  • Make sure to disable the power saving mode before using the Wi-Fi on the phone. 
  • Make sure the phone security is not turned OFF which can be the reason you are facing this problem
  • Open the Wi-Fi settings and erase the network name. Restart the phone and add it again

Give those a try and let us know if it helps at all. If not, it might be worth checking out a Huawei forum as @BandOfBrothers advised. 

View more options
4: Newbie

Thanks for the advice.

I have tried all those suggestions already.

I may try resetting the phone completely when I have time, to see if that solves it.

 

View more options
Moderator
Moderator

You're welcome @simonb007 - sorry I couldn't be of anymore help. If you reset the phone, please keep us updated and let us know if it helps at all. 

View more options