main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Not receiving emails over 4G when WiFi works ok.

Moderator
Moderator

You're welcome @robertn 🙂 Once you've managed to try this, please pop back to us and let us know how you've got on. 

View more options
4: Newbie

Hi

I've tried Blue email which worked with the PAYG SIm but still no joy over 4G.

 

Bob

View more options
Moderator
Moderator

@robertn It's unusual that this is ongoing and you're still unable to send and receive emails over 4G. Have you tried turning your 4G off and sending or receiving emails via your 3G connection? This will help us to identify if this is a standalone 4G issue or the mobile network as a whole.

As everything seems to be working with everything else whilst connected to 4G, it's still worth checking some of the basic internet settings.

Have you tried setting up a basic (non company) email account, such as hotmail? This will help us to understand if it's all emails, or only certain email accounts that are affected. 

View more options
4: Newbie

Loz

Thanks for the reply . I can send but still can't receive. gmail & outlook both work fine over 4G.

Kind regards Bob

 

View more options
17: Community Champion

It sounds as though the service provider may be restricting mobile connections.  This is usually more likely to affect outgoing than incoming, but I think your best recourse is to contact the service and ask them whether this is the case.  As other services are OK, it would appear not to be a Vodafone/4G issue.  It would be worth trying what Loz suggested, though, just to rule out something very weird.

View more options
4: Newbie

 Thanks for the reply.

I did ask them and they were adamant that this was not the case. As I've said before it used to work but stopped and when I tried a Vodafone PAYG SIM in the Motorola One it worked straight away. I will try Loz suggestion and see if that works.

 

Kind regards

Bob

View more options
17: Community Champion

There was an assumption in an earlier reply that other data connections (ie web & apps) were working OK, but I can't see that confirmed.   Is it?  If so, then this appears to be confined to email and this device.  The only other suggestion I can come up with would be to refresh the APN by texting WEB to 40127 (although a fault with that ought to affect all data connections).

View more options
4: Newbie

That is the what is happeining, everthing else works with WiFi and 4G. I'll try and see if this makes any difference.

View more options
1: Seeker

Hi All

 

I ahve been having the exact problem, after phones calls to VF and resetting Iphone 7 wiping reinstalling I found one thing thats seems to work - Switch OFF 4G and phone reverts to 3G and voila all emails send and recievce without any changes or fuss - this to me seems to be a 4G issue and I think its getting incorrect IP addresses that are either being blocked or are not reconised by the emial servers. hope this helps.

View more options
17: Community Champion

If 4G is using different IP addresses and your email service is operating by whitelist, that might be possible.   They may need to add the relevant IP addresses to their list.

View more options
4: Newbie

AJ

Thanks for the tip but I tries it this morning and it makes no difference.

Kind regards

Bob

 

View more options
1: Seeker

Hi, make sure all outgoing email details are completed username - email address and password, also confirm the port numbers are correct pop is normally 25 or 487 I think I found if all details are not complete 3and 4 G networks don’t work but on WiFi will, it’s an odd thing.

 

regards

View more options
4: Newbie

Thanks to all for the help. The current state of play is, with my Motorola One over WiFi & 4G I can do everything I try, ie browse websites, receive gmail, outlook etc. Using K9 mail with WiFi I can send and recieve emails via the POP3 and SMTP accounts. Over 4G I can send via SMTP but POP3 does not receive..

I have just tried on a PAYG O2 Moto G4  with K9 mail using the same configuration and this works ok over 4G send and receive. I don't know what this proves, (if anything). FWIW On the Motorola One  if I try to alter the POP3 settings on K9 mail it will not connect over 4G.

Bob

View more options