main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

OnePlus Wifi Calling + VoLTE

2: Seeker

I can also confirm that VoLTE and WiFi calling are working on my Android 9 OnePlus 6T. My phone was purchased via FoneHouse but appears to be non customised as you find buying sim free from OnePlus or Amazon

 

When I first got the phone with a temporary number I  was able to make HD calls (not VoLTE or VoWifi) which uses a 3G signal. However since my number ported I never get the HD call identifier when a call is in progress.

 

I've not seen any posts on this forum but would be interested to see if others have this working. There is a noticeable improvement in voice quality and clarity for a HD call

 

 

 

 

View more options
2: Seeker

Screenshot_20181214-110459__01.jpgHD call quality icon is present

 I think this forum is running some kind of Christmas magic, just made a call after posting and HD calling is back!

 

View more options
4: Newbie

I also have a OnePlus 6 running Oxygen 9.0.2

I did the *#800# trick and ticked the two boxes.

After reboot I can now see and enable the VoLTE and Wi-Fi calling option.

I can also see that Wifi Calling is enabled on MyVodafone account settings

But I still cannot make calls when in Airplane mode and Wifi on - also dont see any HD calling logo when not in Airplane mode and connected to 4G network.

 

So, it seems this works for some and not others.

 

Come on Vodafone - please add OnePlus to your supported list  - Thanks.

View more options
12: Established

Have you tried rebooting your router or trying someone else's WiFi? 

View more options
4: Newbie

nope - not tried rebooting router - internet being used right now by kids so will try later...

View more options
12: Established

I get HD on my OP6 when calling a iPhone on Vodafone. What device are you calling? Does that device get HD icon when calling other Vodafone numbers? (i.e. are you sure the problem is at your end?)

View more options
4: Newbie

Hi,

Ok - I rebooted the router and now I see VoLTE in the icon bar - and the HD logo when I call my partner's mobile - yay!

 

But if I put the phone into airplane mode + Wifi on and try to make a call - it still insists I take phone out of flight mode to place a call. - Ah well one out of two for now...

 

Cheers.

View more options
12: Established

Well the odd thing here is that your router/wifi have nothing to do with VoLTE or HD Voice, but at least it's working!

I would try someone else's wifi connection, it may be your ISP or router blocking it.

If you dial *#*#4636#*#* (spells info) is 'wifi calling provisioned' enabled under phone information?

 

View more options
4: Newbie

Hi,

Yes tried the 4636 and it shows Wifi callin Prov is switched on

 

Cheers.

 

View more options
12: Established

One last test, tether to your partner's phone with airplane mode and WiFi on, does WiFi calling work?

View more options
2: Seeker

Hi there,

I am getting the exact same issue. OnePlus 6, have VoLTE in the top bar. Phone says WIFI calling provision is enabled, but unable to call over wifi with airplane mode on. Same error as you were getting.

Could it just be the Oxygen OS version we are on?

View more options
12: Established

I'm on 9.0.3 and it's working fine for me.

View more options
2: Seeker

I haven't updated to 0.9.0.3 yet. Maybe I will do that tomorrow.

View more options
12: Established

It worked on 9.0.2 as well. Maybe ask Vodafone on live chat to reset it?

View more options
2: Seeker

What did you do to test? Have WIFI switched on in Airplane mode?

View more options
12: Established

@ArthurHucksake wrote:

What did you do to test? Have WIFI switched on in Airplane mode?


Yes.

View more options
2: Seeker

Hi mate, I just rang Vodafone and they enabled it for me.

I was sceptical, but five minutes later and booom..... I have WIFI Calling and VoLTE. 

It says VoWIFI at the top. Disable WIFI, and it goes to VoLTE. 

 

View more options
2: Seeker

Thanks.... turns out it was the phone provider.

I wonder if Harry has the same issue?

View more options
12: Established

Did it show as enabled in my Vodafone before they enabled it though?

View more options
2: Seeker

Yeah, it did. But for whatever reason it wasn't actually active.

I requested over the online chat thing, took five minutes.

View more options