main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Android

P20PRO wificalling

Highlighted
4: Newbie

Hi anyone know if WiFi Calling will work with the P20PRO and if not will it be activated shortly

Thanks for any info,

 

Stew

 

View more options
189 REPLIES 189
Highlighted
17: Community Champion

Hi @stewiebrown it's not yet showing on the list here

 

https://www.vodafone.co.uk/explore/network/network-improvements/wi-fi-calling/

 

You would expect it to as the P10 is on the list but it will just be a matter of keeping an eye out or watching the blog to see if it gets added.

 

I take it there is nothing in the settings yet?

View more options
Highlighted
4: Newbie

Noting in the setting as yet, Tried to active last night no luck, 

View more options
Highlighted
17: Community Champion

Have you tried a manual firmware update? Just in case.

 

A mate I work with picked his up on Friday, I will have a look at his tomorrow.

View more options
Highlighted
4: Newbie

Both the P20 and P20 Pro should support Wi-fi calling.  You need three things:

1. A plan that supports Wi-fi calling - most on these phones seem to.

2. To text 'CALLING' to 97888 - Vodafone will then set the service up for you.

3. Enabling certain settings on the phone - and this is where it all goes wrong, as they don't seem to be there !

I have had 3 tedious chats and one call with Vodafone support on this, each going over the same ground.  Basically they do not know how to fix this.

Eventually I went to the Huawei support Web site and looked at the manual - consumer.huawei.com/en/support/phones/p20-pro/

This says that you need to go to Settings >Wireless & networks > Mobile network and turn on VoLTE calls and turn on Wi-fi calling.  I do not have those options in my settings - anyone else have them ?

It also says that you need to go to the phone dialler and go to > Settings > Wi-Fi calling, enable Wi-Fi calling. Touch Mode and follow the onscreen instructions to set the preferred network.  I do not have those settings - anyone else have them ?

It appears that we need a firmware update to provide these features - I have tried numerous times, but no update is available at the moment.

If anyone has further info on this, then please post here.......

View more options
Highlighted
17: Community Champion

Hi @Steve928 that's normally the case, a firmware update is rolled out the the new device once Vodafone have tested it. Hopefully it should come fairly quickly for you and the other users.

 

Hopefully the team here can feed back and ensure that the firmware can be rolled out (provided they are going to support it !!).

View more options
Highlighted
4: Newbie

Gave it ago if your mean going to setting about and update? Will await to here from you tomorrow, was hoing someone from vodafone was going to comment. 

View more options
Highlighted
17: Community Champion

My mate just noticed this in his main settings page.

Screenshot_20180410-200517.png

 

 

 

View more options
Highlighted
17: Community Champion

H activated it and it's working for him.

View more options
Highlighted
4: Newbie

That's very interesting.  I have no recollection of this being one of the 'Suggestions' on the list I had, but too late now as I 'processed' all the items on it and I have no idea if there is any way of getting the list back to check.

However, this does suggest that there is an option/setting/switch somewhere on the phone that enables Wi-fi calling.  I assume that he also sent the 'CALLING' text to Vodafone as I was told that this was a pre-requisite for Wi-fi calling to work!?

I've just been through every setting in turn again (including the developer options which I turned on) and I can't see it.

I'll call Vodafone tomorrow afternoon and will report back if I find anything that helps.

View more options
Highlighted
4: Newbie

Hi,

I too don't have that option, I  have actived WiFi Calling by text. I was wondering where the phone was purchased mine was CPW  Maybe a vodafone firmware? 

Would love to get this working.

 

 

 

 

 

View more options
Highlighted
17: Community Champion

His was direct from a vodafone store.

View more options
Highlighted
4: Newbie

Mine was direct from Vodafone - order placed over the 'phone.

Is he able to check in Settings >Wireless & networks > Mobile network and see if there are settings in there for VoLTE?

And also look in the dialler to see if there is an option to turn on Wi-fi calling?

Thanks.

 

View more options
Highlighted
17: Community Champion

Will try and catch him tomorrow but there was nothing in the dialler settings when we looked on monday.

View more options
Highlighted
4: Newbie

Spoke to Huawei today via live chat.

 According to them,  Vodafone needs to active the  Wifi calling option, a firmware update is not required as  the fuction already exists on the phone awaiting activation.

 

 

View more options
Highlighted
4: Newbie

Is that per phone, or globally ?

According to one poster a friend of theirs is using it, but clearly some of us (despite sending the SMS to Vodafone) cannot !  I'm just about to call Vodafone.

View more options
Highlighted
4: Newbie

I think I have the solution - well, it's worked for me !  Another call to support (30 mins this time), being very insistent that it is a Vodafone issue, as they wanted me to contact Huawei as "all their settings were correct"!

I was able to refer to stewiebrown's post about his live chat with Huawei, saying that the phone was ready for Wi-fi calling and it was for Vodafone to set it.

During the three previous chats and one telephone call I was assured that my 'CALLING' text had been recieved and Wi-fi calling had definitely been activated. During this last call the operator kept pushing tech support to double-check everything and guess what - it had not been rolled out through the network. They reset it and it was there on the dialler (Wi-fi calling disabled -> set to enabled) within a minute.

So, if it isn't working for you after your text, then CALL support and suggest that they re-provision this facility.

Phew!

View more options
Highlighted
4: Newbie

@steve928

Did you receive a text with the re-provision?  As been told one has been sent, but with the new system they are not alway received as texts  and I'll need to reboot the phone in half hour if no text received.

 

If not I'll get back onto them.


Thanks for your help.

 

View more options
Highlighted
4: Newbie

I was told that I would, but I didn't get one.

I don't think that I even had to restart the phone - it was just there !

View more options
Highlighted
4: Newbie

Did it  take long still waiting, unless I'm missing something take it just in setting? 

View more options