main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

P30 Pro WiFi Calling. 😠

Highlighted
3: Seeker

Vodafone sort yourself out. I have not had WiFi calling since February and done every thing from support, chat and in store.

I'm paying over Β£70 unlimited plan a month for setting that don't even work. There must be a way you can send through the setting just like mms settings?

I'm sick of this, vodafone is not providing a service you offer. I think a complaint to trading standards in order.

View more options
7 REPLIES 7
17: Community Champion

What have you carried out thus far to try and get Calling Over Wifi working @DOMBAMBER  ?

 

Ask the agent to force the phone via sending an OTA configuration update that should provision your phone for Calling Over WiFi. 

 

My apologies if you've tried the below already.

 

"Register for Vodafone Wi-Fi Calling

Text the word CALLING to 97888

This is a free text which will add the service to your account.

You should receive the following confirmation text:

Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.

 

If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us.

 

Once you receive the confirmation text, switch on Wi-Fi Calling in your settings

Go to Settings, scroll down and choose the Application icon.

 

Choose Phone and scroll down until you see Wi-Fi Calling β€“ select the box beside this option.

 

A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
13: Advanced Member

I think it took me several calls to find someone with the skill to send the OTA update but now Wifi calling is working fine on my SIM free P30 Pro.

Well I say working fine, everytime you unlock the phone and wifi calling is active you get a notification. It's very annoying. Vodafone have known about it since the P20 Pro days last year, and seem incapable of fixing it.

View more options
3: Seeker

It highly annoying nothing has been done about this issue. 

 

I am giving vodafone 14 days to rectify the issues. Then I WILL be seeking help and a complaint to trading standards. 

View more options
13: Advanced Member

So just to confirn, you do not see the wifi calling option or it's just not working?

View more options
3: Seeker

Screenshot_20190818_112435_com.myvodafoneapp.jpg

 

Screenshot_20190818_112344_com.android.phone.jpg

 

View more options
13: Advanced Member

Once the images are approved hopefully we can help further.

View more options
13: Advanced Member

@DOMBAMBER, well the good news is that your phone allows you to turn it on. The OTA update does this, so hopefully that's not necessary now. The fact the start date shows 2016 though suggests they haven't recently removed it and re-added it. When they did that with mine, the date changed to the date it was re-enabled.

I assume you have tried airplane mode with wifi on, to confirm it's not working? I would keep on at Vodafone, ask to escalate to Level 2, get them to reprovision wifi calling, and keep on at them to try various things. It helps to call from another phone though, as often you will be cut off if they reset your settings.

View more options