main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Android

Samsung S20 - WiFi calling

Highlighted
3: Seeker

Does anyone have any clue as to when the S20 will be supported? I live in area with no service and rely fully on WiFi for the functionality of my phone when I am at home. 

 

Being as though the S20 is realistically the only android phone I'd want right now, I'd have to leave Vodafone to get one that works at home.

 

Thanks!

 

View more options
6 REPLIES 6
Highlighted
17: Community Champion

It certainly has the capability of supporting Calling Over Wi-Fi even though it's not yet on the Vodafone page.

Try asking a Vodafone agent to turn the feature on and send an OTA configuration and then look in your myvodafone.

This was from an old thread.

Not wanting to celebrate to soon but I think my problem with making wi-fi calls on my S7 has been solved. Yesterday I decided to do a check/update of my phones software via hard wire, rather than via wi-fi. Was uncertain that this would help but decided it was worth a try. Re-booted and 12 hours later re-booted again. I then did the following:

Opened "settings"

Selected "Connections"

Selected "apps"

 Clicked on the 3 dots (top right of screen)

Selected "Switch on System apps"

Scroll down to the first of 3 Phones and select

Select "More settings" at bottom of drop down box

Select and enable "Wi-F-calling"

Back to home page and re-boot.

I left my phone overnight and when I checked a small phone/wi-fi icon had appeared on my home screen. Tested calling and is appears to work as one would expect. 

Lets hope that the issue is resolved completely, my thanks to all the helpful posts.

 

 

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui 2.1  / Android 10.

 

Samsung Gear s3 Frontier Watch.

Samsung Galaxy Buds.

View more options
Highlighted
3: Seeker

Thanks for this. I'd really prefer not to have to send the phone back!

 

I think I've found something (although the menu options were slightly different - I did manage to find 'Wi-Fi calling' in the apps list and turned on the permissions for the 'telephone'. I'm sort of hopeful because that was on 'denied'.)

It's not worked right away but I shall leave it over night and see what happens!

View more options
Highlighted
17: Community Champion

If you haven't, it would be worth opening the phone app and then seeing if wifi calling is available in its settings.   I'm surprised it isn't on by default, tbh.   I set up a Sony L3 a while back and the wifi calling icon appeared in the system area of the notification bar almost immediately.

View more options
Highlighted
2: Seeker

I've been having this issue as well - I thought the nut might have been cracked following the steps you outlined above, alas no...

 

I too have enabled the permission within the app settings as it was denied for me as well. I rebooted the phone half expecting it to work and it didn't :Sad_face:

 

Is this something to do with the 'Wi-Fi Calling' having permissions with 'Telephone' and not 'Phone'? When I go into the 'Phone' app, 'Telephone' has permission but not 'Wi-Fi Calling' nor is that an option. I was hoping that as 'Wi-Fi Calling' has access to 'Telephone', it would somehow carry through the permission to 'Phone', which is the default used for calls etc. 

I've been on the phone, online chat so many times over this and zilch. I keep getting assurances and have even specified asking for the OTA update and nada... 

View more options
Highlighted
3: Seeker

I've managed to get mine working. No idea how but these are all the things that happened:

 

Sent the text to turn Wi-fi calling on, didn't get a reply after 24 hours so went on to the chat and got through the tech team who apparently sent the configuration settings to my phone. I didn't see anything but I know something changed because the option to toggle wi-fi calling on/off appeared in the dialler settings and also in the quick settings, whereas they were not there before. it doesn't appear in the normal settings under 'connections', which it is supposed to be.

I also turned on permissions for 'telephone' on 'Wi-fi calling' on the apps menu (you need to turn on system app view).

I then went in to My Vodafone and turned the Wi-fi calling off. Restarted my phone, waited for a bit. Turned it back on, restarted. Toggled wi-fi calling in the quick settings on and off a few times. Then it just started working. I now have the icon next to my wi-fi symbol (a little phone with little wifi bars).

 

Sorry that's not terribly helpful - I'm not sure what actually did it in the end!

View more options
Highlighted
4: Newbie

In my case WiFi calling on Galaxy S20 ultra was working straight out of the box - nothing else required. I got the phone unlocked - not from Vodafone.

View more options