main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

wifi calling s8 plus

4: Newbie

unfortunately nothing has fixed the issue. The wifi calling feature does not even show up in the phone settings menu.

View more options
12: Established

Sorry to hear that only other thing you can try is a new SIM card.

View more options
4: Newbie

This is Vodafones response.

Hello,

We?ve just investigated the fault you are experiencing with wifi calling. Your phone is currently running the latest version of Android (Nougat) which regrettably is currently incompatible with wifi calling, as soon as an update is released to Android wifi calling will resume normal service on your phone.

Regards,

View more options
4: Newbie

Unyet, I have the s7 which is also running the latest version of android Nougat and although wifi calling wasn't working when I got the phone (there was no sign of it anywhere) a quick call to Vodafone and hey presto the wifi calling toggle appeared in the CALL settings (see my other posts) and Bingo ... I was making my first wifi call.

So if it's specifically a problem with Nougat as it seems you are suggesting then how come I have it?

or is it a problem specific to the s8?

Maybe i'm missing something here??

View more options
4: Newbie

I must admit I am confused.  I can only tell you what Vodafone technical team have said and that the feature is not on my Samsung S8 plus.

View more options
2: Seeker

 

 

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

View more options
2: Seeker

Jacko20jj wrote:

 I need wifi calling for work if it's not an option mine will be going back can any one from vodafone help or even comment?

 

 

 

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later


 

View more options
2: Seeker

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

View more options
2: Seeker

@jacko20jj

 

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

View more options
2: Seeker

@bazjohn11

 

Just got mine working after i had Vodafone activate wifi calling on my account last week. 

 

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

View more options
2: Seeker

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

View more options
2: Seeker

benjameshodges wrote:

I also do not have the option of Wi-Fi calling. I have had the feature enabled on the Vodafone website since 19th April and received my S8 on 20th April. I still do not have the option even visible in the settings. Gone through many hard resets, removing of SIM etc. 2 colleagues also do not have Wi-Fi calling available from their Vodafone Samsung Galaxy S8s. This is a wide issue with Vodafone and I'll probably be changing provider soon as I require Wi-Fi calling at my workplace.

 

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later


 

View more options
4: Newbie

Sorry can't thank anyone if this still does not work after following all the instructions. 

View more options
4: Newbie

I've not read the whole thread, but I hope my experience will help you.

I have a Galaxy S8 Duos (SM-G950FD) which I got from Singapore, and I have changed the CSC code to XEU (does not void warranty as it is a built in function on Multi CSC phones). That means that for all intents and purposes my phone acts as if it is meant for UK markets. It has latest firmware on it (AQG5 at time of writing) and WiFi calling did not show up under Phone > Settings (https://www.youtube.com/watch?v=00ZT_Uqf5AE). Following a tip from someone else on another forum, I contacted Vodafone and asked them to turn OFF Wifi Calling on my account (while my phone was OFF). I then turned phone on and let SIM connect to network and waited for a few minutes. I then turned phone OFF (and removed SIM, JUST to be sure) and asked them to turn WiFi calling ON in my account. After 15 minutes, I turned my phone back on, connected to Vodafone network and magically, WiFi calling option now shows under Phone > Settings, and I am able to enable it.

 

I can therefore say that WiFi calling does indeed work on Vodafone (I have a RED account) with a Galaxy S8 with the latest firmware and an XEU CSC code (goto Settings > About Phone > Software Information to check this information, or install this app to check - https://play.google.com/store/apps/details?id=org.vndnguyen.phoneinfo

 

Really hope this helps you.

My current devices -

Galaxy S8 Duos (SM-G950FD)

Galaxy Tab A6 10.1 (SM-T585)

View more options
2: Seeker

Steps to enable Wi-Fi calling on galaxy S8 and galaxy S8 plus. Wi-Fi calling use to text & video call from indoor locations where cellular signal poor in your galaxy S8 device.

 

Settings > Connections > Wi-Fi calling > Enter address, city, state & other details > Ok > Enable Wi-Fi calling

Quickly turn on / turn off Wi-Fi calling on Samsung galaxy S8 and galaxy S8 plus:

Swipe down from the notification bar > Wi-Fi calling

 

View more options
4: Newbie

Great if wifi calling actually showed up in settings.  It shows up under system Apps but is cannot be made active.

 

View more options
Moderator

@nigelstgeorge So we can take a look into this for you, I've sent you a private message.

Once we receive your details, we'll be in touch as soon as possible.

View more options
4: Newbie

@nigelstgeorge - your Wifi Calling you see under System Apps is simply the app / service that is used when using WiFi Calling.

Basically, for wifi callin to work, you need -

1 - A phone and Firmware that supports it (you have this, as WiFi calling shows under System Apps)

2 - WiFi supported and enable on your network (Vodafone does support it and I assume you have confirmed it's enabled on your account)

3 - The phone model and firmware (more specifically, the CSC Code configured on your phone's firmware) need to be supported by Vodafone - this requirement could be an issue for people that purchase phones from other countries or from other networks and then use a Vodafone SIM in them

4 - Your phone to 'realize' that WiFi Calling is enabled on your SIM card (as I said, for this to happen for me, I had to get Vodafone to DISABLE WiFi Calling on my account and then enable it again)

 

I assume that 1 to 3 are all valid for you, so let VodaFone custoemr support assist you further, as per the private message they sent you. I really hope it's as simple as toggling WiFi Calling off and then on again on your SIM (with some time inbetween for your phone to register the change - as per my post earlier).

 

If you get it working, please do let us know how you did it. Good luck !!

 

My current devices -

Galaxy S8 Duos (SM-G950FD)

Galaxy Tab A6 10.1 (SM-T585)

View more options
4: Newbie

Hi Natasha.  Certainly items 1-3 are ticked as it was a Vodafone supplied phone and the App is showing.

Vodafone has confirmed twice it is turned on.  Here is the hazy bit - if i go into my Vodafone account online and look at my services I can turn Wifi Calling on and off.  I have done this and nothing changes.   I have not as yet actually got Vodafone to turn it off and then on again later.  I will try.

View more options
4: Newbie

If you're replying to me, then my name is not Natasha :-) Natasha is the post before me, and I think works for Vodafone. Natasha would probably be the best person to assist you with them actually disabling it on your account (them doing it is different toyou doing it using your online account) - I was just pointint out the things I had found during my time getting WiFi calling working on my phone. That said, my phone is actually a Singapore sourced phone and I was able to get WiFi calling working with my Vodafone SIM, so I think you have a good chance of getting it working with Vodafone Customer Support's help.

My current devices -

Galaxy S8 Duos (SM-G950FD)

Galaxy Tab A6 10.1 (SM-T585)

View more options