main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

wifi calling s8 plus

4: Newbie

Vodafone technical team have finally enabled wifi calling on my Samsung S8 plus phone.  However, does anyone know of any way of actively testing this to make sure the option works?  I am told there should be a little phone symbol alongside the wifi signal status at the top of the phone but looking at mine I am not sure if the strange symbol alongside my wifi signal is indeed a phone symbol.  So advice to test much appreciated.

View more options
4: Newbie

Glad to hear you got it sorted. Was it just a matter of disabling it and re-enabling it on your account ?

 

When I had it on my phone, I actually received a notification in the Notification area that said WiFi Calling. I THINK it only appears when your phone signal is 'low' which means that the phone will use WiFi Calling instead.

Not sure if this was necessary, but after I got my WiFi Calling to papear on my phone, I sent a text to 97888 with the text CALLING in it. This was mentioned on this page as something requried AFTER you turn on WiFi Calling in Phone settings - http://support.vodafone.co.uk/Using-our-network/Wi-Fi-Calling/67269365/How-do-I-set-up-Wi-Fi-Calling...

 

After all this effort, I have no turned off wifi calling on my phone, because since I enabled it, my battery usage seemed to go through the roof, with the main culprit being "Android System". Since turning it off, my phone battery usage seems better. I'm not saying it WAS wifi calling that caused it, but it was a co-oncidence it happened at same time. I may turn it back on to see if the same happens.

My current devices -

Galaxy S8 Duos (SM-G950FD)

Galaxy Tab A6 10.1 (SM-T585)

View more options
4: Newbie

It seemed I needed a new version of Android from Samsung which came out very recently. To be honest I did the end of July update and it was not working then but someow is now showing in the phone settings. So activated it and hope all works.  Does all seem very much hit and miss this wifi calling although with a bad mobile signal could be very useful if it works well.

I think I will leave this post for a while and see how things go.

View more options
2: Seeker

Hoping for some help please - Have S8+ bought from Samsung, with latest software update installed and I don't get an option in the phone settings to enable wi-fi calling. It doesn't appear. I have text CALLING to 97888 and had a reply that wi-fi calling will be enabled in the next 24 hours. Will I see the setting appear once it's been enabled by Vodafone? 

 

 

View more options
Moderator

Hi @COGS, this option should now appear on your phone. 

If this doesn't show, please ensure you've followed our steps.

Let us know how you get on 

View more options