main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Android

wifi calling s8 plus

12: Established

Yep I can confirm that wi-fi calling is not working as no-one can here me at all. 

View more options
2: Seeker

Solved no Wi-Fi calling on my phone... After many phone calls and a chat session I thought I would try something new 

1. Text "CALLING" to 97888. And wait for conformation text telling you Wi-Fi calling is active (even if like me you know it is.

2. With phone turned on and a signal eject your sim card wait about 10 seconds and re'insert ( i had to do this twice)

3. wait for a text from Vodafone saying you have a new SIM and install setting.

4.  Go to phone app.. click the three dots... select settings and scroll down to what should now show wifi calling toggle

 

 

View more options
2: Seeker

Solved no Wi-Fi calling on my phone... After many phone calls and a chat session I thought I would try something new 

1. Text "CALLING" to 97888. And wait for conformation text telling you Wi-Fi calling is active (even if like me you know it is.

2. With phone turned on and a signal eject your sim card wait about 10 seconds and re'insert ( i had to do this twice)

3. wait for a text from Vodafone saying you have a new SIM and install setting.

4.  Go to phone app.. click the three dots... select settings and scroll down to what should now show wifi calling toggle

 

 

2: Seeker

Solved no Wi-Fi calling on my phone... After many phone calls and a chat session I thought I would try something new 

1. Text "CALLING" to 97888. And wait for conformation text telling you Wi-Fi calling is active (even if like me you know it is.

2. With phone turned on and a signal eject your sim card wait about 10 seconds and re'insert ( i had to do this twice)

3. wait for a text from Vodafone saying you have a new SIM and install setting.

4.  Go to phone app.. click the three dots... select settings and scroll down to what should now show wifi calling toggle

 

 

View more options
1: Seeker

Vodafone is working so hard to earn irrelevance to their customers.

 

So ridiculous are their policies. Vodafone makes the life of thier customers more complicated.

 

S8 can support Wifi calling. No piece of engineering is required from Vodafone apart from sending the Carier updates to their customers but still they over complicate this process by excluding different set of customers from these updates that costs nothing to Vodafone. I would like to see Vodafone going out of this business. They dont understand their customer needs.. totally hopeless company.

 

My situtation is I have a corporate SIM on S8 that I have purcahsed from Samsung. I have virtually no signal at home. Whenever I work from home, to join the office conference calls, I'm forced to use my personal number [Luckly that number is from EE]. Had there be an Wifi calling, it would have been so much easier for me to join those long calls and Vodafone would have benefit by having more calls going through their network.

 

 

View more options
10: Established

after speaking to a few different department's last night my wifi calling is now a option on my S8+ as well 

View more options
12: Established

Hi all could someone who has wi-fi calling on there phone try and make a phone call and see if the other person can hear you on the other end please.

View more options
4: Newbie

When I tried it yesterday most calls were one way. Some worked, but a minority. I switched wifi calling off. 

View more options
3: Seeker

I have been both to store and called telephone support. They have both fobbed me off. I know wifi calling is activated but I don't think I ever received a config message. Do I need a config message or any tips to get them to send it to me as I never get anywhere with them? The store even told me to contact samsung!

View more options
12: Established

Hi first of all do you have wi-fi settings on your actual phone.

 

If no goto online chat and ask them to check your account to see if it's been activated if it ain't they will activate it for you then in around 15 to 20 mins you turn off your phone and back on then you will get the messages that you will need to install.

If you have wi-fi calling on your phone not the on vodafone app ask them to resend you the configuration messages again.

View more options
2: Seeker

Nobody can hear me but I can hear them. Even when I switch Wi-Fi calling off it still defaults to Wi-Fi calling. I also cannot receive or send texts without mobile signal but with Wi-Fi calling on. 

 

This was so much easier on o2 and my EE iPhone works fine with Wi-FI calling.

 

This has been an absolute sham by Vodafone and if they are not throwing money at this to get their team to fix this, then they are all wasting our time.

View more options
4: Newbie

Im also having problems with WiFi calling and expericencing the same one way sound as others.

 

I enabled WiFi calling today and my phone menu was updated (S8), I set the toggle to on and after a minute the WiFi calling icon appeared.  Unfortunately when I make or receive calls the caller cannot hear me, but I can hear the caller.  Have tried rebbot and toggling off/on but still get the same.  Looking at the other posts this is probably a firmware or backend issue.

I contacted online chat who, to be honest, were next to useless and advised me to contact samsung!

Hopefully one of the Voda team can update on this for us.

View more options
10: Established

same here I can hear the other person they can't here me and after a few secs the call drops 

View more options
3: Seeker

The 3rd telephone support agent was about to get my wifi calling active. It was simply a case of sending the configuation over which the first two did not do. Instead they sent me round the houses. I have made a couple of test calls which seem to be okay (time will tell). I find wifi calling only comes on in locations with bad reception rather than all the time, is this meant to be the case?

View more options
Moderator

Hi Guys,

 

Keep an eye out on our Wi-Fi Calling page for any updates. 

 

View more options
Moderator

@benjameshodges
 

The issue's being investigated at the moment, we'll update the thead once there's any progress.

Thanks for your patience with this.

View more options
4: Newbie

none of my calls using wifi calling is audible to the other person. even on turning off wifi calling, the icon does not go away and still calls are not audible to the other person.......

View more options
Anonymous
N/A

Wifi calling worked for me right away after enabling it on my phone (my account was enabled for wifi calling as I came from a iPhone 7 Plus before)

View more options
2: Seeker

What is the actual problem with vodafone enabling wifi calling??? I have an s8 and get a terrible signal at home so wifi calling is a must, I've literally tried everything to get wifi calling enabled  been on live chat been into shop, tried everything more than once all  tried all solutions that people have tried on here an nothing!! I'm starting to lose patience here with vodafone, I've been a customer 23 years and have 2 phone contacts, and nobody at vodafone seems to definitely know why my phone can't get wifi calling enabled!! It's making me angry to the point I'm gonna cancel both mobile contracts as soon as I can!!! Totally lost all confidence in vodafone as a company!!😤😤😤😤

View more options
Administrator

@taper We'll update this thread as soon as we have an update on how to enable this feature. 

View more options