main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

This is a locked archive and content on this page may no longer be up to date. These posts and threads have been archived for reference only.


Dongle - Connected But No Internet

2: Seeker

Dongle: Vodafone K3570-Z

Connection: GPRS (Solid Green Light)


I am very frustrated with the connection of my mobile broadband dongle. For some reason, I can get a connection but there is no internet access at all. There is no upload or download whatsoever. I have just put a topup of £10 on it and the software tells me that it is there and none has been used.


I have tried the following:

Disabling it and re-enabling it.

Reinstall of the software.

Disabling security on the laptop.

Installing the business version of the software instead of the lite version.

Removing the dongle physically and putting it back in.

Enabling the auto-connect feature and manually connecting with the software.

Removing the sim card and giving it a blow (Just for reassurance).


I only got it the other day for college and it’s really irritating me that it’s not working.

Thanks for any help provided. It is much appreciated!



View more options
Moderator (Retired)

Hi awesumlewy,


Firstly, a very warm welcome to the eForum .


Can you let me know exactly what happens when you try to load a web page? Do you see any error messages at all? Also, which web browser are you using? It may be worth trying an alternative one, such as Google Chrome or Firefox.


Also, this could just be down to the signal in your area being poor. If you're seeing a solid green light then the modem is definitely establishing a network connection, so is working correctly. However, GPRS will never be particuarly fast when it comes to internet speed, especially if you're connected to a very busy mast. If you could let me know the postcode of the location you're using this in, then I'll be able to check on this for you.


Finally, if you're using an older version of the VMC (Vodafone Mobile Connect) software then it may be set to only connect via GPRS and not 3G. This can be checked by going to Manage Devices > Select Modem > Edit > Set to 3G preferred. You'll also be able to update the software here: VMB Version 10.


If you can give those suggestions a go and let me know the answers to the questions, then I'll be able to assist you further.


Kind Regards,



View more options
2: Seeker

Hi, this is happening to me to only I will sometimes get pages and sometimes not, even following a link from a web page that did load.


When it stops working the browser (I E) simply hangs with a message at bottom saying waiting for http://what ever it is you typed and you wait and wait, sometimes clicking refresh wakes it up but it is so unreliable that it is unusable.


Its always connected and always has 3 signal bars just no traffic.


My thought was that because it is the one with no time limit maybe vodafone are doing it to get me so frustrated that it flies into the bin, which is a shame because it is quicker that my home connection and would use it a lot if I could.


Anyone got any ideas PLEASE .

View more options
2: Seeker

I have the EXACT same problem as you have, and that is the same exact problem this other user a few threads down has ... What's wrong with Vodafone USB 3G?

View more options
Moderator (Retired)

Hi there farmboy,


Many thanks for your post about the pages not loading on your dongle.


Please could you confirm what OS you are running and any service pack versions?

Please could you also try loading the same page in an alternate browser?

Which version of Vodafone Mobile Broadband are you using?

If it's an older version, please update to the latest approved version.

Finally, will the device work in another machine in the same location?

It's also worth trying the steps in our Network Troubleshooting thread.

If you are still experiencing the issue having completed these steps, post the template with your answers here and we'll get back to you as soon as we can.



View more options
2: Seeker

After wasintg HOURS on this issue I have managed to get mine working using the following ... I unstalled and uninstalled the vodafone softare first ....


Creating a Manual Dial Up Networking Connection on Windows 7:


In order to set up a manual dial up networking connection, first enter the initialisation command in the modem properties. This specifies the Access Point Name (APN) the device is going to connect to:

  1. Go to Control Panel and select System (visible when viewing by Small or Large icons) and then Device Manager from the left hand menu

  2. Expand the Modems heading and go into properties for the Vodafone Mobile Broadband modem

  3. Go to the Advanced tab

  4. Enter the initialisation command as AT+CGDCONT=1,”IP”,”internet”

  5. Click apply and ok


Once done create a new dial up networking connection as follows:


  1. Start Menu / Control Panel / Network and Sharing Center / Set up a new connection or network

  2. Choose “Connect to the Internet”

  3. Ensure ”No, create a new connection” is selected and click Next

  4. Click on ”Dial-Up”

  5. Select  the Vodafone Modem  (if there are no other modems installed on the system you will not see this option).

  6. Enter the Phone number:  *99***1#

  7. Username & Password = web & web

  8. “Connection Name” = a name of your choosing.

  9. Click “Connect” to complete and test the connection. Note: Please ensure Vodafone Mobile Connect/Vodafone Mobile Broadband is not running before attempting the connection.

View more options
2: Seeker

Dongle:K4201 I

Signal: 3G (Blinking Blue)

I have installed the Vodafone software succesfully and am able to connect too. But when I try to open any webpages, they don't open and an error message is shown viz. "UNABLE TO CONNECT TO INTERNET" !

This happens with every browser. The Vodafone software conitnues to show the duartion of connectivity and also the speed of uplink and downlink. I am currently using Windows XP SP3. 

I have tried re-installing the software but nothing helps.

Please suggest a solution to this problem!

View more options

Hi Agni


Do you receive any error messages other than the one you state?


Have you installed any software that coincides with the time that this has stopped working?


Please uninstall the software through your control panel, restart your computer and check that this has been fully removed before re-installing it.



View more options
2: Seeker

Hi DaveCD,

Thanks deeply for your help. Here is my report :- 

No, there are no other error messages displayed. 

As for any other software, I did install another software previously, but I had completely uninstalled it before installing the Vodafone software. 

Surprisingly, when I uninstalled my Vodafone software and reinstalled the other software, the dongle runs perfectly! There must probably be some sort of problem with my Vodafone software! Otherwise the dongle's working fine. 

Any help now??

View more options
Moderator (Retired)

Hi Agni,  


What other software were you using?


Try running the Vodafone cleanup tool to remove any traces of old installs.


You can download it from here.


Once you’ve done this, download the full version of Vodafone Mobile Broadband (VMB) software from here.


Once it’s installed, try to connect again.


If you still can’t connect, try the troubleshooting section of the K4201 quick start guide.


You can download it here.





View more options
2: Seeker

Hi Andy, 

Thanks for your suggestion. I will fo as you say and will nform you shortly about the results.


View more options