main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community


HTC Desire - Internet Settings

2: Seeker



I can no longer access the intenet on my HTC Desire.

When i looked in the APN setting i only had the wap settings not internet, so i created the following as suggested on other posts but still no luck connecting.


Name: Vodafone Internet

APN: internet

Username: web

Password: web


Do you have any ideas why this is not working for me?




View more options
17: Community Champion


Don't know if you've tried these yet (from the Help Centre) but it might be worth going through the full walkthrough guides listed on the help page below, just to check everything is in place:


HTC Desire WAP and Internet Settings


Failing that, if you can let the moderators know:


- How long the problem has been occuring

- What error message you get

- If you place your SIM (if possible) in another Vodafone device do you still have the same problem

Vodafone customer since 2004. Attempting to help where I can on the Community

View more options
9: Established
Hello there,

The below might only be helpful if the settings are 100 percent correct and you have followed redpages instructions above.

If you didnt touch the settings in the first place and it just suddenly "stopped working" try checking out the sim card. You need to make sure that the two different aspects of the sim card are both updating on the network.
Try dialing in


Call this number as though you are calling a normal number, so just type it in and press dial or call. It will take a few moments ( as long as you have signal at the time) and then bring you a reply back. Two replies infact. The first one that you see (we are looking for a date and a time here - and there will be two entries) will be the "voice" side of the sim card, that should be -in a perfect world- updated first, the second one will be the "data" side of the sim card which should -again in a perfect world- be updated JUST a few seconds after the first one.

If that second one is anything more than 2 hours ago (from the current time) you will want to do a manual roam on the phone (this does not always work!) and check again. If the second date on the sim has not updated, give customer services a call and ask them to "reregister your sim on the network"

NB!! They will then do some fancy things on the network and hopefully force it to update. IF you do this please make sure that you are not calling from the phone at the time (landline on 08700700191) and you have the phone turned off (battery out of the phone!) while you ask them to do this. If you ask them to reregister the sim on the network with the battery in and the phone on it will stop the phone from working until you restart the phone.

Hope this helps.


ps. if you like, post the two dates and times - only the dates and times (dont put the other info you see on that screen onto the forum, as i think its unique to your number) and I can let you know if they are updated correctly.

example from my phone is below

CS : registered 05-dec-2011 21:31:29
PS: registered 05-dec-2011 21:31:33

you can see mine updated yesterday evening.
View more options
2: Seeker

Hi, Thanks for that, but that page is no help really.


The problem has been occuring for about a week or so now.


When i click on the internet i get a message that says - no network connection, browser cannot load this page.


my two access point setting are as follows, not sure which one should be select either, im assuming internet.


vodafone Internet


Name: Vodafone internet

APN: Internet

Proxy: not set

Port: not set

Username: web

Password: web

Server: not set

MMS Proxy: Not set

MMs Port: : Not set

MMS Protocol: : Not set

MCC: 234

MNC: 15

Authenticate Type: Not set

APN Type: Not set


vodafone wap


Name: Vodafone wap


Proxy: not set

Port: not set

Username: wap

Password: wap

Server: not set


MMS Proxy:

MMs Port: : 8799

MMS Protocol: : wap 2.0

MCC: 234

MNC: 15

Authenticate Type: Not set

APN Type: *


Any help would be appreciated.





View more options
16: Advanced member

The settings should be 

1.Press the MENU key
2.Touch Settings
3.Touch Wireless & networks
4.Touch Mobile networks
5.Touch Access Point Names
6.Press the MENU key
7.Touch New APN
8.Touch Name
9.Enter Vodafone WAP, touch OK
10. Touch APN
11. Enter:
For Pay monthly customers:
For Pay as you go customers:
12. Touch OK
13. Touch Proxy
14. Enter, touch OK
15. Touch Port
16. Enter 8799, touch OK
17. Touch Username
18. Enter wap, touch OK
19. Touch Password
20. Enter wap, touch OK
21. Press the MENU key
22. Touch Save
23. Touch the circle to the right of the Vodafone WAP profile you have just created
24. Press the Home key to return to the home screen
25. Touch the MENU key
26. Touch All programs
27. Touch Internet
28. Press the MENU key
29. Touch More
30. Touch Settings
31. Touch Set home page
32. Touch Set home page
33. Enter, touch OK.


These are the wap settings and it looks like you have no proxy settings in there they need to be in there for it to work 

taken from Vodafones settings

Now the internet settings look ok 

But you can check on

But it looks like a wap problem to me 

If your not bothered about setting up a VPN network to a company then all you need is wap

View more options
Moderator (Retired)

Hi shaungibson1,


Thanks for updating the thread.


Could you give the settings that Northern-dj has posted a go and let me know how you get on please?





View more options