main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

This is a locked archive and content on this page may no longer be up to date. These posts and threads have been archived for reference only.

Archive

What version of Vodafone Mobile Broadband software can I use with my modem?

Moderator (Retired)

Hi Everyone,

 

You will find a full list of modems below with information regarding which version of Vodafone Mobile Broadband software that can be used with each of them.

 

Once you have found your modem in the list, please scroll to the bottom of the post to find instructions on how to get the correct version of Vodafone Mobile Broadband (VMB) software.

 

The following modems will be supported in Vodafone Mobile Broadband 10.3.400 and future versions of VMB:

 

K4305 
K4201  
K4201-z 
K4202 
K5150
K5005 
K5006-z 
K3772 
K3770 
K3765 
K4510 
K4511 
K3770-z 
K3771
K3772-z 
K3805-z 
K3806
K3806-z

R205

R210
R208
R203-z
R212-z
R204

 

The following USB modems will be supported from Vodafone Mobile Broadband 10.3.401 and future versions of VMB:

 

K5008-z
K4605
K4505
K3565-z
K3765-z
K3570-z
K3571-z
K4505-z
K4510-z

 

The following internal modems will be supported in Vodafone Mobile Broadband 10.3.400 and future versions of VMB for Windows 7 only:

 

Ericsson F3307
Ericsson F3507g
Ericsson F3607gw
Ericsson F5521gw
Ericsson F5321gw
Ericsson H5321gw
Qualcomm Gobi2000
Qualcomm Gobi3000
Huawei E770
Huawei E820
Huawei EM770W
Option GTM382
Samsung GT-Y3100
Samsung GT-Y3300
Samsung GT-Y3400
Acer / F3307
Dell / D5530, Toshiba / F3507g, Lenovo F3507g
Dell / D5540, Lenovo / F3607gw
Dell / D5550, Lenovo / F5521gw
Dell / D5560, Lenovo / F5321gw, HP / hs2350
Dell / D5565
Dell / D5620, HP / un2420
HP / un2430
Acer / EM770
Acer / EM820
Acer / EM770
Sony / GTM382
Samsung GT-Y3100
Samsung GT-Y3300
Samsung GT-Y3400

 

The following modems are not supported by Vodafone Mobile Broadband 10.3.401 or 10.3.400 or future versions of VMB. To use these devices with the Vodafone Mobile Broadband software you will need to use them with a version prior to Vodafone Mobile Broadband 10.3.400.

 

Vodafone B970
E170
Vodafone (Huawei) E172
Huawei E220
E270
E270+
Vodafone (Huawei) E272
Huawei E510
E618
E620/E621
E630
E660A
E800
Huawei E870  

Vodafone E3735
Vodafone K2540
Vodafone K3520
Vodafone K3565
Vodafone K3715
R201
Novatel Wireless
MC950D
Novatel MiFi2352
U740
XU870
X950D   Colt
Vodafone E3730
Fuji Lite
GE0201
Option Etna (GE0301) (RAS)
Option Etna (GE0301) (NDIS)
Magnum Lite
GI0301 (Icon 3)
GI0311
GT 3G Quad
GT Nozomi
GT Ricola    

Vodafone K3760
Vodafone K2525
Vodafone K3520-Z

  

You can download the latest version of VMB here however, if you do need an older version of software for your modem, please post in this thread and one of the team will be able to get this for you.

 

Thanks

 

James

View more options