main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Broadband & Home Phone

Router dropping connection / Apple Airplay / Loss of speed

4: Newbie

It's the connection.  The router shows that it's been up for ages.  But the connection regularly drops.  


My speed HAS dropped from the original speeds I recieved the first few days of being connected to VF, but now I'm on speeds consistant with that I had with BT for years.  Except with BT I could use my own modem and I never had any connection drops.

View more options
4: Newbie

Almost 3 hours later and still no call-back.


So much for 5 minutes / customer service.  A shame as the person I spoke to was very good and appeared to speak to the tech guys directly.

View more options
4: Newbie


Next Day --  Still no reply from Vodafone Tech support.  Pretty safe to say they have forgotten me and it will now be down to me to chase them again and waste my time explaining to 1st line support.


I was just looking on the router and as I was examining the logs....  The WAN dropped..!  Below is the log information.




18.03.2017 12:03:30 WAN connected, WAN type: VLAN Physical Device, service type: data, IP:, device: ppp2 WAN
18.03.2017 12:03:30 WAN connected, WAN type: VLAN Physical Device, service type: data, IP:, device: ipsec3 WAN
18.03.2017 12:03:29 PPP authentication successful System
18.03.2017 12:03:28 PPP CHAP authentication started System
18.03.2017 12:03:26 PPPoE PADS received System
18.03.2017 12:03:25 PPPoE PADR sent System
18.03.2017 12:03:25 PPPoE PADO received System
18.03.2017 12:03:25 PPPoE PADI sent System
18.03.2017 12:02:22 PPPoE PADI sent System
18.03.2017 12:01:49 PPPoE PADI sent System
18.03.2017 12:01:33 PPPoE PADI sent System
18.03.2017 12:01:25 PPPoE PADI sent System
18.03.2017 12:01:21 PPPoE PADI sent System
18.03.2017 12:01:19 PPPoE PADI sent System
18.03.2017 12:00:58 WAN disconnected, WAN type: VLAN Physical Device, service type: data, device: ppp2 WAN
18.03.2017 12:00:58 WAN disconnected, WAN type: VLAN Physical Device, service type: data, device: ipsec3 WAN
18.03.2017 11:54:21 User sucessfully logged in to UI from LAN System

View more options
4: Newbie

Called Vodafone.  25 minutes on the phone.


They have lost all information about yesterday's call and noone was ever going to call me back.


They won't look into the source of the issue (the router) until I 


  1. Go buy or borrow a land-line phone.  As I don't own one.  Then "test that the line works".  I'm sat here getting 60/18Mbs!  Of course it works !
  2. Take the faceplate off my (pretty new) Master Socket with built in filter to isolate the Broadband / Phone line and test using a filter in the Test socket.  This is massive pain in the ##~## (due to location) and I really can't be bothered with Vodafone anymore.

I've had enough.  For now I'm just going to try to live with it.  Can't waste any more time on this.  If it gets too bad I will just have to go back to BT.


Please bear in mind here (as I've explained to Vodafone support several times.  I have been on BT Infinity since the day they started the service.  Never had it go down like this.  There are no hardware faults in the home, this is a Vodafone issue with either the Router or something at the back end.

View more options
4: Newbie

Paul.  Hi.


What exactly did you "turn off" ?  I'm happy to try anything at this point which actually might make a difference.

View more options
10: Established

Andrew - hey there - how new is the master socket ?  It doesn;t coincide with the disconnects does it.


So I have everything turned off... absolutely everything.   No Wifi, no dhcp, no upnp, nothing, no firewall, no media sharing, etc..  I do it all via my better router I love....   Just go through each of the tabs and turn off everything you do not need.


Then I turned on the exposed host option (DMZ) , plugged in my good router wan port to port one of the VF router and gave my router WAN ip address in the same subnet as the routers internal side subnet


So my VF router internal is and my WAN port of my good router is


My DMZ/exposed host I made (yup my good router is then effectively exposed to the internet) and on my good one I turned on Firewall, DHCP (used a different range/subnet So all my internal devices connect on a 192.168.1. and all internet traffic is routed through to   



Then I turned on a couple of option - I used googles DNS so the DNS option I set to and and I also setup a DDNS option in the vodafone router so I could connect back into my home VPN when away.


So far so good.

View more options
4: Newbie

When I say "new".  It's 5/6 years old, bit of a loose term...  Since it's been fitted the service with BT has been solid and it's in a hard to reach place where noone can go near it, kick it, or even touch it without an effort.


I see.  I hadn't realised you were using your own device too.  I really want to avoid doing this as the office is so neat and tidy with just one device.  And I know I need many of these services running, like DCHP for instance.


Did you used to have daily / bi-daily WAN drops before you turned off all the services and routed them to your other device ?  If I really need to I will consider doing this and I'm lucky to have a good router sat in the desk drawer but far from ideal :-(


Thanks for the reply.  At least some of us realise how important the internet is, even if Vodafone don't.

View more options
10: Established

Andrew I had a loty more drops before disabling uPNP - I remeber it was the same on my old sky router when I first got it years ago uPNP caused the router to drop and die, so I have always worked around uPNP.


Try just disabling uPNP at the very least.  It is on the Settings->Configuration page near the botton of the page.


Let us know if it makes any difference.

View more options
4: Newbie

Cheers Paul.  I will try that this evening.  Hopefully it doesn't effect too many things I do and has some effect.  Certainly worth a try.


Had to step away from it on Saturday as it was starting to ruin my weekend.

View more options
4: Newbie

I'm updating this topic here and will see how things go.  This is FAR too early to draw ANY conclusions.


  1. Yesterday evening --  I disabled uPnP
  2. I updated the Router to the latest version.  The snappily named  (I kid you not)
  3. Once all the above was fully complete I turned the router off and on.


One thing that I find interesting (but by no means conclusive of anything yet) is that my Sky Apps were having issues communicating with Sky HD box at the weekend.  Tonight those same devices are working fine.


Airplay / etc still working. 


I'll continue to monitor.

View more options
4: Newbie


Thursday Update


  1. Exactly 3 days since I made the above changes the router is still up and running.  Too early to draw any conclusions, but this is the longest I can remember the external connection staying up.  I need to monitor it for several more days before any conclusions are drawn.
  2. I've done nothing different (regarding usage) in the last 3 days, in fact I've watched a fair bit of HD content via streaming (Sky & Netflix).
  3. Broadband support called me this evening.  The gentlemen seemed fairly clued up and on the ball.  Due to point 1 we've agreed not to change anything for now and he's going to call back in 2 days to check latest status.
  4. Broadband support have taken an action to speak to 2nd-line to see if the connection speed can be reset, to allow the speed to go back to that I was originally acheiving.  I'd like to try this once because the vast majority of the 10Mb/s I've lost (since installation) was when I had ancient firmware installed on the router.

So, fingers crossed.  Will continue to update.

View more options
4: Newbie

Monday Update


  1. Not wanting to tempt fate, but I'm now under an hour away from 1 Week since the router last dropped the WAN connection.
  2. Although Vodafone called me.  Their promised call back on Saturday never materialised. 
  3. Because of the above there's no progress / news on getting my 10Mb/s back that I've lost due to constant disconnections.

Still... Overall the news is good and I'll keep watching.


Out of interest has anyone with issue been monitoring the Router utilisation stats at the bottom of the status page ?  I've taken a few random readings and seem to get :-


  • CPU Usage  --  Usually stays below 15%  (haven't monitored whilst streaming HD Netflix)
  • Memory Usage --  Seems to remain steady at 31%

I'm just curious if eiher stat climbs higher when there's an issue.

View more options
4: Newbie

Yes the stats do and thats the problem

View more options
4: Newbie

Any analysis into the stats Paul ?


  • Is memory or CPU generally the one to cause issues ?
  • At what level do you start to get concerned.?

I can't help but feel there should be a sticky regarding some of the simple things people can do to help themselves.  Although I'm sure some issues are far greater than this, if it helps you and I, it must surely help some others too.

View more options
10: Established

Not sure cause I do not see it now, but I would not be unsuprised for one or two of the modules to increase the CPU/Mem utilisation until the kernel fell out from under the device - also if mem and cpu are thrashing about then you are not going to get the throughput that you would expect from other services.  So I am not surprised at all.


Another stat to pay attention to is SNR - you will notice likely as your devices stays up longer the SNR on the downstream will creep downwards - People do then report disconnects when it reaches "a threshold" this changes from individual to individual.   But on a reconnect the speed may be lower in order to compensate.


This is what I have noticed anyway and so far with PNP and the other things disabled my CPU and mem seems pretty consistent - When it was thrashing I remember my CPU being > 90%.  



View more options
4: Newbie

Although way better than anything I've seen before the Router eventually failed after just under 12 days uptime.


There is a tiny chance that Vodafone instigated this as my speed has increased slightly from 52 to 55.  However I find this unlikely as (despite the promise of a callback 9 days ago) I've heard nothing from them and I'm sure they'd have been in contact before / after a restart.  Also I had 62 initially, before the router rebooted itself constantly.

View more options
10: Established

@Andrew1000 this sounds much more likely to be DLM particularly if it was a convenient time it rebooted... early in the morning.  If there is stability at a reduced speed DLM should in theory increase the speed for you and this likely involves a disconnect/reconnect from the router.


However it seems a pretty small increase for DLM to be increasing it...  I would have expected it closer to what you were initially.  


I found this to be interesting - although not for Vodafone I would assume FTTC is FTTC the world over.



View more options
4: Newbie

Indeed an interesting article.  I shall have to work out exactly when it dropped the PPP connection and see if it fit the "Any changes made by DLM are executed between 3am-5am". 

I also note that "Unfortunately we are not able to do remote resets on FTTC circuits at present, so this isn’t something that can be requested nor can we send engineers out solely to complete a DLM Reset."

So unless DLM does it's job.....  Then Vodafone's issues with sending out appalling Router BIOS's that are a year old and totally unfit for purpose has cost me a lot of bandwidth (that I'm paying for) which they will never get back.

EDIT  --  The PPP connection was dropped at approx 13:30 (almost 4 days ago).  So it seems that DLM is not the issue.  Just another router "blip", even though my resource utilisation figures appear to steady all the time (around 10 / 32).

View more options
4: Newbie

Small Update for anyone that has followed this thread.  It certainly seems the disabling of uPnP has had a long-term benificial effect on my service.  I've had a couple of shorter intervals but currently I have a solid connection for over 11 days.  Not only this, but my connection speed has increased from lows of 52 to almost 60, this puts me close to the original connection speed before all the router issues degraded it.

View more options
4: Newbie

Seems I get to 14 days now and it restarts the connection again.  It's not ideal, but 14 days is livable.  Think I just have to thank my lucky stars it's not a lot worse.  Cheers Paul for the suggestions along the way.


Btw - I HATE this "new" forum layout.  Is there a way to "turn it off" ?

View more options