main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Broadband & Home Phone

Vodafone Connect Broadband - some sites stop loading (e.g. eBay and reddit)

3: Seeker

 

 
 

I've recently got Vodafone Connect.

I was previously with Sky and had no issues with websites not loading or any sort of lag.

I moved to Voda and have noticed that some sites stop loading.

For example, I can access Reddit.com fine, but some links (to other parts of Reddit) will just sit waiting to load as if the router cant resolve the connection. 

It's also happened with eBay and a variety of other 'legitimate' websites. I can connect to eBay fine, but when clicking on a link to a product that's for sale, it acts like the connection drops

Screen Shot 2017-03-18 at 08.44.43.png

 

I played around with the content settings, as I thought it might be blocked for content reasons, but even switchign that off makes no difference.

I know the links are valid, as I can reach them with my iphone on 4g.

Any ideas?  

 

Using:

Mac OS 10.12.3

MacBook Pro 

Safari 10.0.3

iPhone 6 on 4G

Edit:

I've also done the usual clear cache, restart, updated to latest versions, inc the Router Firmware.

View more options
9 REPLIES
17: Community Champion

Hi,

 

When was your Vodafone Broadband Activation date ?

 

Try clearing Cache and Cookies 

IMG_1084.JPG

3: Seeker
View more options
17: Community Champion

Vodafone state....

 

"When your broadband is installed, we'll optimise your connection to ensure you get the best possible speed. However, doing this can sometimes cause some short drops in service or unexpectedly slow speeds for the first 10 days and in extreme cases up to 30 days. Please don’t turn off or reset your router during this time."

 

Sometimes I find changing wireless channel and splitting the frequencies in the router to 2.4ghz and 5ghz and then choosing the best for me helps. 

 

Possibly use Ookla Speedtest to see what speeds and ping your getting. 

IMG_1084.JPG

View more options
3: Seeker

No issues with speeds really, just that the site will stop loading.

I'm getting 35-36meg

It's more like theres an issue with dns resolution but ive already reached the site and am trying te navigate within it

View more options
17: Community Champion

Could any content blocker , firewall, security suite or pop up blocker be hampering the sites from opening ?

 

can you try an alternative browser? And or check out your current browser settings / permissions. 

IMG_1084.JPG

3: Seeker

I'll try Chrome (:catsad: not a fan) and see if there's any change

I've also cleared caches, cookies etc. 

View more options
3: Seeker

So the latest update is the Vodafone website - specifically my Vodafone doesnt appear to work 100% with Safari on MacOS??!

Blank screen in Safari but full content in Chrome. What on earth?!  Does anyone actually do any testing these days...

View more options
4: Newbie

Try changing your DNS in the Router (Expert mode I think?) to the Google Public DNS -

8.8.8.8 (primary)

8.8.4.4 (secondary)

and restart the VF Connect Router and the client.

View more options
4: Newbie

I've had this behaviour since I got the router as well. It's very annoying and happens on every single device I have so it's not a cache issue.

 

You get used to it after a while. It's just part of the substandard experience from this router.

View more options