main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Broadband & Home Phone

Vodafone Connect Router issues

2: Seeker

My vodafone broadband was installed today and setting up my home ive come across the following issues.


1. My Laptop connected on the Wifi 5Ghz channel cannot see my Server connected by LAN Cable, if i disable the 5ghz band i can see the server fine but it reduces the functionality of the router.

2. I cannot connect to a device via port forwarding using the external router IP from within the network. however i can access the device from outside the network.

3. My fibre broadband speed is significantly slower (28MB) than the service i was recieving with sky (40MB) even thoughi was promised full (76MB) speed


has anyone else had these issues and can provide assistance ?

View more options
17: Community Champion




In regards to speeds these are shown at optimal conditions and can differ from those expected. That said that's quite a dip in speeds you were expecting. 


There are some good tips via a Google search on how a person can try and improve these speeds from their end. i.e. Use Ethernet cable instead of wifi etc. 


I did read a post not too long ago in which a person successfully had Vodafone reduce their subscriptions to a lower tier , reducing their payments as the real world speeds in their area wasn't attainable. 


I recently turned off my 5ghz settings in my Bt Home Hub Router as my Xbox 360 was having difficulty in latching into it via wifi because it was pushing out the two frequencies.


That said now I'm on 2.4Ghz I see no reduced functionality or speeds in connection. 


There is a Broadband Tech Team who can be contacted to discuss issues.


Got a question?

08080 034 515
(free from all UK landlines and mobiles)
Lines are open between 8am and 11pm, seven days a week


View more options
2: Seeker

Thank you for the reply.


Turning off the 5ghz part of the signal results in a speed loss from approximately 800Mbps tp 144Mbps depeninding on if you have a wifi adapter with ac capability. this is a significant speed loss across the network.


i know this doesnt affect the broadband speed itself, but I send alot of traffic across my home network and wanted to use that speed. if i cannot make use of that speed the router itself is not fit for purpose.


i have spoken to somone regarding internet speed and they said i have to wait 10 days from install to see what speed i will receive.


Update: Just spoke to esther on the live chat and saved transcript, the technical team will be emailing me directly to discuss these issues.

View more options
2: Seeker

I have a similar problem. 


How did you get the technical team to email you? I have had little success contacting them, I am told they only contact out, and will call me when they are good and ready. When I've spoken on live chat I've just been told to call the main dreadful number. 


I also asked for the login and password to the broadband so I can install my own router to get around these problems, but I was given an unequivical no. So far I am very unimpressed with Vodafone.

View more options
2: Seeker

the vodafone technical team never emails, just the live chat person made the commitment and i intend to follow up shortly. i can post the live chat script if you wish but i will need to take time to remove any of my identification information out of it.


i have a feeling the my line speeds are due to vodafone now getting my line running correctly and have an engineer visit booked for tuesday

View more options
2: Seeker

If you wouldn't mind that would be very helpful.

View more options
2: Seeker

You're now chatting with Esther.
Esther at 9:01, Sep 28:
Esther at 9:04, Sep 28:
I wont be a moment as I check the agents previous notes
Esther at 9:08, Sep 28:
right, your broadband isnt showing on your online account
Esther at 9:08, Sep 28:
I have seen the notes from the previous agent also
Esther at 9:09, Sep 28:
I can see that your services went active with us yesterday
Account Name at 9:09, Sep 28:
Esther at 9:10, Sep 28:
Its simply an admin issue on our side with our systems why its not appearing on your online account and it can take approximately a week for your broadband and home services to appear on your online account
Account Name at 9:11, Sep 28:
ok, can you remove the content controls on my broadband then please
Esther at 9:12, Sep 28:
yes of course one moment
Esther at 9:14, Sep 28:
Account Name can I ask, is your broadband currently working?
Account Name at 9:14, Sep 28:
im currently at work but yes it is working
Account Name at 9:14, Sep 28:
i am remote connected to a home server right now
Account Name at 9:16, Sep 28:
the broadband is slower than expected but an advisor said i had to wait 10 days to see what my speed will be
Account Name at 9:17, Sep 28:
at last check my landline wasnt working
Esther at 9:17, Sep 28:
according to our records the broadband order had a slight delay so it doesnt seem to be activated as of yet, the wifi will appear as an option to connect but you cannot connect to the network to access the internet. You will have access at some point today but right now its showing on our system that there is a slight delay
Account Name at 9:18, Sep 28:
the broadband is active
Esther at 9:20, Sep 28:
the reason why I thought it may not be activated as yet is because the system i use to turn the content control off doesnt recognise your Broadband reference number as yet, it could be our systems or the broadband line isnt active. I am unable to change the content control settings until it shows on my systems that your broadband is active
Esther at 9:21, Sep 28:
What I can do is case manage this so later today I can change the content control settings when your broadband order updates on our systems
Account Name at 9:21, Sep 28:
could the broadband be under a different account ?
Account Name at 9:22, Sep 28:
the account number i gave you was for my mobile account, i do not have an account number for my broadband services
Esther at 9:22, Sep 28:
its all linked on your account
Esther at 9:22, Sep 28:
your mobile and home phone with the broadband is in the same account
Account Name at 9:22, Sep 28:
so will the account be activated properly today ?
Esther at 9:22, Sep 28:
Esther at 9:23, Sep 28:
I can monitor this for you and make the content control changes later today
Account Name at 9:23, Sep 28:
ok i would appreciate that
Account Name at 9:23, Sep 28:
i also have some technical issues with the router that i would like to discuss
Esther at 9:23, Sep 28:
Account Name at 9:25, Sep 28:
when my wifi is set up to use the 2.4Ghz and 5ghz band,
Account Name at 9:25, Sep 28:
i cannot connect to a computer that is coonnected to the router by cable
Account Name at 9:25, Sep 28:
from a computer that is connected to the router via the 5ghz band
Account Name at 9:26, Sep 28:
after disabling the 5ghz band i can connect to the cabled computer properly
Account Name at 9:26, Sep 28:
but this reduces the functionality of the router and network connection speed from ~800Mbps to 144Mbps
Esther at 9:27, Sep 28:
Esther at 9:28, Sep 28:
this is a first for me, is it ok if I quickly as a technical member of my team to help you with this?
Account Name at 9:28, Sep 28:
yes that is fine
Esther at 9:29, Sep 28:
ok one moment please
Esther at 9:34, Sep 28:
have you tried splitting your SSID to have seperate devices running on either the 2.4GHz and 5GHz?
Account Name at 9:35, Sep 28:
yes i tried that but with no joy
Esther at 9:36, Sep 28:
when you split the SSID did you reconnect each device seperately?
Account Name at 9:36, Sep 28:
i even had the 5ghz on a seperate SSID to ensure i was connected to that band
Account Name at 9:36, Sep 28:
yes they were reconnected and reboot the router when i changed the settings
Esther at 9:39, Sep 28:
my colleague asked was it working the way you wanted before the splitting of the SSID?
Account Name at 9:39, Sep 28:
no i couldnt connect to the cabled connection from the 5ghz band
Account Name at 9:39, Sep 28:
i could connect to one on the 2.4ghz band from the 5ghz band
Account Name at 9:40, Sep 28:
and connection to the cabled computer from the 2.4ghz band was fine
Esther at 9:41, Sep 28:
My colleague said 2.4 Ghz is the preferable band to use simply because all devices work on this frequency. However if you want to us the 5Ghz frequency then not all devices are compatible with this
Account Name at 9:42, Sep 28:
yes i understand they are not all compatible which is why you can use both
Account Name at 9:42, Sep 28:
but devices using the 5ghz band should be able to connect to all the other devices still
Esther at 9:42, Sep 28:
Account Name at 9:44, Sep 28:
i understand it may not be somehting that can be immediately resolved
Account Name at 9:45, Sep 28:
however i think your technical team need to look into it for a future firmware update for the router
Account Name at 9:46, Sep 28:
there is clearly something blocking access between the devices on the router and hasn't been caught before
Esther at 9:46, Sep 28:
definitely, we have been advised that there are a lot of firmware updates that are in the pipeline to be applied to customers routers but its difficult to say when this will happen
Esther at 9:46, Sep 28:
you seem to be very technical - I think our technical team could do with having you on the team
Account Name at 9:49, Sep 28:
im quite a technical person, personally i would rather use my own router but i have read that vodafone do not allow this so wish my issues to be resolved using the supplied equipment
Esther at 9:50, Sep 28:
definitely - I will make it my business to have this passed onto the relevant team to escalate this issue to
Esther at 9:51, Sep 28:
Hopefully in the coming future Vodafone will become more relaxed in giving out the username and passwords to allow customers to use their own routers but again...something to look forward to in the coming future
Account Name at 9:52, Sep 28:
ok thank you. hopefully you will be able to access my account today to resolve the content filtering issue
Esther at 9:52, Sep 28:
I will keep a check on this for you
Account Name at 9:53, Sep 28:
i have one more query
Esther at 9:54, Sep 28:
go ahead
Account Name at 9:54, Sep 28:
i cannot access a service on my network using the external network ip address from a computer on the internal network
Account Name at 9:55, Sep 28:
but i can from outside of the network
Account Name at 9:55, Sep 28:
example my external ip address is {ip Address} if i use that to remote desktop from my office i can connect fine
Account Name at 9:56, Sep 28:
but if i use that inside the network i cannot connect
Account Name at 9:57, Sep 28:
this appears to be another router issue as i could do this with my previous provider
Esther at 9:58, Sep 28:
that would be because within the network the IP address is dynamic and changes all the time
Account Name at 9:58, Sep 28:
no i have set up static ips for all of the devices on the network
Account Name at 9:59, Sep 28:
and the external ip address is updated to a dynamic dns provider
Account Name at 9:59, Sep 28:
so instead of the external ip address i use a domain name to connect to my devices
Esther at 10:00, Sep 28:
let me get some advice on this also
Esther at 10:10, Sep 28:
right Account Name, I spoke to my tech team who have advised its a IP conflict issue you have, they advised you should have only 1 device set up in DHCP or use DHCP only
Account Name at 10:11, Sep 28:
im using the router for DHCP
Account Name at 10:12, Sep 28:
no other devices
Account Name at 10:12, Sep 28:
the static ips have been set up in the router
Esther at 10:14, Sep 28:
Esther at 10:15, Sep 28:
sorry Account Name as you can see I am not the most technical person
Account Name at 10:15, Sep 28:
i understand
Esther at 10:19, Sep 28:
I dont think its something we support Account Name as I am asking my technical team and they havent got back to me as yet.
Account Name at 10:20, Sep 28:
this shouldnt be something supported or not, this is another issue with the router that should likely be resolved via firmware
Esther at 10:21, Sep 28:
If you like Account Name I can take all your questions and send them to my technical team and have them email you back with answers - which would be better than what I can advise
Account Name at 10:21, Sep 28:
as per the last issue these issues make the router not fit for purpose right now and need to be resolved in the future
Account Name at 10:21, Sep 28:
that would be great, i would appreciate an email conversation with the technical team
Esther at 10:22, Sep 28:
that is something i can arrange for you
Esther at 10:22, Sep 28:
you will hear from us shortly
Esther at 10:22, Sep 28:
hopefully we can get all your questions answered
Account Name at 10:23, Sep 28:
thank you very much
Esther at 10:23, Sep 28:
thank you
Esther at 10:23, Sep 28:

View more options
2: Seeker


Was searching on the web to see if anyone was having the same issues as myself, and I came across your thread. So, here is my story.


Took up the vodafone connection due to the line rental fee removal and got activated on the 22nd of September. Was on SKY originally, and was getting a constant speed of 36-37Mbps. On activation day, line refused to hold connection. It could hardly stay on for 2 minutes before getting disconnected. Called tech support immediately and was given the usual run around; wait 10 days, blablabla. Anyway, by day 2, it kinda settled down, with 4 to 5 disconnections, but at a slower speed, and everytime it reconnects, the speed kept dropping. When it got to 25Mbps, I told them i was going to cancel the order. Also, I requested only to deal with 2nd line support. I got connected to a very helpful guy named Lewis. They decided to book an Openreach engineer to come have a look.


First guy came, could not find a fault on the line, but replaced the master socket just in case. Speed increased to 35, but still disconnections. Lewis booked another engineer who came, ran a new cable to a new master socket and disabled all extensions in the house( i didnt need the extensions). Speed went up to 52Mbps, but the disconnection persisted; twice a day like clockwork.


During my research and testing, I kept making changes to the router config, and I noticed that my iPad was the only device connecting on the 5Ghz band, and from it, I could not browse my local network properly, neither could I see my plex server which was connected via cable. So, I disabled 5Ghz, disabled wifi scheduling, and changed the 2.4Ghz band from 20Mhz to 20/40Mhz. I didn't get a single disconnection for 5 days. 


I have now reversed the changes and the disconnection is back. Next point of call is disabling the iPad for a day to see if it the culprit. I think the wifi/network implementation in the latest firmware is buggy and does not successfully work on single SSID for both 2.4 and 5GHz. After this test, if its still not stable, I will be requesting for my vodafone credentials to use a third party router or get the order cancelled.


Sorry about the length of my write-up, but it might help someone going through this same issues as we are.

View more options
Moderator (Retired)

Hello @femilovechild


I see, if you need any further help with this please call our Customer Service team on 08080 034 515 and we will fully investigate for you. 



View more options
3: Seeker
Hi abates85,

I am having the same issue with my new vodaphone router. Communicating with my nas or raspberry pi, connected using ethernet cables, from my phone or laptop, using the wifi, have intermittent connection issues. I can connect using an external ddns address or ip when outside the network,but not while connected to wifi. Did you ever get your issue resolved?
View more options
4: Newbie

AFAIK this is a well known issue with the Vodafone supplied Router/Modem.


I had a similar issue whereby my wireless PC's could not "See" my wired network printers. However, if I connected a PC by ethernet cable I could print from the printers.


My solution was to obtain my username/password amd then throw £150 at purchasing my own Router/modem.


Apparently this option is no longer available as Vodafone are currently refusing to divulge login details.

View more options
2: Seeker

I havent had any resolution as of yet, 2 of the issues are router issues which will or will not be patched by the vodafone tech team, the last issue with speed im currently getting 42MB connection.


View more options
4: Newbie

I'll trhow my hat in here as well - somewhat regretting leaving plusnet for this level of service.  


Vodafone router does not seem to support any kind of routing between devices on different sections of the network.  My only solution to date is to use a seperate wireless router in AP mode.


Frequent disconnections - i'm also getting atleast two dissconnections, usually early evening and mid morning, sometime more often. 


So far a pretty poor show


update: just waited for an hour on the chat to be told they won't give out connection details so your stuck with the rubbish router until someone hacks it and gets the connection details...

View more options
4: Newbie

I have worked for a couple of companies supplying end user equipment and the Connect router really is sub-standard.


I had the same WiFi LAN to Wired LAN connection issues. 


I have set reserved IP addresses under Static DHCP in Settings for hard wired and wireless devices.


I have changed the DHCP lease time to a week in the hope that will help.


I am not convinced it is fixed but since I did the above, I haven't had the issue where WiFi clients cannot print to or access wired  devices.

View more options

@mooredav @its5am @PeterGMc57 So we can look into this for you, please speak with our Broadband team directly on 08080 034 515 or through Live Chat.


@abates85 Please keep us updated on the outcome of your query.


View more options
4: Newbie



Firstly, never speak to customer services but write to them (email or web chat). Then you will have a record of who said what.


But funny how Natasha keeps giving a "standard" message directing us to a web chat URL that doesn't work.


Are you a robot?


View more options
4: Newbie

yup, links don't work - well done natasha


Chat is fun to get through on (takes about 30min generally, but i've been waiting for an hour before).


The response is device seperation is a known issue the firmware team are working on, no timelines (great) and no connection details so your stuck with the rubbish router, company policy

View more options
4: Newbie



I'm close to paying early termination fees and going with another provider.


Knowing what you know, I bet you don't use Vodafone broadband yourself?


You're with BT or Virgin right?


Can you recommend a good provider with good customer service?

View more options
2: Seeker


This all tallys with my experience. Directed to non-existant webchat for broadband. I have been told definitively that they are not giving out usernames and password details. In addition I have been offered money off over the phone which has never appeared. 


My phone renewal is coming up shortly and I will be changing away from Vodafone, and will do the same as soon as possible with the broadband.

View more options
1: Seeker

Same issue here: devices on WiFi cannot connect to devices on the wired ethernet.


Any solutions other than "buy a new router" would be appreciated!

View more options