Showing results for 
Search instead for 
Did you mean: 






Certain apps not working despite high speed and good signal???

3: Seeker
3: Seeker


New customer here, having started on a 500MBps package on Monday 6th November. All speed tests show the speeds we expect and when streaming shows etc performance is also as we'd expect with this speed. However we've encountered a few other issues primarily in relation to a number of mobile apps (although I'm still making my mind up if everything is working well on my work laptop too as Microsoft Teams and some video calls have encountered the odd 'glitch'). Generally, despite high speeds and good signal these apps are extremely slow (e.g. up to 5 minutes to load up, and even then theres no point trying to do anything with them). I've tried all the usual switching off and on, forgetting the network etc to no avail. Importantly, I'm clear its not my phone or the apps as I have a new Galaxy S23 and critically the apps work like clockwork the minute I revert to 4G. I've listed the apps with issues (discovered so far):

  • Gmail (does seem to receive mail sometimes, but it can go all day before doing so. Also can't send email. At one point I removed my email acocunt and re-added but ran into all sorts of issues ('cant find server') so had to switch to 4G to set my emails up again
  • Sky News - very slow in loading then painfully slow to view news stories. News notifications dont appear to be working
  • Asda -takes minutes to open, then is not functional 
  • MySky app - as above, takes forever to load then is so slow there is no point trying to use it

As mentioned above, if i revert to 4G this fixes everything (but isn't an acceptable solution on a 500Mbps package). For context, we previously had 150Mbps with BT with no issues at all, even at peak use.

I did speak with Vodafone support yesterday for quite some time and to their credit they did eventually appear to resolve the issue (they advised they changed some content control settings). Right at that moment the above issues went away, but overnight they have returned. I had read about possible clashes with content control so was hopeful this would have fixed it and I'm now stuck as to how things might have 'reset' overnight... I've been in to my router settings (inc on Expert mode) and can't see any obvious content controls that I might check, although I'm no expert when it comes to routers.

It definitely feels like something is off with settings (and the content control aspect seemed to temporarily clear the issue) somewhere at the router but I'm stuck as to what to do next and would welcome any wisdom? It feels like this must be a common issue given my setup, but I cant find much on the subject...?

Many thanks!






16: Advanced member
16: Advanced member

@Branney1984  You're not the first S23 that's popped-up in the last few days, have a look on the forum. Have you tried changing the router DNS settings away from the Vodafone default to / (Google) or / (Cloudflare) ?

4: Newbie

Same issue. I'll try to call them soon because this is not acceptable. 

3: Seeker
3: Seeker

Thanks - I've tried the alternative DNS addresses with no success :Sad_face: After posting I noticed a similar post below. Definitely a common theme!

I'll try tech support tonight again (hopefully the fact they did something last night that temporarily fixed it offers some hope as having now found some other posts I can see more and more functionality is lost across my apps!)

Screenshot 2023-11-09 114745.png

Did you change the control settings from your end or they changed them for you? I tried to turn them off but it didn't help for me.

They changed them at their end and it was an immediate fix (stuck emails sent, affected apps loaded immediately etc). I was advised I could change them at my end but for the life of me I can't see how to anywhere in the router settings.

They can be changed on your vodafone account.

3: Seeker
3: Seeker

UPDATE - ISSUE NOW RESOLVED (Again... hopefully it sticks this time!).

Credit goes to RJFINN03 for advising as follows:


"You will need to log into your router, change the mode to "expert mode" at the top right of the page. Then go to the "Settings" tab along the top and click on "local network" down the left hand side. Scroll down and you'll see "IPv6" is checked. UNCHECK this, scroll all the way to the bottom of the page and click apply. It might take a minute to take effect, but this completely fixed my issues with using my apps. Apps now open as quick as they should, display everything they should and I'm receiving emails as they are sent and not hours later." 


I've disabled the IPv6 on local network but still issues persist.. did you notice immediately an improvement?  

Yes, almost instantly