Showing results for 
Search instead for 
Did you mean: 






Certain apps not working despite high speed and good signal???

3: Seeker
3: Seeker


New customer here, having started on a 500MBps package on Monday 6th November. All speed tests show the speeds we expect and when streaming shows etc performance is also as we'd expect with this speed. However we've encountered a few other issues primarily in relation to a number of mobile apps (although I'm still making my mind up if everything is working well on my work laptop too as Microsoft Teams and some video calls have encountered the odd 'glitch'). Generally, despite high speeds and good signal these apps are extremely slow (e.g. up to 5 minutes to load up, and even then theres no point trying to do anything with them). I've tried all the usual switching off and on, forgetting the network etc to no avail. Importantly, I'm clear its not my phone or the apps as I have a new Galaxy S23 and critically the apps work like clockwork the minute I revert to 4G. I've listed the apps with issues (discovered so far):

  • Gmail (does seem to receive mail sometimes, but it can go all day before doing so. Also can't send email. At one point I removed my email acocunt and re-added but ran into all sorts of issues ('cant find server') so had to switch to 4G to set my emails up again
  • Sky News - very slow in loading then painfully slow to view news stories. News notifications dont appear to be working
  • Asda -takes minutes to open, then is not functional 
  • MySky app - as above, takes forever to load then is so slow there is no point trying to use it

As mentioned above, if i revert to 4G this fixes everything (but isn't an acceptable solution on a 500Mbps package). For context, we previously had 150Mbps with BT with no issues at all, even at peak use.

I did speak with Vodafone support yesterday for quite some time and to their credit they did eventually appear to resolve the issue (they advised they changed some content control settings). Right at that moment the above issues went away, but overnight they have returned. I had read about possible clashes with content control so was hopeful this would have fixed it and I'm now stuck as to how things might have 'reset' overnight... I've been in to my router settings (inc on Expert mode) and can't see any obvious content controls that I might check, although I'm no expert when it comes to routers.

It definitely feels like something is off with settings (and the content control aspect seemed to temporarily clear the issue) somewhere at the router but I'm stuck as to what to do next and would welcome any wisdom? It feels like this must be a common issue given my setup, but I cant find much on the subject...?

Many thanks!






Did you remember to apply or save changes?


Very grateful to find this post - several apps weren't loading and Google devices finding it hard to respond to voice commands - all appears to be sorted now the IPv6 checkbox has been unticked as described above.

Spot on Branney1984

This had been driving me nuts for over a week. Resolved the issue instantly.

Thank you

Hi, I'm new to the forum. Thanks for specifying how to change the IPv6 settings. I had seen the post by RJFINN03 which helped a great deal in pointing me in the right direction. I was having the same issue of apps not opening on both our Samsung phones, after taking out another contract with Vodafone, but working fine on 4g. This solution solved the problem instantly, for which I'm very grateful, unlike when I contacted Vodafone who are having to ring me back next week!

16: Advanced member
16: Advanced member

This is because VF does not support IPv6.

That's interesting to know... Its definitely not something I switched on manually so it appeared that way from the default setup... 

2: Seeker
2: Seeker

Hi. In also had this exact same issue. Spotify didn't recognise i was connected to the Internet, Hive, asos, vinted, BBC news, TSB apps all would either load incredibly slow or not at all. Spent 3 frustrating hours chatting to BB help but they couldn't fix. Thank you to those who contributed to helping. All very embarrassing for Vodafone they don't know that there's an obvious issue here...

2: Seeker
2: Seeker

Hi Branney

I had similar issues with some apps, mainly all the BBC ones plus some shopping and bank apps. Spent numorous hours on the Vodafone chat with no success. They even sent out open reach. Any found on Google a suggestion to log into the router expert settings and disable Ipv6 and save. Did this and success everything working fine. Only took a few minutes.

16: Advanced member
16: Advanced member

Just to add another PoV to this thread. For a long time now I've been using a 6in4 tunnel from Hurricane Electric but recently I've been having problems with devices dropping offline, failed screencast, etc etc

This whole thing does make me wonder about the current state of vodafone's IPv6. You see, I'm using my own (asus) router so it's likely nothing to do with the thg3000. Yes, disabling IPv6 is working but it seems it's fixing the service, not the router. 


Hey @Branney1984 We’ve identified a routing issue impacting a small number of users who use Android apps, and it’s currently being looked into. Sorry for the disruption caused, we're getting it resolved as quickly as we can. If you need more help with this, please speak with our Broadband Tech team on 191 free from a Vodafone mobile or 03333 040 191 from any other phone. They're also available on Live Chat.