Showing results for 
Search instead for 
Did you mean: 






Certain apps not working

2: Seeker
2: Seeker

At the beginning of November I moved to a faster broadband service. It was with the same provider and same router. Certain apps on my android phone stopped working on the WiFi. All the BBC apps, Sky News, Gumtree one of my banking apps, Zara and M&S to name a few. But similar apps did work. The WiFi service was fine otherwise. Streaming etc worked fine. On three or four occasions I went on the chat line but despite restarting, factory resetting the router etc. calling out an engineer nothing worked. I googled the problem and a lot of Posts suggested logging into the router and disabling Ipv6 and hey ho success 





4: Newbie

Same problem here, and I tried everything with no luck.


Hi @Newburghbrian @salvom89 Thanks for your message! We’ve identified a routing issue impacting a small number of users who use Android apps and it’s currently being looked into. Sorry for the disruption caused, we're getting it resolved as quickly as we can. If you need more help with this, please speak with our Broadband Tech team on 191 free from a Vodafone mobile or 03333 040 191 from any other phone. They're also available on Live Chat.

16: Advanced member
16: Advanced member

Disable IPv6 everywhere you find it on the router. 

1: Seeker

Thanks for the IPv6 tip. Had same problem since about the same time Oct/Nov 2023 when were activated for digital voice. Only Android apps that connect to internet like BBC News, Spotify, M&S etc as suggested were affected, and all worked on Apple. Could get apps to work if you disconnected wifi on the device and then immediately reconnected but would stop working again after a short while, so had become a real pain. Connect by mesh discs normally but connection direct to router wifi (which is normally off) all seemed to work fine. Was about to buy new mesh system to see if it cured problem and had one last search for a solution and came across this. Disabling IP6 in the router seems to have fixed it but Vodafone do need an update to firmware to resolve it properly.

I moved to VF a few weeks ago and had problems from the start, but disabling IPv6 seems to have fixed them, thanks to this community. If Vodaphone are listening they need to disable it before sending the routers out, it can't be that complicated can it? Perhaps it should be a sticky post in here?

16: Advanced member
16: Advanced member

A lot of users are having no problems at all with IPv6. It's becoming clearer what actually causes problems, including more exotic setups, but we don't have a properly defined list as yet. Vodafone have only just started rolling out their dual-stack implementation so there will be some problems caused by the unexpected/untested setups, and the experienced members here are also still just learning.

As you mentioned in your thread about pihole, it may have taken a while but the penny did eventually drop. 

Registered to say thanks! This has solved my issues and was even affecting access to certain websites I use for work via Edge on a Windows desktop