main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Broadband connection

Port 445 on home broadband

Highlighted
2: Seeker

Hi there,

 

I am working with an Azure account and would like to map a drive using SMB (Server Message Block). However I cannot connect despite checking port 445 is open. The suggestion is that it might be my ISP (Vodafone) who has blocked this. Can you advise if this is the case and whether this port can be opened / or any workarounds that may exist.

 

Thanks. 

View more options
3 REPLIES 3
Moderator
Moderator

Hey @godisaclog, thanks for getting in touch, We don't block ports, although you're free to play about with the port settings in expert mode of the router if you wish. 

Unfortunately we don't provided support for the type of advanced networking that you're doing. Keep your eyes peeled though, another member of the community may have some ideas. 

View more options
2: Seeker

Hi guys,

 

So after further experimenting I was able to identify that the port blocking wasn't an issue, despite the tools on the internet claiming it was. The connection to Azure needed only the outbound port 445 opening. I tried this via powershell and that worked OK.

 

The issue was caused by NTLM being set to a lower level than required. I had to change a registry key as described in cause 2 in this article: https://docs.microsoft.com/en-us/azure/storage/files/storage-troubleshoot-windows-file-connection-pr...

 

Once that was done I was suddenly able to map a drive to an Azure file share. It works well - except of course for the latency of accessing Azure over the internet.

View more options
Moderator
Moderator

Great stuff @godisaclog - I'm glad to hear you've got it all figured out 👍

View more options