main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Broadband connection

Router blocking IKEv2?

norfolk_uk
2: Seeker

I am using a Raspberry Pi and want to connect it to my VPN service. My VPN service doesn't officially support Raspberry Pi OS but being Linux it is possible to connect to their VPN manually.

However apparently the Vodafone router is either blocking the IKEv2 protocol or the IPSec Passthrough is not enabled.

I have been through the router's settings but cannot see any relevant options.

Does anyone have an ideas regarding this?

View more options
3 REPLIES 3
petezx9
2: Seeker

I have no solution to offer but my VPN provider uses IKEv2 to connect and I have no trouble connecting.

View more options
Anonymous
Not applicable

I actually doubt that the VF router (crap as it is) would be blocking such protocols - there is no point it's just data.  All your data packets look roughly the same, so it's unlikely that the router will be going to the trouble of decoding them just to block a specific VPN protocol.

 

I would say though that using a Raspberry Pi as a VPN gateway is a pain in the backside, especially if it's not always on.  It's not uncommon to misconfigure such VPN gateways (and get no feedback to tell you), to misconfigure the gateway and any local routing, and finally to have issues caused by having a dynamic IP if not using DDNS.

View more options
norfolk_uk
2: Seeker

An update: I can confirm that the Vodafone router (at least the THG3000) does not block IKEv2. My issue turned out to be a slight mis-configuration of IP/server name of the VPN I was trying to connect to. All sorted now.

View more options