main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Mobile Broadband

Impossible to turn off 5G on Gigacube

SOLVED
View solved solution
jwinchis
3: Seeker

I'm beyond frustrated. Will try to keep this as brief as possible.

I got a Gigacube a couple of months ago. Initially I was disappointed that I had no 5G signal, but this actually turned out great as I was getting really good speeds via 4G+ (averaging 200mbps, and pretty consistent).

All was fine and dandy until at the start of this week, it finally decides to connect to 5G. But instead of a speed increase with the 5G connection, my speeds have dropped off a cliff. I'm now getting 6mbps if I'm lucky.

The frustrating part is that I cannot select a 4G signal only, and I'm currently stuck with these rubbish speeds at 5G.

NOBODY at Vodafone seems to realise that you CANNOT change the network selection setting. Below are the options I've tried (and that Vodafone keep telling me to try despite them not working).

 

1. Logging in to the router admin page > Network Settings > Mobile Network Settings. DOES NOT WORK (!!!) The option is set to auto and cannot be clicked or changed. (see screenshot)\Screenshot 2021-03-24 at 11.30.14.png

2. Changing settings in Huawei AILife app. As above. The option cannot be selected or changed, just says 'auto'

3. Changing settings in the Huawei HiLink app. This was the one way I could do it previously. But now the app does not work. It will not accept the router password, whether it's my new one or I reset the router and use the original password. Cannot log in to the router via this app, no matter what. Have tried reinstalling, installing on my girlfriend's phone. The result is the same - 'login failed'

I also asked Vodafone to change the account settings and turn off 5G on my sim, which I was told was done. Yet the Gigacube is STILL connecting to 5G and giving me the terrible speeds.

There is a previous thread here of people having similar problems, with no resolution:

https://forum.vodafone.co.uk/t5/Mobile-Broadband/Turn-off-5G-only-on-Gigacube/td-p/2639488

 

Please, can someone sort this out. I'm so sick of being told to try the same things that DO NOT WORK! 

 

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
atillae
3: Seeker

i have tried uploading screenshots but they have to go throw the moderator.  I'm not good whit explaining stuff but i will try :Smiling: 

 

1) login into your gigacube and navigate to network settings than Mobile Network Searching.

( there will be no options to manipulate but don't worry :))

2) find the option  "Network search modeAuto" right-click on the line and chose to inspect.

( a Chrome console will show up there assuming you use chrome on pc. You can drag the console area to be wider so you can see the lines easier.)

3) You have the manipulate code lines to show interactive menu on the page just look for lines -

mobilesearch_input_support_5G_switch_operate class="clearboth hide"

double click on class="clearboth hide" and replace hide whit show.

do this for 3G 4G 5G and mobilesearch_btn_save_div.

4) You Have to first tick 3G 4G and 5G when you tick 5G you will See another dropdown menu appear. You have to Choose SA and Unclick 5G otherwise it will fail to save settings. 

you will also need to keep 3G Ticked and save. if it fails close your browser and repeat. 

GoodLuck :Smiling:

 

 

View solution in original position

View more options
5 REPLIES 5
Evie
Moderator

Hey there @jwinchis - I understand how important it is to have a stable connection, especially now. It sounds like you've tried all troubleshooting we would suggest with this. 

I've spoken with our Gigacube tech team to see if anything else can be suggested and they've advised we'd need to check your account and make sure 5G is turned off. For us to do this, could you drop us a DM on social media please? Make sure to include a link back to this forum thread to save you repeating yourself and your mobile/account number.

View more options
jwinchis
3: Seeker

Thanks. Will get in touch on social media.

I just don't understand why the options in the router admin page/apps aren't selectable. Can't Vodafone change this? They continually suggest users use options that don't exist. Every time I've spoken to someone about this on the phone or web chat, they ask me to try it, even when I've told them in advance that it doesn't work!

View more options
atillae
3: Seeker

it is possible but you need to do some tricks :Smiling: I will try to show you. 

Step 1Step 1Step 2Step 2Step 3Step 3

 

View more options
atillae
3: Seeker

i have tried uploading screenshots but they have to go throw the moderator.  I'm not good whit explaining stuff but i will try :Smiling: 

 

1) login into your gigacube and navigate to network settings than Mobile Network Searching.

( there will be no options to manipulate but don't worry :))

2) find the option  "Network search modeAuto" right-click on the line and chose to inspect.

( a Chrome console will show up there assuming you use chrome on pc. You can drag the console area to be wider so you can see the lines easier.)

3) You have the manipulate code lines to show interactive menu on the page just look for lines -

mobilesearch_input_support_5G_switch_operate class="clearboth hide"

double click on class="clearboth hide" and replace hide whit show.

do this for 3G 4G 5G and mobilesearch_btn_save_div.

4) You Have to first tick 3G 4G and 5G when you tick 5G you will See another dropdown menu appear. You have to Choose SA and Unclick 5G otherwise it will fail to save settings. 

you will also need to keep 3G Ticked and save. if it fails close your browser and repeat. 

GoodLuck :Smiling:

 

 

View solution in original position

View more options
jwinchis
3: Seeker

Wow you utter hero, it actually works! Thank you

View more options