main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Mobile Broadband

K3770 Huawei Dongle (No Device Found) Solution

2: Seeker

K3770 Dongle "No Device" issues.


I have recent bought a K3770 Huawei Dongle on a Monthly Tariff from Vodafone.  I managed to install the software via the K3770 Dongle but no matter what I tried my Laptop Windows 7 would not recognise the Dongle as a Dongle and would not allow any internet access.


After speaking to an Independant Specialist he confirmed that the issue was not with the Laptop but with the K3700 Huawei and not being able to update the correct software.


I returned to Vodafone and spoke to a Tech Specialist there and he stated that this has been a common problem with the K3770 and there was nothing they could do and it was something they could not sort out.


By luck they had and old K3565 Dongle out the back and this worked perfectly using the software that had been down loaded through the K3770.


The answer if you cannot get the K3770 to work and have tried everything like me is to get a K3565 from Ebay and this shoudl sort it.

View more options
4: Newbie

It may not help, but the tech background to the problem you're seeing is probably the following:


Huawei modems (which includes the Vodafone-branded K3770) are what's known as USB "composite devices" - one physical USB device presents itself to the system variously as a modem device, a virtual CD-ROM device (for the software and drivers), and maybe even also as a flash/memory-card device.

The device typically appears as a CD-ROM device most prominantly, which gives the auto-start and software-install. It appears to me that it often requires the driver-software to be installed before it can "mode switch" (Linux term) to make the modem-hardware visible to the system. If that driver software isn't installed properly, then the "mode switch" doesn't happen, and the PC never "sees" the modem hardware. If you've previously installed drivers for older Huawei modems, this may prevent the drivers for the newer modems installing and/or the older drivers may only mode-switch the device for which they were installed. You may need to do a manual uninstall to remove the last debris of old drivers before the new ones will work.


Older modems (E220 and E1752) can have their multiple personalities disabled by means of a geeky terminal-interface and a AT^U2DIAG command which worked well for me and enables me to mix and match those devices on two computers (I installed the full version of the Connection Manager software on the PCs so don't need access to the virtual-CD-ROM). Unfortunately my experience is that the K3770 doesn't support the AT^U2DIAG command (and others on the web find the same thing)...

View more options
Gay 2: Seeker
2: Seeker

I have the K3565 and as of 2 days ago it now shows NO DEVICE. I have been using the dongle since 2008 without problem. The dongle still works perfectly on my computer at work. I have not recently changed anything on my home computer and I have tried uninstalling and reinstalling the dongle as well as rebooting the computer. I have also tried disabling Bluetooth and have reassigned a different letter to the dongle. Nothing works. Have spent hours on it and still the same message NO DEVICE. At first I started getting this message intermittently over the last couple of months but was always eventually able to access the internet. The problem now seems to be permanent. I am still searching the web for a solution and have a couple more things to try. There is always hope. One suggestion was to delete info on the dongle in the modem tab and reinstall (message on Vodafone forum from Tech Team). Will check that out next.

View more options

Hi Gay


Thank you for your post and a very warm welcome to the eForum.:smileyhappy:


Sounds as though this has gotten progressively worse, please can you uninstall this completely and ensure that you are running the latest Vodafone Mobile Broadband Software, also on this link there is a quick start guide and Frequantly Asked Questions.


Please let me know how you get on.


Many Thanks



eForum Team

View more options
2: Seeker
View more options