main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Mobile Broadband

VOIP fails on vodafone

2: Seeker

I'm using a SIP softphone on my handset (Galaxy S3) to link to a PBX as an extension.

This works fine when the handset is connected over WiFi, including connection over the internet.

However using the vodafone data network the handset cannot stay registered and calls to the handset from the PBX don't get through. The settings are exactly the same, but just the internet network connection is different.

However if I connect over the vodafone network to a commercial SIP server, there is no problem.

The response from VF technical support was "Could you please explain what VOIP is" and " we can't find anyone who understands what this is", so that doesn't give me much confidence in them.

Has anyone had any experience of the VF network giving a different behaviour with SIP?



View more options
2: Seeker

I am having the same issues after moving from Three to Vodafone, this is a major issue for me as I can't always be connected to a wifi connection...


Anyone know of a fix?


Thanks in advance!

View more options
2: Seeker

I have an alternative: use TCP or TLS instead of UDP as the transport protocol. This is now working solidly for me on TLS but I do have access to the PBX configuration so I could enable it and open the correct port.

View more options
Moderator (Retired)

Hi @walford58


I would recommend trying to speak to the Live Chat team here who will be able to get this looked into for you.


Let us know how you get on with this and if you require further help please message us here and we will assist you. 





View more options
2: Seeker
Hi Khizar
I had already tried twice with the Live Chat team, but they bounced it to tech support, who responded with a lack of understanding as in the comments in my first post.
Since I've now resolved my own problem independently, I dont see a need to bother Live Chat on this.
View more options
2: Seeker

I have exactly the same problem, and would appreciate any help. Chat technical support have no idea what I am talking about and have not been able to help. Have a VOIP setup that works perfectly with EE data sim. As soon as I change sim card for Vodafone data sim - I can register, but I have no sound in either direction. I do not have access to PBX, but I suspect the packets used are UDP (as UDP port redirection is the only firewall hole I had for EE sim cad). When I try to enable TCP redirection on vodafone it still does not work. Is there anyone who can help?

View more options

Hi @poppyfields1234


We'll need to look into this, to see what's happening. 


I've sent you a private message with details on how to get in touch.



View more options
2: Seeker

Hi @Amanda

1. I have followed the links to the specific support and filled out the relevant form twice with no reply

2. Tried pm you - no reply


For Everyone else:

My setup: E3372h (HiLinK - moded firmware) -> Router -> VOIP phone

Any advice on why VOIP works with EE on the above setup, but not with Vodafone.

EE - everything works

Vodafone - SIP registers but no voice in either direction (so Vodafone either blocks RTP packets or their NAT does not direct them through) .


Any advice appreciated.

View more options

@poppyfields1234 Sorry for the delay in replying to your post. 

I've checked our inbox, however we're unable to see any emails from yourself via the registered email address within your profile. 

If you'd like us to help, please contact us directly using the instructions @Amanda previously sent to your inbox. 

View more options