main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Mobile Broadband

Why is my website blocked?

Jcoulthard72
2: Seeker

I have a business webpage which has happily been working for many years. Today it seems that anyone using Vodafone is unable to access the page. 
There’s been no changes to the site and it’s not adult. 
access is ok from other mobile providers. 

Address is www.acpcs.co.uk

 

any help would be appreciated. Vodafone’s answer was to send me a text saying I can now access adult sites! Which wasn’t the issue anyway. 

View more options
13 REPLIES 13
Ripshod
13: Advanced Member

I'm able to access your site no problem. Only thing that springs to mind is I don't use vodafone's dns servers so they have no control over what sites I visit.

My standard advice is to avoid vf's dns. 

View more options
Jcoulthard72
2: Seeker

Hi there

thank you for your response. 
for some reason it seems to be anyone within the north west of England having an issue. People further away can access it! 
People using broadband and other mobile data providers can also access it. 
Vodafone could offer no solution!

View more options
Gemma
Moderator

@Jcoulthard72 - I’ve tested this on my phone with Wi-Fi off and your website didn't load for me.

I've raised this for review for you. We’ll post back here as soon as we’ve an update.

View more options
imimimx
2: Seeker

I'm pretty sure Vodafone have got BGP/routing issues for a few weeks now - at least 3 - we have a number of mobile data sim cards at the same location and quite frequently some sites simply cannot be accessed.

 

For example, tracing to your Shopify IP address from one mobile data connection it fails - it gets stuck in the Vodafone network at 192.168.213.21, it would seem to suggest Hop 4 has no further routes on the Vodafone network:

 

jT6ITt6c.png

 

Testing at the exact same time, from the same location, different sim card/connection, same make mifi it works - destination is reached:

 

24pePcr8.png

 

This is not a DNS issue, as I'm testing direct to the IP.

 

I frequently see the issue with a number of different ASNs, providers, for example sometimes Cloudflare cannot be reached, other times Akamai, then maybe BBC.

 

If you toggle the data connection a few times, often you can resolve it - presumably ending up on a different router on the Vodafone network.  But it will return and it WONT always be the same sim card, nor mifi, it's seemingly random.

 

 

View more options
imimimx
2: Seeker

Here's another example - Cloudflare CDN resolves a site to 2 IP addresses:

 

104.18.114.97

104.18.115.97

 

Running a trace to 104.18.114.97 from Connection-1, it fails:

 

8IIUjD4s.png

 

Running a trace to 104.18.115.97 from Connection-1, it works, destination is reached:

 

o69FdJB5.png

 

Repeating the tests on another mobile data connection - Connection-2, testing to 104.18.114.97 - same location, same make dongle, etc - both work:

 

GR2RwZTO.png

 

And then 104.18.115.97

 

6v8ssXKp.png

 

It's not just a UDP/ICMP issue either, when you cannot trace to an IP you also cannot telnet to the HTTP/HTTPS ports (80/443)... there is no connectivity.

 

When CDNs such as Cloudflare present 2 IPs, often you can only access the hosted site 50% of the time - if you client chooses the reachable IP address.

View more options
imimimx
2: Seeker

And another example, to an Akamai CDN IP - 184.51.132.158

 

Connection-1, fails:

lkgfuwYw.png

 

Connect-2, it works:

CbaDULeX.png

 

There also does NOT appear to be any correlation to the external IP address assigned by Vodafone.

 

For example you can have 185.69.144.70 and it will work on one, then IP 185.69.144.100 (for arguments sake, same /24 subnet) on another and it will NOT work.

 

.. whatever controls the internal routing at Vodafone, seems to be the issue.  It's ALWAYS 192.168.213.21 that is the last hop on the trace, when traffic is black-holed.

 

View more options
Jcoulthard72
2: Seeker

Thanks 

is there anyway to fix this?

kind regards Julie 

View more options
imimimx
2: Seeker

My view, from the raw data, is that it is for the Vodafones core network team to fix.

 

But as with all such similar problems, actually getting someone from such a team (usually non-customer-facing teams, that hide in the back office) to view the problem is challenging - it's almost impossible to get anything out of support, other than what their support scripts allow.

 

It's not a sim card issue, it's not a device issue, it's not a location issue, it's not a DNS issue, it's not an 'adult block issue' .... which each time you phone up, you have to go through again and again.,.,.and again.

View more options
Jcoulthard72
2: Seeker

Thanks. 
those are all the things Vodafone have suggested like it’s just my phone. 
Surely someone in Vodafone must understand how to fix it?

View more options
imimimx
2: Seeker

@Jcoulthard72 wrote:

Thanks. 
those are all the things Vodafone have suggested like it’s just my phone. 
Surely someone in Vodafone must understand how to fix it?


The problem is generally not finding someone who knows how to fix it - they undoubtedly have some smart techies in their core network teams.

 

But getting an appropriate level techy to view the problem to start with, making it past the support scripts the call centres have to follow as standard operating procedures.... until someone gets the chance to look at it who can fix it.  That's the problem.

@Gemma probably remains your/our best hope, as I've given up going by the call centres.  Next step for me is to cancel 30+ sim cards and move them to EE.

View more options
Jcoulthard72
2: Seeker

Hi

yes you are correct! 
Im struggling to anyone to confirm that it’s a fault!

oddly we’ve found a couple of people who can still access the site on Vodafone. But more can’t than can!

Julie 

 

View more options
Jcoulthard72
2: Seeker

I don’t know who fixed this issue but it’s now all working again. 
the customer service team couldn’t tell me who fixed it or even if it was the cause of Vodafone. 
Hopefully it won’t happen again. 
Thanks for the responses on here!

kind regards Julie 

View more options
Amanda
Community Manager

Hi @Jcoulthard72 🙂 thanks for keeping the thread updated and letting us know it's working for you now. 

We've also updated the classification of site to prevent this happening again and this will complete by 2am on Friday 8 July. 

View more options