main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Other OS & Unlocking

NUC requst form says error when i click apply

1: Seeker

i completed the nuc form but when i clicked apply, the page went to error

View more options
3 REPLIES
4: Newbie

Hi Rovers14, we have the same trouble. Fill in all the details and when we press submit the page goes to error. Tried on different browsers but still doesn't work.

View more options
17: Community Champion

The Live Chat Team or Customer Service Team on 191 should be able to fill out the form on your behalf. 

IMG_1084.JPG

View more options
Moderator

@rovers14 @bigstevec I've just tested this and everything seems to be working now 😊 

Please clear the cache and cookies on the device you used and attempt to complete the NUC request form again. 

View more options