Showing results for 
Search instead for 
Did you mean: 






Java error

4: Newbie

I'm trying to sort out the fact that Vodafone have cocked up takng my data money yet again but when I enter the security code or press some other options I get a java error message similar to the following :- says:


ADF_FACES-60097:FOr more information, please see the server's error log for an entry
beginning with ADF_FACES-60096:Server Exception during PPR, #172


so I can do nothing to sort out my account.

I've tried three different browsers - all give the same error message.

Any ideas, please? 




I know that, you know that and tech support would probably know that too. The only thing missing here is for customer support to pass the information to tech support so someone can fix the issue. My guess is that "java error" isn't in the handbook so customer support has to start their checklist from page 1 (did you try turning it off and back on again ...)

@amun I've not had any sucess with support so far (right now my support requet is flagged as a "complaint" rather than "technical issue", which is unhelpful). Anyway, I've been digging though the process and it seems to be the 2FA that is failing. There might be a way to bypass the error and get into your account if you are getting the error at the same place.

Start at

Attempt to log in and get to the 2FA page

Receive code and type it in

Get "java.lang.StackOverflowError" error message

Type in the code again and submit (yes you'll get the error again)

Reload the page (use F5 or the reload button). You'll probably see the error again

In the browser navigation click "back"

Click the option in the top right to access your user account

If all has gone well you should now get a different message to save the computer details

Yes, you'll get another "java.lang.StackOverflowError" error if you turn that on or progress but try anyway.

In the browser navication click "back"

Now click the option in the top right corner again

You should be in your account.

(ymmv ; did it once using standard chrome browser)



Same (or very similar) here.  Unable to complete login.  Get the following message when I click the "Continue" button after typing the security code:
ADF_FACES-60097:For more imformation, please see the server's error log for an entry beginning with: ADF_FACES-600096:Server Exception during PPR, #294  


I had 3 identical failures this afternoon, and no successes.

@petesimpson Sounds like the same issue. Once you see the error (and dismiss) did you try reloading and then clicking back (in the browser navigation).

@Xantius  I have just tried your suggestion.  It worked for me (thanks), and I'm in the Account Summary page.  However clicking the "See usage or Top up" button returns the same error message (with a different PPR #) and I can't find a workaround similar to your suggestion for login.


My general impression is that clicking links within the My Vodafone web pages works OK, but clicking buttons results in the Java error message.  NB: I don't guarantee that this is true for all links / buttons.


My own environment is PAYG phone + Chrome browser on a seriously underpowered Windows 10 netbook with Java version 8 update 144 (build 1.8.0_144-b01). My Java was last updated early morning on 21Sep2017


Foolisly I spoke to someone in customer service who I thought might get the idea that this was a technical issue for their technical team. Instead they reset my account (changed username and password) and now I can't even get as far as the 2FA error. Well, I guess that as I don't get the error any more it was a fix? 

Moderator (Retired)
Moderator (Retired)

@Xantius Please reply to our latest email and we'll be happy to assist you further.

@petesimpson So we can take a closer look into this for you, I've sent you a private message with details to contact our team. 

@amun I've been unable to locate an email from the registered email address on your profile. Please follow the steps provided in the private message and we'll be happy to take a closer look into this for you.

@Natasha  Thanks for your reply.  There is nothing (yet) in my personal message inbox.  I'll check again tomorrow.


Although on 24/9 every attempt I made to sign on resulted in the Java error, today 27/9 every attempt succeeds.  Same browser, same Windows 10 netbook whose Java version is unchanged from 24/9, and I haven't requested any cleanup of cache or cookies.  I'm not aware of changes in my hardware or software configuration, but so many software updates occur automatically nowadays I cannot guarantee that there have been none.

Same here - nothing changed at this end, yet today it seems to work OK, so they've obviously fixed the problem.


@Natasha I have been replying to the emails. However one of the support team "went rogue" and changed my username and password without understanding what they were doing (and without permission from me). Waiting for escalation to the technical team (and complains team) to attempt to recover my account.


As you can see from the other resposes in this thread, this was not an account issue but a server-side issue.