Showing results for 
Search instead for 
Did you mean: 






Java error

4: Newbie

I'm trying to sort out the fact that Vodafone have cocked up takng my data money yet again but when I enter the security code or press some other options I get a java error message similar to the following :- says:


ADF_FACES-60097:FOr more information, please see the server's error log for an entry
beginning with ADF_FACES-60096:Server Exception during PPR, #172


so I can do nothing to sort out my account.

I've tried three different browsers - all give the same error message.

Any ideas, please? 



Moderator (Retired)
Moderator (Retired)

Apologies for any inconvenience that this is causing @Xantius. I can see our team are continuing to chase this for you - we'll be in touch via email once we receive any further information.

@petesimpson @amun Thanks for updating us. I'm glad to hear that this is now working for you both :Smiling: If there's anything we can help with in the future, please don't hesitate to let us know.

I am seeing the same "java.lang.StackOverflowError" if I try and change my PIN or password, or any other action that requires entry of a security code.  I can log in to my account and top it up, but that is about all I can do.




Moderator (Retired)
Moderator (Retired)

We can look into this for you @david_wiseman 🙂

I've sent you a private message with details on how to contact our team directly. 

When trying to log into my personal account, I get the following error when entering the verification Security cde sent to my phone.




ADF_FACES-60097:For more information, please see the server's error log for an entry beginning with: ADF_FACES-60096:Server Exception during PPR, #108

I have tried different PCsLaptops and browsers. I have tried to clear the Java cache, none of which has worked.


If this cannot be quickly resolved, I might switch to a new provider.



2: Seeker
2: Seeker

I have been suffering the same problem all weekend now.


I have already put it up on your problem pages and NOBODY has replied.


This is very very  poor customer support from Vodafone.





Its now 3 days since this error was first reported to you !!!!!!!



Community Manager
Community Manager

@dlocky42 - I’m sorry for the delay in us reaching your posts!

If you’re still facing this issue, we’ll need to access your account.

Please send us your details by following the instructions in this private message.

This has been going on for weeks.  I've been on Chat and they have tried to reset but it never works.  I can get in to my account by ingnoring the java error because I noticed in the top right it was showing I was logged in.  I then proceeded to change my Pin number - because your number doesnt match mine, but I get the same java script error and no chance of saving the changed Pin number.  Time to give up my account with Vodafone i think.

Moderator (Retired)
Moderator (Retired)

We'd be happy to look into this further with you @dandare2 🙂

I've sent you a private message with details on how to get in touch with our team directly. 

As discussed at length with the Vodafone chat hotline last week and today, I am no longer able to log in to my Vodafone account. Windows Chrome browser, Firefox on a second Windows PC and my Android tablet all return the same error from your server: „ says java.lang.StackOverflowError ADF_FACES-60097 ...“. I can see in the forum that many other people reported the same problem here last year which is due to a middleware error in your Oracle database.

Just as with Xantius in this thread on 24 Sept. 17, I foolisly chatted to someone in customer service who reset my account (changed my password) and now I can't even get as far as the 2FA error. Luckily, the My Vodafone app on my phone still works, but I would rather manage my account on my PC.


I am certain of my memorable word and also my voicemail PIN (they are written down in my secure wallett app), but the hotline tells me they are both incorrect. The My Vodafone app, which does automatic authorization through the installed Vodafone SIM card, does not have a menu to reset the browser password.

Strangely, the timestamp on the chat protocol I received by email from vodafone is set to EST (East Coast US). GMT would be more helpful. David