Showing results for 
Search instead for 
Did you mean: 






Lumia 625 MMS not working

5: Helper



One of the phones on my account we have recently changed. We bought a Nokia Lumia 625 (PAYG) from the Vodafone store, delivered to the local Vodafone shop. They transfered my wifes existing pay monthly number to the new micro sim card and set the phone up. All OK. So are using a pay monthly sim only account, as was previously with an old HTC which worked OK, but new sim card, smae number.


Except we cannot get a picture message to send. Everything else works, internet etc, but unable to send an MMS message. It keeps saying "Cant send message, try again".


Access Point is set to Vodafone UK Contract and shows as active.


Help! Anyone any idea? Thanks.


OK. Problem sorted. It was the SIM Card ! Resolved by a very helpful vodafone shop. Swapped SIM. All data is now working again as is MMS. Thanks to all for their input.

View solution in original position


16: Advanced member
16: Advanced member

Hi there


Here is a step by step guide to how to configure the handset for MMS - it may be an idea to check all the settings just in case any of them are incorrect.  You can also text the word WEB to 40127.


Went through the process of setting up a new access point for mms etc as per the link in previous post, activated new access point OK but,  still get the same failure message when trying to send a picture message. All other settings look OK.


17: Community Champion
17: Community Champion

It's possible that MMS got turned off on your account in the upgrade process.  Hang on for the Tech Team here as re-enabling it often requires deeper access that the Customer Services people have.

16: Advanced member
16: Advanced member

Have you tried testing the word WEB to 40127?  If so, did the configuration message install on the handset?  You can also try getting the settings sent through here.


Yes. Just tried Txting WEB to 40127.


Received the settings and they installed OK.


Still fails to send picture message, have also discovered that it doesn't receive them either. It just displays "media content in this message". Selecting "get media content now" results in a chime, but no picture downloaded. 


Thanks for your help on this one guys.

16: Advanced member
16: Advanced member

I think that one of the eForum Team will need to look into this for you as it does sound like MMS hasn't been provisioned on the account.


One quick check, can I confirm that you were trying to download MMS over the mobile phone network and that you don't have WiFi on?


Well, Wi-Fi was on, but if I turn it off it makes no difference to the problem.


Hi sparky17


We’ll be more than happy to help, get in touch with us here


We’ll get back to you in 48 hours, or for immediate help go here.





Hi Laura,


Many Thanks. Have sent you my details via your link.