main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Other OS

Nokia Lumia 1020 Can't receive MMS

Highlighted
2: Seeker

Hello,

 

Any one knows why I can't receive MMS?  I can access the internet through 3G without a problem. When they send me an MMS it says "Get Media Content Now" I click on it and it doesn't do anything

 

Thank you

View more options
6 REPLIES 6
Highlighted
Administrator

Hi CharleeBangs,

 

It could be the settings on the phone aren’t correct.

 

Take a look here for help with this.

 

Thanks

Michelle

View more options
Highlighted
2: Seeker

followed these instructions and it did not make any difference - I cannot send or receive media in MMS text

 

Amy on the telephone customer service told me to call Windows as a software issue.  She did not know the number which I was absolutely flabergasted.  I searched on the web and found a tech support number and then got push from department to department at Microsoft and still not had this issue resolved.

 

Any other advice?

I work in the design industry and sending images is imperative and if I can't I will have to demand a different phone

View more options
Highlighted
17: Community Champion
Hi, it could be that MMS is enabled correctly on your account.

One of the team on here will be able to check for you but it can take up to 48 hours for them to respond.
View more options
Highlighted
17: Community Champion

Could you get images sent by email rather than MMS?  That would only use data and not incur a charge.

 

I can understand yoru not being able to send MMS if you account isn't correctly provisioned, but not being able to receive them is usually a matter of the settings on the device, as far as I'm aware.   It certainly shouldn't be an issue with the model of phone.

 

I'm not fully up to speed with Windows, but can you go into Settings and make sure you have the correct APN?  It should be Vodafone Contract WAP for pay monthly or Vodafone PAYG WAP for PAYG.  If there's more than one in there, make sure the Vodafone one is set as default.

View more options
Highlighted
2: Seeker

Thank you

I previously checked APN and it is all set up accordingly so regret no idea why not working

Thanks for replying

View more options
Highlighted
Moderator (Retired)

@dstdesign 

 

So we can take a look and make sure this is enabled on your account, get in touch here.

 

Thanks,

 

Matt

View more options