main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Other broadband queries

Android DNS Issue

Not applicable

I'm having issues accessing the web via Vodafone home broadband wifi on all Android devices (tested four different devices so far). I know the Android devices can connect to wifi with other providers (tested on BT, Sky and various free hotspots) and I have no trouble using my Vodafone home broadband wifi with ALL other devices (iPhones, laptops, etc).


I believe the issue is DNS related. I can ping IP addresses from the Android devices but not hostnames. I have changed the DNS config on the router to use Google DNS and when that didn't work I tried OpenDNS which also didn't work.


I've also tried changing the DNS config on the Android devices between Vodafone, Google DNS and OpenDNS, none of which have worked.


I'm not sure what else to try now. Vodafone technical support got me to repeat all the steps I detailed above when I was speaking with them but they have now given up and are saying it must be an incorrect setting on the devices (something I'm not convinced about but they may be right), and that they can no longer provide support because it's not a Vodafone problem.


Has anyone had any issues like this before?


Thanks in advance for any help.

View more options

@Anonymous From what you've said, it sounds like the Android devices aren't connected correctly or it could be related to your Wi-Fi. 

Have you tried completely forgetting the network and then reconnecting either with the wireless key from the back of the router or the one you may have changed this to? 

If this doesn't work then we could have a look into your services. In this case, please contact our team directly using the link in my private message.

View more options