main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Other broadband queries

How to Set up a third party router with vodafone 2019

Highlighted
14: Advanced member

 

The first thing you need to do is ask vodafone for your user name and password . live chat with vodafone is best because you can copy and paste the name and password into the router. ( some users did write it down wrong. password is lower and upper case . username watch out for zero and o )

https://www.vodafone.co.uk/contact-us/index.htm

 

The setting are the same for all the router it's down to the isp (the setting page will be laid out difference but the setting are still the same , eg

vodafone setting are

Vlan ID - 101

enable 802.1q (not on every router)

Username  - ******@broadband.vodafone.co.uk

Username - ******@businessbroadband.vodafone.co.uk  ( for business customers )

Password - ********

PPPoE

MTU Size : 1492

rest of the setting auto detect when the router and the dslam are negotiating with each other

 

List of third party router that work well with vodafone will update as more router are confirmed working 100%

technicolor tg589vac :            ADSL and VDSL router with Ethernet + dual band Wifi 

Netgear rbk40  :                       ADSL and VDSL router with Ethernet + Tri-Band technology

Netgear D6220                        ADSL and VDSL router with Ethernet + dual band Wifi 

Netgear Nighthawk D7800    ADSL and VDSL router with Ethernet + dual band Wifi 

The DrayTek Vigor 130:           ADSL and VDSL modem with Ethernet                                ( UK model )

TP-Link AC 1600                      ADSL and VDSL router with Ethernet + dual band Wifi 

TP-Link VR600                        ADSL and VDSL router with Ethernet + dual band Wifi 

TP-Link W9970                        ADSL and VDSL router with Ethernet + dual band Wifi 

asus ac68u                              ADSL and VDSL router with Ethernet + dual band Wifi 

 

IF YOU ARE USING A THIRD PARTY ROUTER THAT WORKS 100% WITHOUT BUGS.PLEASE PM ME THE MAKE AND MODEL SO I CAN UPDATE THE LIST 

 

---------------------------------------------------------------------------------------------------------------

gigafast 

 

vlan 911

PPPoE 

Username - *******

Password - ********

 

List of routers that work with gigafast

Asus RT-AC86U 

Cisco 5506-X

Linksys EA9500

netgear nighthawk ar500

 

 

View more options
72 REPLIES 72
Highlighted
3: Seeker

1) Does it not seem a bit ridiculous that one would have to purchase a 3rd party router rather than use the one provided by vodafone?

2) Who exactly do we need to speak to in order to get that login information for our account? I assume it is hidden and/or not identifiable within the existing vodafone router config.

View more options
Highlighted
14: Advanced member

 

Read the first post again lol

The first thing you need to do is ask vodafone for your user name and password . live chat with vodafone is best because you can copy and paste the name and password into the router.

https://www.vodafone.co.uk/contact-us/index.htm

View more options
Highlighted
3: Seeker

Hi all,

 

i have a netgear R7000 running dd-wrt. I’ve tagged the wan port of the router in vlan 911 but I’m still getting no joy. Is anyone else running dd-wrt with gigafast successfully? Cheers

View more options
Highlighted
3: Seeker

I have been using an ASUS RT-N56U Router alongside the supplied Vodafone one, using the Voda as just the Modem.

Previously I used an ASUS DSL-N55U and that is the Modem also version of the 56 I suppose ( does not seem to be ANY difference in their functions )

Since getting hold of the username and password for my ASUS Modem, I was overjoyed, however, I have yet to be able to connect.

There seems to be a whoel host of options that I am not  in posession of, such as LLC or VC_MUX, VPI, VCI and so on... I have been trying out so many things in the last coupel of days on and off, and its a killer trying to work out if this Modem is even useable with Voda? I have also tried all the default setups such as SKY, BT, and the like, and just editted those settings, but again nothing.
The Vodafone own router takes around 2 minutes to log on from being powered off, tis is by far, the lognest that any provider has ever done, and so I try to give the ASUS as much time as I can... It does try connecting bu tthen it comes back with internet down.
I have also tried AUTOSETTING, and this tries to gather the protocols etc but the modem, keeps telling me that it is not even connected to the phone line? ( Yes, I have checked this modem at 2 of my mates houses, on SKY and on TalkTalk and its fine )
So I have a horrible feeling that this mode, is NOT compatible with Vodafone.
One other small annoyance, is that I could not find the PSU and so as I love this router so much, I just bought another one, just because I need a PSU.... Its not even here yet and I just found the PSU.
Typical.


 

View more options
Highlighted
16: Advanced member

@FatRacoon Hi the problem with the Asus DSL-N55U is that it does not have a VDSL capable modem only an ADSL modem, and as such is incompatible with VFs FTTC service.  Sorry, but there is no way to get this working with the service that you have!

View more options
Highlighted
3: Seeker

Ah, thats cool.
VDSL not ADSL
At least I know now... I can stop wasting my time with it.
I also know what other routers I can check out instead... Thank you my friend.

View more options
Highlighted
16: Advanced member

Not a problem, you are not the first to have done this, and you will not be the last!

View more options
Highlighted
3: Seeker

Argh, now I am just annoyed to heck.

I have the username and password and I hope all the other info required to get the Modem conected, I find out that mine is not VDSL ( None are ) and so today, I wenmt out and splashed out on a nice expensive new VDSL router thats in the list of known ones that do work with Vodafone, and I still cannot get connected.

In fairness, the DSL LED is showing up and so I am definitely linked, but it turns out my username and/or password is incorrect.

So, I phone up Vodafone and I explained that I just needed to verify my username and password, and as it turned out, the username I was using was missing the "l" and so its started with "ds4" instead of "dsl4"  but also one of the characters in the password was also an "1" when it should have been an "l".

I thanked her and entered the info... The modem takes ages to mess about with the new info and so I thanked her and we left it and since it was coming up to 8pm and I had to run and get my daughter, I had to end the phone call anyway.
Now, I still cannot get conected, and I have gone through all variations of "l", "i", and "1" and even "!" in both the username and the password and the thing is still not getting onto the internet.

So, again tomorrow, I am going to yet again have to phone them up and yet again, I am going to have to go through the username and password.

 

I asked if she could text the details or email them through to me and she said she would, however, I got a text on my landline, not the Mobile and so it spoke to me the details in a seriously rubbish voice that I repeated and saved but cannot now get at it, and so thats now gone and I have not had a text to my mobile or an email to my PC so that I can fully and properly check the info.

But the thing is, that on both phone calls, I fully verified the username and password and both phone calls they said different usernames and passwords ( although so, so close to being the same )

Im really annoyed about it if I am honest.

 

View more options
Highlighted
Administrator
Administrator

I'm really sorry to hear about the problems you've had getting your new router up and running @FatRakoon. Have you managed to get this resolved since you last posted? 

If not, so one of our team can take a look into providing you with your username and password; I've sent you a private message so you can contact us directly. 

View more options
Highlighted
4: Newbie

So I brought the ASUS router as mentioned in this post. Plugged into my city fibre modem and nothing I put in my pppoe info I got from Vodafone but I see no vlan setting? 

View more options
Highlighted
4: Newbie

This is where I get a little confused, the box you speak of I believe is the ONT box. Does this act as the modem part or is that also built into the supplied Vodafone router?

 

The Linksys EA9500 is listed as working with Gigafast but looking in to this router I can't see any mention of the modem built in so I'm a little confused how this all works 

View more options
Highlighted
4: Newbie

Yes the ONT is separate and connects to the city fibre network. The router I put in the PPPOE info that Vodafone gave me but no joy. I have since connected a 3 disk BT whole home set up to the Vodafone router and it's working perfectly! Strong WiFi in every room with good speeds on 5ghz I get around 300-400 down and 600 up my line is capable of 900/900 but I don't expect to see these speeds over WiFi. Also the issue of the hub restarts when an Apple Watch is connected is no longer an issue as the BT disks are handling all WiFi connections. I've disabled the WiFi on the Vodafone hub 

View more options
Highlighted
4: Newbie

Morning, ah yes this was another option I was exploring. Just using the VF router as a modem and turning off the WiFi and then using a mesh system. I've actually been looking at the netgear orbi my self.

 

how are the Bt disks?

View more options
Highlighted
4: Newbie

They work really well I've had them for a while. Used to use with BT infinity they are super easy to set up. The disks even tho quite far away from the main disk (connected to hub) always get a really good connection! And the WiFi steering works really well with no transition issues (sky was a nightmare for transition to different WiFi points) I think they are soon bringing out an upgraded one! But I do recommend them the Vodafone hub is to put it politely rubbish! 

View more options
Highlighted
4: Newbie

Yes I agree the WiFi is crap on these VF routers. How ever they are seem ok for wired connections 

View more options
Highlighted
4: Newbie

I'm just lookin at the BT whole home WiFi disks and they do a mini version of the disks. Are these new ?

View more options
Highlighted
4: Newbie

Yes I think so? I think there are 3 versions now low, mid and expensive! Don't know what the difference is? I always say get the best you can afford it will last longer! But I do fully recommend them work very well! I have been experiencing constant drops in my connection since I had it installed since I've had these it's been rock solid 

View more options
Highlighted
16: Advanced member

Just answering one specific thing here.  In regards to using the required VLAN settings with a standard router, the workaround is to use the IPTV function of the router to get the tags inserted.  If the devices you buy do not have IPTV settings then they'll not work without an intermediary device that does - ie you use the supplied router, but turn it's WiFi off, and just use the Mesh devices for the WiFi and not for the whole network management!

 

It's possible that you'll start seeing the VLAN settings in the main connection settings of some standard routers quite soon!  *Last time I tried explaining why we have IPTV settings at all I almost lost the will to live!

View more options
Highlighted
4: Newbie

If only I'd known that I saw IPTV setting in the router I brought and thought it can't be that 😂 but it ended well the BT whole home I had in the loft is working a treat! I can't believe how trash the Vodafone router actually is! Mind you though it is handing a lot of data via BT mesh and a quite a few LAN cables at once just seem to be the WiFi that is trash 

View more options