Showing results for 
Search instead for 
Did you mean: 






Smart devices unable to connect to Ultra Hub Wifi (Eufy Doorbell and AudioPro speakers)

3: Seeker
3: Seeker

I've recently moved back to Vodafone, and had my FTTP service activated yesterday, with the Ultra Hub and Pro WiFi.

Laptops, phones and tablets are working just fine, but I have a few smart devices that refuse to connect, specifically a Eufy Video doorbell ( and several AudioPro multiroom speakers (

On both of these, you use the manufacturer's mobile app to choose a WiFi network and provide the password, then they should connect, but it just fails every time. They were all working just fine on Tuesday with my BT Hub so it looks very much like a compatibility issue with the Vodafone router.

I have tried using WiFi compatibility mode on the Router but that's made no difference, and have had some incredibly painful chats with the support team who have insisted that WiFi won't work properly in the first 48 hours until the service is fully activated, or that the problem is with all my devices. They also seem to disagree about whether I have the Pro WiFi or not, and suggested that might be stopping things connect. They did offer to send another WiFi booster in case it's a coverage issue, but that's not the case as these are a matter of meters away.

Has anyone seen anything similar with smart devices that refuse to connect, and if so, how did you solve it?

In the event log I can see errors like
"Failed to send to ff02::1%guest@br-guest (Cannot assign requested address)" and "Ignoring MLD pkt on non snooping enabled bridge interface lan"

The tech support team didn't seem even remotely interested in looking at those.

If this can't be fixed I'm going to need to leave Vodafone, as the service is not fit for purpose and I'm not going to abandon £1K's worth of equipment that can't connect, but I don't imagine that's going to be easy.


3: Seeker
3: Seeker

It’s only gone and worked!   
Renamed the guest WiFi to what I plan to use as the main SSID and joined the devices, then flipped the names over and so the main network has the right name and it reconnected just fine. 

<insert huge rant about how a Pro WiFi service shouldn’t require an IT professional with twenty years of experience to figure out a trick like this, or how the online chat support was so infuriating it nearly reduced me to tears>

Hopefully this will save someone else the headache. Thanks to all of you who offered suggestions which helped nudge me towards a solution. 

View solution in original position


16: Advanced member
16: Advanced member

@DJM1971  Without revealing details, how long (short) did you make the guest SSID and password? I wondering if the devices have different min/max lengths.

Mine was a 10 character SSID and around 15 for the PSK

About 16 for each

I have a similar issue with a TECKNET smart plug that will only connect on 2.4ghz and yes I tried compatibility mode and it did not work either.   Can you explain a bit more about what you did with the name change?  I don't quite get it?

Sure can. 

If your main SSID (the Wi-Fi network name) is HomeWiFi, then rename it to HomeWiFiTemp. 

Rename the guest SSID to HomeWifi and go through the setup for your plugs. Don’t worry about all your other devices for now. 

Once the plugs have connected, change the guest network to HomeWiFiGuest, and the main one back to HomeWiFi. 

Your plugs should reconnect just fine. 

Thanks; had exactly the same problem, tearing what little hair I have left out at the inability to simply turn off 5Ghz for five minutes. The guest wifi solution worked perfectly.

3: Seeker
3: Seeker

I'm leaving Vodafone if they don't get this sorted too. The Ultra-Hub compatibility mode is a joke, leaving all smart devices unreliable.

16: Advanced member
16: Advanced member

@ChrisO_SWC  I agree it's not good. Many "smart" devices are on WiFi 2.4GHz only and that there are regional differences in the WiFi 2.4GHz standards that means certain countries do not have channels 12 and 13. Japan only has channel 14 and then only for 802.11b. Also the manufacturer may have chosen to adopt the non-overlapping channels, as do some ISP routers.

The problem seems to be doing the initial setup of the 2.4ghz smart devices. Once they are configured with the right SSID and password then they will reconnect just fine. You could use any other router with the same credentials to do the setup, then they’ll work with the Voda one. 

3: Seeker
3: Seeker

Just adding my voice to this conversation. I recently upgraded to a new Ultra II hub and it's been a bit of a nightmare for some devices, namely our Givenergy Solar Inverter, which is a vital bit of kit to have connected so I can not only monitor solar/battery levels but also schedule charging, etc.

I tried compatibility mode and even the Guest WiFi trick but it didn't work. This morning I spent ages fiddling with the WiFi set up inside the Givenergy dongle and managed to see two "MainSSID" listed, one with a strong signal, one weaker, so I chose the stronger signal and it now works! I think it saw the 2.4ghz (strong) and 5ghz (weak) separately for the first time. This was after days of trying (even trying an older 2.4ghz extender, but the Ultra Hub II wanted nothing to do with that either).

It's working for now, but I fear power cycling the router will cause it to drop the connection again. 

Just allow us to split the SSIDs! It would have taken me about 30 seconds instead of the 3 days.