main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Other broadband queries

Strict rDNS checking by email recipient.

Highlighted
2: Seeker

I have a static ip address to facilitate running my own email server on my own domain.

This has worked fine until recently when I started receiving email reject notifications due to:
'HELO/EHLO not matching your DNS configuration'

This requires a PTR entry to be made for the reverse DNS but this is not something I can do, it us under Vodafone's control.
This has appeared in another thread but the exact procedure to get it done is not perfectly clear.

Although I believe I have done what was suggested, I have not heard anything back yet.

Suggestions?

View more options
3 REPLIES 3
Highlighted
2: Seeker

I realise it is bad form to come back on my own question but I'm getting a bit frustrated.

 

Anybody know how I can get a response from Vodafone on this matter?

View more options
Highlighted
6: Helper

@WhiteCar wrote:

This requires a PTR entry to be made for the reverse DNS but this is not something I can do, it us under Vodafone's control.

 If my static IP address is anything to go by, a PTR record already exists. You can verify yours by running

dig -x addr

where addr is your static IP address.

The HELO (or EHLO) command used by mail servers to establish a session with each other has the format

HELO fqdn

where fqdn is the fully qualified domain name for your IP address, the one reported by dig earlier. It is not the domain name in your email address.

To remove the error you are seeing, you need to configure your mail server so that it uses the correct string for fqdn. Most servers will default to the hostname which will almost certainly be wrong for machines sitting behind a NAT router. You will need to override it manually. For example, on the postfix mail server on linux, the value is controlled by the smtp_helo_name parameter in main.cf. Check the documentation for your mail server.

Hope this helps.

 

View more options
Highlighted
2: Seeker

Whilst I am aware of this Postfix parameter, configuring it to match the rDNS was not something I had considered.

My preference is for my domain to remain 'honest' but, since only VirginMedia are creating this problem, maybe this could be the solution if I cant get the PTR record changed to my domain.

 

So, thanks for making me look at this in another direction.

View more options