Showing results for 
Search instead for 
Did you mean: 






VOX 3.0 Router DNS servers

4: Newbie

I have been attempting to change the DNS servers on the VOX 3.0 router to Google's DNS (Primary and Secondary but the router won't accept the IP addresses...or any other IPs for other DNS servers. I select the 'Manually' button, then enter the IP addresses for Google, scroll down to the apply button, but when I hit apply to make the changes I get this:


Corrections needed
Invalid value.


Won't accept any other IPs.  Can someone help out here. I'm far from a  novice, but I cannot work out how to get this wretched setting to 'take'. I even tried with zeroes before the 8, as I know some devices like to have all 3 decimals for each octet (some TVs and BD players require but no joy.


I'm glad the firmware was updated recently, and that I can now at least make changes to settings, whereas before I couldn't, but this must be sorted pronto if it is borked.




I had the same error message.  Then I tried resetting the DNS page to defaults (the purple arrow in a circle) and after that I was able to apply and

View solution in original position


2: Seeker
2: Seeker

Can't help but wanted to add that I'm seeing the exact same issue. Won't accept any manual DNS.


Not applicable

Don't have the VOX3 router, but have you tried other forms of punctuation such as 8,8,8,8  8-8-8-8 or 8:8:8:8


I know some of those are just wrong, but in a few decades of playing with networks, I've seen all of those and even more bizarre!

Sadly no, it's one of those interfaces where you get 4 boxes, one for each octet.

1: Seeker

I'm getting the same issue. I've heard that using Vodafones DNS addresses can result in slow speeds but I'm unable to change them to Google's DNS routers. 


I've just had Vodafone broadband installed last week and the speed is shocking so far. Nothing like the 60mb guaranteed speed they advertise it as. If it carries on I'm going to have to ditch them.

Community Manager (Retired)
Community Manager (Retired)

Hey @Privateofcourse@OldManSheff and @ChrisF2020. It's really strange that you're struggling to get your DNS settings updated. 

Our team will be happy to access your accounts and take a closer look into this for you, it may need raising to our Technical team too. Find out how to get in touch here.

Please also provide a link to this thread, along with your usernames; this will save time and we’ll be able to help you quicker.

I contacted support and explained the issue and was told that it was being looked into. However, no idea whether that is accurate or how long a fix is going to take.


This is the very first time I've ever encountered this issue (changing DNS) with any router. Somewhat miffed about it to be honest. I was told there had been a firmware update in January to address some issues, but what I don't know is whether this was one of the issues that was supposed to have been addressed.


Perhaps tech could update you on this matter and you could let us know?



2: Seeker
2: Seeker

I do encounter the same issue. Is any solution available already? What about this F/W update?

I had the same error message.  Then I tried resetting the DNS page to defaults (the purple arrow in a circle) and after that I was able to apply and

Well well done you for that! That did it. Hurray! There must be a glitch after the update. Any other issues I encounter I'll look for the 'page reset icon' first and see if it sorts it.


All credits in your Kudos bank!  :Hand_Shake: