main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Other broadband queries

Vodafone Wi-Fi Hub bug in web GUI: cannot change wifi settings.

_rik_
4: Newbie

Hi,

Just received the router and went live yesterday at around 8pm.

Before going live, I set the the wifi properly. At 8pm the router was automatically reset by Vodafone (every setting lost).

Now I can see the firmware is different.

Firmware-Version: 19.2.0307-3261013

Productname: Vodafone Wi-Fi Hub

 

A previous bug has disapperead but there is as new but even more annoying: the router doesn't let me change anything in the wifi settings, not even the password despite the router itself pop up a message saying "you should change the password".

 

I'm going to work around this problem with the mobile app... let's see what happens....

 

View more options
36 REPLIES 36
_rik_
4: Newbie

Fortunately the phone app was a valid workaround.

Hope for a web GUI fix because it's quite buggy.

See the other bug I've found in 5 minutes of use, here.

https://forum.vodafone.co.uk/t5/Other-broadband-queries/Vodafone-wifi-hub-bug-device-name/td-p/26822...

View more options
Jayach
16: Advanced member

I would suggest giving the router a factory reset via the GUI. It cured the problems I was having trying to change wifi settings. (Not the wifi channel that is still not available)

View more options
_rik_
4: Newbie

Actually this problem came out because of a factory reset and mainly the firmware update. With previous version of the firmware there were other bugs, but not this one, so resetting it's only a waste of time (I've already made a lot of settings).

 

Having a look at the http response I can see the error "Your changes have not been updated " is presented before  any http/ajax call, so there is something wrong in the JS of the page, not "server"(router) side.

 

Looking in the browser console I can see tons of warnings about cookies follow: "Cookie “sessionID” will be soon treated as cross-site cookie ... because the scheme does not match" (this is not a problem now but it will be in the nead future because noboby using Firefox will be able to access the router).

 

I've tested the same operation with Firefox on Windows (I'm working from Linux). Same problem.

I've tested from Windows using Opera and there is no problem with that.

 

So, I can confirm it's browser related, for sure.

Why Firefox doesn't work with it? Surely not because it's the browser to blame but because it is strict on rules... and this is an error in the web GUI of the router. If I find some time to go further in the analysis I could tell something more accurate about the cause of this bug...

 

View more options
Jayach
16: Advanced member

I use Firefox as my main browser and have no problems with accessing the router. A factory reset cured my wifi setup problem that sounds exactly like what you are having. You could save your configuration and reload it after the reset if you have made many changes that you don't want to lose.

View more options
_rik_
4: Newbie

If a reset really solves the problem it's not a good sign! 😊 Moreover it would be quite spooky if lots of people find themselves with this problem with Firefox and that because of random coincidence that can be solved by a reset.

 

In any case I went live 2 days ago so I don't want to upset the DSLAM with a second reset.

View more options
_rik_
4: Newbie

By the way if find out the problem is present only in Advance mode. Applying in Basic mode has no problem. This could be the difference you see after the factory reset.

 

So the workaround is simple

Since there is no difference in Wifi->general from Expert to Basic, such settings can be set in Basic mode, then switch back to Expert for the rest of the settings.

Probably there is a bug in the way it validates data in Expert mode.

 

With a bit of debug I can find the problem, but, what's the purpose? I doub the developer are interested in knowing which line has the problem.

View more options
Jayach
16: Advanced member

Setting it back to advanced mode is the first thing I do after a reset. I don't think one more reset will upset DLM.

There have been other reports of people with problems accessing the router with Firefox, but I have never experienced them. I suspect it's more likely to be extensions they may be running.

View more options
_rik_
4: Newbie

I'm a software developer so I have all the browsers and OS of this universe, but my main computer runs on Debian Buster.

I've tested FF ESR and FF Developer on Linux. Both have the same problem.

I've tested an old Firefox ESR from an XP VM. Same problem.

I've tested FF on Win7: same problem.

I've tested FF on Win10: same problem.

No problem with any other browser on any OS. Even crap-Edge it's OK. 😱

 

FF has this problem even in --safe-mode, so no addons involved.

Having a firmware corruption so that only Firefox has this problem has a chance to happen similar to throwing a box of 100 needles from a skyscraper and see them all landing 1 over the other vertically! 😄

 

Provided you have the same piece of cr... ehm I mean hardware I have😂 , you could try this with FF

 

 

1) Go to Wi-Fi. General tab.

2) Set Basic mode

3) Set Advanced mode

4) Simply toggle "Enable Wi-Fi On/Off button on Vodafone Wi-Fi Hub"

5) Click Apply and see if it really saves the change.

 

I've received the router 4 days ago so could be another hardware release, different from yours.
NB: Before the firmware upgraded (happend automatically when I went live) this bug was not present.


Firmware version
19.2.0307-3261013-20200812152603-87d129527e2b6c5db641b036118778179b03c3da
Bootloader Version
19.02.1146-0000000-20190110090550-897d2844f012557134a272eb8a8a90f85e9a7a8d
Hardware Type & Version
Vox3.0v

 

View more options
Jayach
16: Advanced member

O.K. I have the same firmware as you.

I carried out your instructions carefully and after setting the wifi off and pressing apply it said "your settings have been applied" , but it came back still enabled. The same thing happened it basic mode.

Exactly the same thing happened in Chrome.

So yes it doesn't seem to work in either Firefox or Chrome.

I'm posting this before I try with the button on the router as I'll probably loose connection

View more options
Jayach
16: Advanced member

Back now.

The button on the router turned the wifi off (but I had to hold it for a few seconds before it took effect), and the GUI on a hard wired PC (using Firefox) showed it as Off. I was then able to use the GUI to turn it back on.

So all in all it seems you can't turn the wifi off with the GUI, but the browser used doesn't matter.

View more options
_rik_
4: Newbie

So basically you are in a worse condition than mine because in your case not even other browsers can change the settings in the page Wi-Fi --> General.

 

Keep an eye on the message: are you sure it says "your settings have not been applied"?

I ask that because mine with FF says "Your changes have not been applied" (with a red box) and with other browsers says "Your changes have been applied" (with a green box) and it really works.

If you see a different message, or the "not" is missing but the changes are not been applies anyway, could be a different software with different bugs, despite the firmware versione looks the same.

View more options
Jayach
16: Advanced member

Just tried it again, this time in Edge(chromium) and it definitely says "Your changes have been applied" on a green background, but the slider returns to on.

The best you can say about this router is it is "flaky" but it seems a solid worker once you leave it alone.

View more options
_rik_
4: Newbie

It's surely a nice piece of kit, but it's quite common these days that any good hardware is ruined by a software that seems to be coded in a kindergarten in Tailand. 😄

All major ISP, no one excluded, have routers with bugs in the GUI.

I remember the first hub of BT with problems saving NAT rules.

Plustnet Hub One with other problems in the NAT section.

TT hub: in DSL stat the SNR is empty + renaming devices is useless because everything is lost at the first restart.

and so on...

Vodafone it's in the same trend. 😄

These are problems so simple that could be solved in minutes with the source code, but for some reason they are ignored for months or years.

 

However, no problem, the most important thing is that once set it works! 🙂

And despite its size, has a low power comsumption: around 7w (tested myself).

View more options
_rik_
4: Newbie

Another problem: there is no way to change wifi channels!!!! 😱😱😱😱😱

This is quite important because on the 5 GHz band, this router has channels unsupported by many clients. In fact I have some devices that only support UNII-I (the first half part of the 5GHz) and since the router is now on channel 64 (and moves at random) I cannot use such devices.

I can't see the channel setting in the app either.

View more options
Jayach
16: Advanced member

@_rik_ 

It's not a bug, it's a deliberate decision by Vodafone because they know better than us how to control our WiFi.

View more options
_rik_
4: Newbie

Great! Good choice! 🤣 I thought it was only a buggy firmware, instead there are also bad choices by design.🤗

 

It's the first time in my life I can see a router without a wifi channel selection. I think it's the only sample in the galaxy...  just like a car without a gear lever.

 

I have many problem with that because:

1) The automatic choise is rubbish. E.g.: the 2.4GHz is now on channel 11 and that is the busiest (I have other 5 neighbours on the same channel, one of which at -63DB. Channel. Other channels are EMPTY! 🤣)

2) I would prefer channel 1 to gain something through the wall (lower frequencies penetrate walls better)

3) On the 5GHz the router has got channel 64 that is the UNII-2 side of the spectrum, and some devices RTX cannot reach such fq, so I have some devices that only connect at 2.4GHz (including the TV at 3m from the router that was on 5GHz few days ago with the Talktalk router).

4) By the way, since the 5GHz is completely empty here, I would choose the first channels that have a better range, not even thinking about the UNII-2 high channels.

 

So, so far... so bad! 😥

View more options
_rik_
4: Newbie

I've had a look at the source code of the page wifi->settings.

 

There are 3 hidden fields:

 

<div class=" vdf-row hide" id="wifiset-lowband-bg">
<div class="vdf-row hide" id="periodic-high-scan">
<div class="vdf-row hide" id="wifisel-auto-mode-wifiHigh">

 

Removing the class "hide" I can see them in the GUI.

 

 

Screenshot at 2021-03-01 08-38-57.png

 

In the screenshot above I've already set "Compatibility" mode. Such input select is a field containing these 2 values

<option value="36 40 44 48 52 56 60 64 100 104 108 112 132 136 140">All Channels</option>
<option value="36 40 44 48">Compatibility</option>

The default value is "All channels" and it means it uses UNII-1 and UNII-2 bands. The feature that interests me just "Compatibility"  whose description can be read from the red box and also in the value of the field itself:it limits to channel 36 to 48 (UNII-1 band).

 

Sending such value I can see the json reply saying "Success". So the router receives the new value but.... unfortunately it actually does nothing, so I suppose they have disable the use of it server side (server=the action of ngix server inside the router when it receives this value).

 

So, nothing to do.

I cannot use 5GHz with some devices because of this stupid choice of removing the compatibility setting. I mean... I'm not asking much... I don't even ask for setting the channels, but at least the band!!!! Even routers that cost 10 pounds have the channel selection!☹️

View more options
Cynric
12: Established

Not to mention dodgy Javascript hiding frequency selection.

View more options
_rik_
4: Newbie

I've also played a bit with the javascript script. For example here

var dfsEnable = "36 40 44 48 52 56 60 64 100 104 108 112 132 136 140";
var dfsDisable = "36 40 44 48";

I've set the dfsEnable = dfsDisable just to remove the choice of the high band.

However the JS is mainly for the frontend choices, enable/disable, etc. E.g. this is the bit where it initially hides the interesting fields adding the class "hide" accordingly to the memorized settings:

$(document).on("change", "#wifiset-sel-lowmode", function(){
    if (this.value == 'bg') {
      $("#wifiset-lowband-bgn-bg").addClass("hide");
      $("#wifiset-lowband-bg").removeClass("hide");
      $("#wifiset-sel-lowband option:selected").val("20");
    }
    else {
      $("#wifiset-lowband-bgn-bg").removeClass("hide");
      $("#wifiset-lowband-bg").addClass("hide");
    }
  });

But that's a "surplus"... I mean, I've already managed to send the value of the field "Compatibility" with "success" reply, and that's what matter.... but unfortunately they have disable something in the backend and that cannot be modifed.

 

At this point I can say we have only 4 options:

1) Suck it up and go on this way. The wifi could be turned off and another device used for wifi.

2) Complaining about this stupid decision and hope for the best. I would be OK with this router if they only let me see the 5Ghz in compatibility mode. Changing channel manually would be even better though.

3) Ask for the source code and modify it by ourselves (it's all GPL so they are obliged by law)

4) Trash everything, and use a decent router or, even better, a modem (Draytek Vigor 130 would do, or an old HG612) + a wifi router. With 100 pounds we can have a far better hardware/software/speed. This router in my case sync at 39 while an old ECI modem sync at 42.

View more options