main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

ICAP protocol error - Vodafone broadband

2: Seeker

Didn't get any response over networking section, will try my luck here.


Only joined Vodafone broadband yesterday and immediatelly started getting constant error whenever I am trying to view images on I turned my content restrictions off, I even contacted support who reapplied it, however I still keep getting this, I can by pass it by keep hitting refresh and eventually it goes to site, but that is very annoying to say the least. This is something to do with Vodafones ICAP (look at the bottom - (squid) ) not allowing a very popular image sharing site to display. Can anyone please advise what to do? I am using Chrome.


Also I had to add imgur to exception in Chrome as the vodafone was not approving of its certificate (this was not the case on Monday when I was still using BT)


Here is what I get:


ERROR The requested URL could not be retrieved

The following error was encountered while trying to retrieve the URL:

ICAP protocol error.

The system returned: [No Error]

This means that some aspect of the ICAP communication failed.

Some possible problems are:

  • The ICAP server is not reachable.

  • An Illegal response was received from the ICAP server.

Generated Wed, 12 Oct 2016 18:37:15 GMT by (squid)

View more options
Moderator (Retired)

Hello @JayJay007


This sounds very odd. 


I'm afraid the only way to have this looked into is to respeak with the Technical Team by calling 08080 034 515 and we will look into your settings to diagnose the issue. 



View more options
9: Established

Sorry to bump an oldie but I'm now getting this for


Did you resolve or move provider 😂

View more options

Hey @jamsterdm, digitalspy should be ok, so i'm surprised you're having an issue with that site.

What's actually happening, is it just the pictures that aren't loading, or are there issues with the full page.



View more options
2: Seeker

I am having this problem to with alsorts of websites including disqus, it seems to be websites i have to securly sign into.  I tick the make exception box and i can see some of it but not all of will load

View more options
1: Seeker

I am seeing the same error with Imgur website. Any help would be much appreciated. Thank you

View more options

Hey all, you'll need to change the DNS settings to manual in the router settings.

To access them put into your browser, then go into expert mode, internet tab, then DNS settings. Change it to manual, then use soemthing like OpenDNS for example.

Which is and

Let us know if this helps.

View more options
2: Seeker


Thank-you so much that worked perfectly

You are a superstar

Merry Christmas

View more options
2: Seeker

Hi Cromer

I got a reply from MarkF a moderator just above and it worked perfectly for me

View more options
1: Seeker

Cheers Mr. Moderator, changing the DNS servers worked for me too!


Thank you very much!

View more options