main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

London Underground WiFI

2: Seeker

Hello 

 

I'm a pay monthly customer with an unlocked iPhone XS Max. I've had no problems with the London Underground Wifi until I switched the sim out of my phone while I was out the country. Since I've been back in the UK and put the Vodafone sim back in, I keep getting the same message saying I'm a pay as you go customer and to buy a data bundle. 

 

I'm on the lasetst IOS and the lasted WAP profile has been send to my phone, and it's made no differance. I appear  to be going around in circles on the telephone with nobody able to sort the problem out.  

 

Please help!

View more options
11 REPLIES
Moderator

@music1210 It may be that your network settings may need to be reset after returning back to the UK. If your mobile data and APN settings are set up as a Pay monthly customer, we'd advise resetting your network settings to refresh these. Please be aware when doing this that you'll lose any saved passwords that are stored in your phone for Wi-Fi. 

To do this, please go to Settings, General, Reset, and tap 'Reset Network Settings'. Please let me know if you're then able to log in with your My Vodafone username and password. If not, we'll be happy to help further.

View more options
2: Seeker

Please let us know if you did that, and if you managed to get access to your old passwords through iCloud.

View more options
2: Seeker

Hello. Yeah already tried that..... it didn’t work...

View more options
2: Seeker

Hello. Yeah I’ve tried that and it’s not fixed it. 

View more options
Moderator

I'm sorry the advice offered by @Natasha hasn't helped @music1210. So we can take a further look into this, please get in touch through the link in the private message I've sent.

View more options
2: Seeker

Is there any reason why the following thread was archived?

 

https://forum.vodafone.co.uk/t5/Archive/London-Underground-WiFI/m-p/2621568#M49203

 

I still have this issue unresolved without contact for over a week now.  I had another user contact me asking why that thread had been archived because they still have the same problem.

 

I am asking here because emails go unanswered.  I am not going to stop until I am comfortable that you are taking this issue seriously.  I have an outstanding complaint on this.

View more options
Moderator

@JGWHITE3 - Thanks for flagging this to us. I’ve moved it from the archived section. I’m sorry it’s still ongoing and please don’t feel like we’re not taking you seriously.

Since we last replied here, I can see we've now emailed you. Please reply back to it.

View more options
2: Seeker

Thanks Gemma.  Appreciate the response.

 

The last email I received was on the 1st Feb saying that I needed to confirm an SMS code sent to my mobile, but I didn't receive one.

 

I also received another SMS from the Vodafone Customer Relations Team at 9pm last night saying they would call me in 30 minutes, but I didn't receive any calls.

 

I'm really at a loss as to what I can do from here.  

View more options
Moderator

@JGWHITE3 Following the email received on 01 February, have you had further communication with ourselves to explain you didn't receive a code via SMS? If not, please can you provide your email reference number so we can chase a reply for you? 

View more options
2: Seeker

Hi Josh,

 

I replied yesterday but haven't heard back. 

 

Reference number is 

EFT195 [#20312813]

 

Thanks.

View more options
Moderator
Moderator

Thanks for confirming your reference back to us @JGWHITE3. I'm sorry for the delay in our response and any inconvenience that's been caused by this. A member of our team will be in touch with your shortly, I appreciate your continued patience. 

View more options